Build #7 for hecc-0.4

[all reports]

Package hecc-0.4
Install DependencyFailed hF2-0.2
Docs NotTried
Tests NotTried
Time submitted 2016-12-22 18:35:22.309266 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, cereal-0.5.4.0, crypto-api-0.13.2, hF2-0.2
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring cereal-0.5.4.0...
Configuring entropy-0.3.7...
Building cereal-0.5.4.0...
Building entropy-0.3.7...
Installed entropy-0.3.7
Configuring primitive-0.6.1.0...
Configuring transformers-compat-0.5.1.4...
Installed cereal-0.5.4.0
Building primitive-0.6.1.0...
Building transformers-compat-0.5.1.4...
Installed transformers-compat-0.5.1.4
Configuring tagged-0.8.5...
Building tagged-0.8.5...
Installed primitive-0.6.1.0
Configuring vector-0.11.0.0...
Building vector-0.11.0.0...
Installed tagged-0.8.5
Configuring crypto-api-0.13.2...
Building crypto-api-0.13.2...
Installed crypto-api-0.13.2
Installed vector-0.11.0.0
Configuring hF2-0.2...
Building hF2-0.2...
Failed to install hF2-0.2
Build log ( /home/builder/.cabal/logs/hF2-0.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-15837/hF2-0.2'
Configuring hF2-0.2...
Building hF2-0.2...
Preprocessing library hF2-0.2...
[1 of 1] Compiling Data.F2          ( src/Data/F2.hs, dist/build/Data/F2.o )

src/Data/F2.hs:33:1: warning: [-Wunused-imports]
    The qualified import of ‘P.div, P.even, P.mod, P.odd’
    from module ‘Prelude’ is redundant

src/Data/F2.hs:46:14: warning: [-Wdeprecations]
    In the use of ‘bitSize’ (imported from Data.Bits):
    Deprecated: "Use 'bitSizeMaybe' or 'finiteBitSize' instead"

src/Data/F2.hs:83:10: warning: [-Wmissing-methods]
    • No explicit implementation for
        either ‘negate’ or ‘-’
    • In the instance declaration for ‘Num F2’

src/Data/F2.hs:112:10: warning: [-Wmissing-methods]
    • No explicit implementation for
        ‘Data.Bits.bitSizeMaybe’
    • In the instance declaration for ‘B.Bits F2’
You are using an unsupported version of LLVM!
Currently only 3.7 is supported.
We will try though...
opt: /tmp/ghc17363_0/ghc_2.ll:7:6: error: expected type
!0 = !{!"top", null}
     ^
`opt' failed in phase `LLVM Optimiser'. (Exit code: 1)
cabal: Leaving directory '/tmp/cabal-tmp-15837/hF2-0.2'
cabal: Error: some packages failed to install:
hF2-0.2 failed during the building phase. The exception was:
ExitFailure 1
hecc-0.4 depends on hF2-0.2 which failed to install.