Build #3 for hgis-1.0.0.1

[all reports]

Package hgis-1.0.0.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-07-03 13:34:25.877284726 UTC
Compiler ghc-8.4.3
OS linux
Arch x86_64
Dependencies Chart-1.9, Chart-cairo-1.9, ansi-wl-pprint-0.6.8.2, base-4.11.1.0, binary-0.8.5.1, bytestring-0.10.8.2, colour-2.3.4, composition-prelude-1.5.0.6, data-binary-ieee754-0.4.4, data-default-0.7.1.1, directory-1.3.1.5, filepath-1.4.2, lens-4.16.1, monad-loops-0.4.3
Flags cairo -development -diagrams

Build log

[view raw]

Resolving dependencies...
Configuring StateVar-1.1.1.0...
Configuring base-orphans-0.8...
Building StateVar-1.1.1.0...
Building base-orphans-0.8...
Installed StateVar-1.1.1.0
Configuring cabal-doctest-1.0.6...
Building cabal-doctest-1.0.6...
Installed base-orphans-0.8
Configuring call-stack-0.1.0...
Building call-stack-0.1.0...
Installed cabal-doctest-1.0.6
Configuring colour-2.3.4...
Building colour-2.3.4...
Installed call-stack-0.1.0
Configuring composition-prelude-1.5.0.6...
Building composition-prelude-1.5.0.6...
Installed composition-prelude-1.5.0.6
Configuring data-binary-ieee754-0.4.4...
Building data-binary-ieee754-0.4.4...
Installed data-binary-ieee754-0.4.4
Configuring data-default-class-0.1.2.0...
Building data-default-class-0.1.2.0...
Installed data-default-class-0.1.2.0
Configuring dlist-0.8.0.4...
Installed colour-2.3.4
Configuring hashable-1.2.7.0...
Building dlist-0.8.0.4...
Building hashable-1.2.7.0...
Installed dlist-0.8.0.4
Configuring monad-loops-0.4.3...
Building monad-loops-0.4.3...
Installed hashable-1.2.7.0
Configuring old-locale-1.0.0.7...
Building old-locale-1.0.0.7...
Installed monad-loops-0.4.3
Configuring parallel-3.2.1.1...
Building parallel-3.2.1.1...
Installed old-locale-1.0.0.7
Configuring primitive-0.6.4.0...
Building primitive-0.6.4.0...
Installed parallel-3.2.1.1
Configuring random-1.1...
Building random-1.1...
Installed random-1.1
Configuring reflection-2.1.4...
Building reflection-2.1.4...
Installed reflection-2.1.4
Configuring semigroups-0.18.5...
Installed primitive-0.6.4.0
Configuring tagged-0.8.6...
Building semigroups-0.18.5...
Building tagged-0.8.6...
Installed semigroups-0.18.5
Configuring th-abstraction-0.2.8.0...
Building th-abstraction-0.2.8.0...
Installed tagged-0.8.6
Configuring transformers-compat-0.6.2...
Building transformers-compat-0.6.2...
Installed th-abstraction-0.2.8.0
Configuring utf8-string-1.0.1.1...
Building utf8-string-1.0.1.1...
Installed transformers-compat-0.6.2
Configuring void-0.7.2...
Building void-0.7.2...
Installed void-0.7.2
Configuring contravariant-1.5...
Building contravariant-1.5...
Installed utf8-string-1.0.1.1
Configuring data-default-instances-containers-0.0.1...
Building data-default-instances-containers-0.0.1...
Installed data-default-instances-containers-0.0.1
Configuring ansi-terminal-0.8.0.4...
Installed contravariant-1.5
Configuring data-default-instances-dlist-0.0.1...
Building ansi-terminal-0.8.0.4...
Building data-default-instances-dlist-0.0.1...
Installed data-default-instances-dlist-0.0.1
Configuring unordered-containers-0.2.9.0...
Building unordered-containers-0.2.9.0...
Installed ansi-terminal-0.8.0.4
Configuring data-default-instances-old-locale-0.0.1...
Building data-default-instances-old-locale-0.0.1...
Installed data-default-instances-old-locale-0.0.1
Configuring operational-0.2.3.5...
Building operational-0.2.3.5...
Installed operational-0.2.3.5
Configuring vector-0.12.0.1...
Building vector-0.12.0.1...
Installed unordered-containers-0.2.9.0
Configuring distributive-0.6...
Building distributive-0.6...
Installed distributive-0.6
Configuring transformers-base-0.4.5.2...
Building transformers-base-0.4.5.2...
Installed transformers-base-0.4.5.2
Configuring exceptions-0.10.0...
Building exceptions-0.10.0...
Installed exceptions-0.10.0
Configuring ansi-wl-pprint-0.6.8.2...
Building ansi-wl-pprint-0.6.8.2...
Installed ansi-wl-pprint-0.6.8.2
Configuring data-default-0.7.1.1...
Building data-default-0.7.1.1...
Installed data-default-0.7.1.1
Configuring comonad-5.0.4...
Building comonad-5.0.4...
Installed comonad-5.0.4
Configuring bifunctors-5.5.2...
Building bifunctors-5.5.2...
Installed vector-0.12.0.1
Configuring hashtables-1.2.3.1...
Building hashtables-1.2.3.1...
Installed bifunctors-5.5.2
Configuring semigroupoids-5.3.1...
Building semigroupoids-5.3.1...
Installed hashtables-1.2.3.1
Configuring profunctors-5.3...
Building profunctors-5.3...
Installed semigroupoids-5.3.1
Configuring gtk2hs-buildtools-0.13.4.0...
Installed profunctors-5.3
Configuring invariant-0.5...
Building gtk2hs-buildtools-0.13.4.0...
Building invariant-0.5...
Installed invariant-0.5
Configuring free-5.1...
Building free-5.1...
Installed free-5.1
Configuring adjunctions-4.4...
Building adjunctions-4.4...
Installed adjunctions-4.4
Configuring kan-extensions-5.2...
Building kan-extensions-5.2...
Installed kan-extensions-5.2
Configuring lens-4.16.1...
Building lens-4.16.1...
Installed gtk2hs-buildtools-0.13.4.0
Configuring cairo-0.13.5.0...
Building cairo-0.13.5.0...
Installed cairo-0.13.5.0
Installed lens-4.16.1
Configuring Chart-1.9...
Building Chart-1.9...
Installed Chart-1.9
Configuring Chart-cairo-1.9...
Building Chart-cairo-1.9...
Installed Chart-cairo-1.9
Configuring hgis-1.0.0.1...
Building hgis-1.0.0.1...
Failed to install hgis-1.0.0.1
Build log ( /home/builder/.cabal/logs/ghc-8.4.3/hgis-1.0.0.1-HvuvJHsKlwu9qB0kBMXpeV.log ):
cabal: Entering directory '/tmp/cabal-tmp-16422/hgis-1.0.0.1'
Configuring hgis-1.0.0.1...
Preprocessing library for hgis-1.0.0.1..
Building library for hgis-1.0.0.1..

<no location info>: warning: [-Wmissing-home-modules]
    These modules are needed for compilation but not listed in your .cabal file's other-modules: GIS.Graphics.PlotSVG
[ 1 of 16] Compiling GIS.Types        ( src/GIS/Types.hs, dist/build/GIS/Types.o )
[ 2 of 16] Compiling GIS.Math.Utils   ( src/GIS/Math/Utils.hs, dist/build/GIS/Math/Utils.o )
[ 3 of 16] Compiling GIS.Graphics.Types ( src/GIS/Graphics/Types.hs, dist/build/GIS/Graphics/Types.o )
[ 4 of 16] Compiling GIS.Math.Projections ( src/GIS/Math/Projections.hs, dist/build/GIS/Math/Projections.o )
[ 5 of 16] Compiling GIS.Math.Spherical ( src/GIS/Math/Spherical.hs, dist/build/GIS/Math/Spherical.o )
[ 6 of 16] Compiling GIS.Utils        ( src/GIS/Utils.hs, dist/build/GIS/Utils.o )
[ 7 of 16] Compiling GIS.Graphics.Plot ( src/GIS/Graphics/Plot.hs, dist/build/GIS/Graphics/Plot.o )
[ 8 of 16] Compiling GIS.Graphics.PlotSVG ( src/GIS/Graphics/PlotSVG.hs, dist/build/GIS/Graphics/PlotSVG.o )

src/GIS/Graphics/PlotSVG.hs:12:1: error:
    Could not find module ‘Graphics.Rendering.Chart.Backend.Diagrams’
    Perhaps you meant
      Graphics.Rendering.Chart.Backend.Cairo (from Chart-cairo-1.9)
      Graphics.Rendering.Chart.Backend.Types (from Chart-1.9)
      Graphics.Rendering.Chart.Backend.Impl (from Chart-1.9)
    Use -v to see a list of the files searched for.
   |
12 | import           Graphics.Rendering.Chart.Backend.Diagrams
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-16422/hgis-1.0.0.1'
cabal: Error: some packages failed to install:
hgis-1.0.0.1-HvuvJHsKlwu9qB0kBMXpeV failed during the building phase. The
exception was:
ExitFailure 1