Build #7 for hoogle-4.0.0.5

[all reports]

Package hoogle-4.0.0.5
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-03 08:32:31.377462 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies array-0.5.1.1, base-4.9.0.0, bytestring-0.10.8.1, containers-0.5.7.1, directory-1.2.6.2, filepath-1.4.1.0, mtl-2.2.1, parsec-3.1.11, process-1.4.2.0, safe-0.3.10, time-1.6.0.1, uniplate-1.6.12
Flags splitbase

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Configuring safe-0.3.10...
Building safe-0.3.10...
Building mtl-2.2.1...
Installed safe-0.3.10
Configuring syb-0.6...
Building syb-0.6...
Configuring text-1.2.2.1...
Installed mtl-2.2.1
Building text-1.2.2.1...
Installed syb-0.6
Installed text-1.2.2.1
Configuring hashable-1.2.5.0...
Configuring parsec-3.1.11...
Building hashable-1.2.5.0...
Building parsec-3.1.11...
Installed hashable-1.2.5.0
Configuring unordered-containers-0.2.7.2...
Building unordered-containers-0.2.7.2...
Installed parsec-3.1.11
Installed unordered-containers-0.2.7.2
Configuring uniplate-1.6.12...
Building uniplate-1.6.12...
Installed uniplate-1.6.12
Configuring hoogle-4.0.0.5...
Building hoogle-4.0.0.5...
Failed to install hoogle-4.0.0.5
Build log ( /home/builder/.cabal/logs/hoogle-4.0.0.5.log ):
cabal: Entering directory '/tmp/cabal-tmp-18090/hoogle-4.0.0.5'
Configuring hoogle-4.0.0.5...
Building hoogle-4.0.0.5...
Preprocessing executable 'hoogle' for hoogle-4.0.0.5...
[ 1 of 77] Compiling Test.General     ( src/Test/General.hs, dist/build/hoogle/hoogle-tmp/Test/General.o )

src/Test/General.hs:11:10: error:
    • No instance for (Applicative Test)
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘Monad Test’

src/Test/General.hs:35:10: error:
    • No instance for (Applicative (List a))
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘Monad (List a)’
cabal: Leaving directory '/tmp/cabal-tmp-18090/hoogle-4.0.0.5'
cabal: Error: some packages failed to install:
hoogle-4.0.0.5 failed during the building phase. The exception was:
ExitFailure 1