Build #7 for hsSqlite3-0.0.4

[all reports]

Package hsSqlite3-0.0.4
Install DependencyFailed state-0.0.2
Docs NotTried
Tests NotTried
Time submitted 2017-01-04 01:04:06.273138 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, mtl-2.2.1, state-0.0.2, utf8-string-1.0.1.1, base-4.9.0.0, mtl-2.2.1, state-0.0.2, utf8-string-1.0.1.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring lazysmallcheck-0.6...
Configuring mtl-2.2.1...
Building lazysmallcheck-0.6...
Building mtl-2.2.1...
Installed lazysmallcheck-0.6
Configuring primitive-0.6.2.0...
Building primitive-0.6.2.0...
Configuring random-1.1...
Installed mtl-2.2.1
Building random-1.1...
Configuring utf8-string-1.0.1.1...
Installed random-1.1
Building utf8-string-1.0.1.1...
Installed primitive-0.6.2.0
Configuring tf-random-0.5...
Building tf-random-0.5...
Installed utf8-string-1.0.1.1
Installed tf-random-0.5
Configuring QuickCheck-2.9.2...
Building QuickCheck-2.9.2...
Installed QuickCheck-2.9.2
Configuring Stream-0.4.7.2...
Building Stream-0.4.7.2...
Installed Stream-0.4.7.2
Configuring arrows-0.4.4.1...
Building arrows-0.4.4.1...
Installed arrows-0.4.4.1
Configuring state-0.0.2...
Building state-0.0.2...
Failed to install state-0.0.2
Build log ( /home/builder/.cabal/logs/state-0.0.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-3163/state-0.0.2'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-3163/state-0.0.2/dist/setup/setup.hs, /tmp/cabal-tmp-3163/state-0.0.2/dist/setup/Main.o )
Linking /tmp/cabal-tmp-3163/state-0.0.2/dist/setup/setup ...
Warning: defaultUserHooks in Setup script is deprecated.
Configuring state-0.0.2...
Warning: No 'build-type' specified. If you do not need a custom Setup.hs or
./configure script then use 'build-type: Simple'.
Warning: The 'license-file' field refers to the file 'COPYRIGHT' which does
not exist.
Building state-0.0.2...
Preprocessing library state-0.0.2...

src/Data/State.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

src/Data/State.hs:1:12: warning:
    -farrows is deprecated: use -XArrows or pragma {-# LANGUAGE Arrows #-} instead
[1 of 1] Compiling Data.State       ( src/Data/State.hs, dist/build/Data/State.o )
Running Haddock for state-0.0.2...
Running hscolour for state-0.0.2...
Preprocessing library state-0.0.2...
Preprocessing library state-0.0.2...

src/Data/State.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

src/Data/State.hs:1:12: warning:
    -farrows is deprecated: use -XArrows or pragma {-# LANGUAGE Arrows #-} instead
Haddock coverage:
   0% (  0 /  9) in 'Data.State'
  Missing documentation for:
    Module header
    LocalState (src/Data/State.hs:10)
     (src/Data/State.hs:14)
    DynamicState (src/Data/State.hs:18)
    ZeroState (src/Data/State.hs:22)
    get (src/Data/State.hs:25)
    put (src/Data/State.hs:28)
    fetch (src/Data/State.hs:33)
    store (src/Data/State.hs:36)
Documentation created: dist/doc/html/state/index.html,
dist/doc/html/state/state.txt
Creating package registration file:
/tmp/pkgConf-state-0.017345751981973594324.2
COPYRIGHT: copyFile: does not exist (No such file or directory)
cabal: Leaving directory '/tmp/cabal-tmp-3163/state-0.0.2'
cabal: Error: some packages failed to install:
hsSqlite3-0.0.4 depends on state-0.0.2 which failed to install.
state-0.0.2 failed during the final install step. The exception was:
ExitFailure 1