hspec: preferred and deprecated versions

Preferred and deprecated versions can be used to influence Cabal's decisions about which versions of hspec to install. If a range of versions is preferred, it means that the installer won't install a non-preferred package version unless it is explicitly specified or if it's the only choice the installer has. Deprecating a version adds a range which excludes just that version. All of this information is collected in the preferred-versions file that's included in the index tarball. [maintainers: edit]

If all the available versions of a package are non-preferred or deprecated, cabal-install will treat this the same as if none of them are. This feature doesn't affect whether or not to install a package, only for selecting versions after a given package has decided to be installed. Entire-package deprecation is also available, but it's separate from preferred versions.

Stored information

Preferred versions for hspec:

Explicitly deprecated versions for hspec include: 1.8.0

The version range given to this package, therefore, is >=1.8.1

Versions affected

Blue versions are normal versions. Green are those out of any preferred version ranges. Gray are deprecated.

0.2.0, 0.3.0, 0.4.3, 0.5.0, 0.6.0, 0.6.1, 0.8, 0.8.1, 0.9.0, 0.9.1, 0.9.1.1, 0.9.2, 0.9.2.1, 0.9.2.2, 1.0.0, 1.0.0.1, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.2.0, 1.2.0.1, 1.3.0, 1.3.0.1, 1.3.0.2, 1.4.0, 1.4.0.1, 1.4.1, 1.4.1.1, 1.4.2, 1.4.2.1, 1.4.2.2, 1.4.2.3, 1.4.3, 1.4.4, 1.4.5, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.7.2.1, 1.8.0, 1.8.1, 1.8.1.1, 1.8.2, 1.8.3, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.10.0, 1.10.0.1, 1.11.0, 1.11.1, 1.11.2, 1.11.3, 1.11.4