Build #3 for hstzaar-0.9.4

[all reports]

Package hstzaar-0.9.4
Install DependencyFailed glib-0.12.5.4
Docs NotTried
Tests NotTried
Time submitted 2016-11-25 04:45:44.474847 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies QuickCheck-2.9.2, array-0.5.1.1, base-4.9.0.0, cairo-0.12.5.3, containers-0.5.7.1, directory-1.2.6.2, filepath-1.4.1.0, glade-0.12.5.0, gtk-0.12.5.7, hashable-1.2.4.0, mtl-2.2.1, parallel-3.2.1.0, random-1.1, unordered-containers-0.2.7.1, vector-0.11.0.0, xml-1.3.14
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Configuring parallel-3.2.1.0...
Building parallel-3.2.1.0...
Building mtl-2.2.1...
Installed parallel-3.2.1.0
Configuring primitive-0.6.1.0...
Building primitive-0.6.1.0...
Configuring random-1.1...
Installed mtl-2.2.1
Building random-1.1...
Configuring text-1.2.2.1...
Installed primitive-0.6.1.0
Configuring utf8-string-0.3.7...
Installed random-1.1
Building text-1.2.2.1...
Building utf8-string-0.3.7...
Installed utf8-string-0.3.7
Configuring vector-0.11.0.0...
Building vector-0.11.0.0...
Configuring tf-random-0.5...
Installed text-1.2.2.1
Building tf-random-0.5...
Configuring glib-0.12.5.4...
Installed tf-random-0.5
Configuring cairo-0.12.5.3...
Failed to install glib-0.12.5.4
Build log ( /home/builder/.cabal/logs/glib-0.12.5.4.log ):
cabal: Entering directory '/tmp/cabal-tmp-8475/glib-0.12.5.4'
cabal: Leaving directory '/tmp/cabal-tmp-8475/glib-0.12.5.4'
Failed to install cairo-0.12.5.3
Build log ( /home/builder/.cabal/logs/cairo-0.12.5.3.log ):
cabal: Entering directory '/tmp/cabal-tmp-8474/cairo-0.12.5.3'
cabal: Leaving directory '/tmp/cabal-tmp-8474/cairo-0.12.5.3'
Configuring xml-1.3.14...
Building xml-1.3.14...
Configuring hashable-1.2.4.0...
Installed xml-1.3.14
Building hashable-1.2.4.0...
Configuring QuickCheck-2.9.2...
Installed vector-0.11.0.0
Installed hashable-1.2.4.0
Configuring unordered-containers-0.2.7.1...
Building QuickCheck-2.9.2...
Building unordered-containers-0.2.7.1...
Installed unordered-containers-0.2.7.1
Installed QuickCheck-2.9.2
cabal: Error: some packages failed to install:
cairo-0.12.5.3 failed during the configure step. The exception was:
user error ('/opt/ghc/8.0.2/bin/ghc' exited with an error:

/tmp/cabal-tmp-8474/cairo-0.12.5.3/SetupWrapper.hs:60:49: error:
Ambiguous occurrence ‘exeExtension’
It could refer to either ‘Distribution.Simple.BuildPaths.exeExtension’,
imported from ‘Distribution.Simple.BuildPaths’ at
/tmp/cabal-tmp-8474/cairo-0.12.5.3/SetupWrapper.hs:11:40-51
or ‘System.Directory.exeExtension’,
imported from ‘System.Directory’ at
/tmp/cabal-tmp-8474/cairo-0.12.5.3/SetupWrapper.hs:23:1-23
(and originally defined in
‘directory-1.2.6.2:System.Directory.Internal.Config’)

/tmp/cabal-tmp-8474/cairo-0.12.5.3/SetupWrapper.hs:91:17: error:
Ambiguous occurrence ‘die’
It could refer to either ‘Distribution.Simple.Utils.die’,
imported from ‘Distribution.Simple.Utils’ at
/tmp/cabal-tmp-8474/cairo-0.12.5.3/SetupWrapper.hs:8:1-32
or ‘System.Exit.die’,
imported from ‘System.Exit’ at
/tmp/cabal-tmp-8474/cairo-0.12.5.3/SetupWrapper.hs:21:1-18
)
gio-0.12.5.3 depends on glib-0.12.5.4 which failed to install.
glade-0.12.5.0 depends on glib-0.12.5.4 which failed to install.
glib-0.12.5.4 failed during the configure step. The exception was:
user error ('/opt/ghc/8.0.2/bin/ghc' exited with an error:

/tmp/cabal-tmp-8475/glib-0.12.5.4/SetupWrapper.hs:60:49: error:
Ambiguous occurrence ‘exeExtension’
It could refer to either ‘Distribution.Simple.BuildPaths.exeExtension’,
imported from ‘Distribution.Simple.BuildPaths’ at
/tmp/cabal-tmp-8475/glib-0.12.5.4/SetupWrapper.hs:11:40-51
or ‘System.Directory.exeExtension’,
imported from ‘System.Directory’ at
/tmp/cabal-tmp-8475/glib-0.12.5.4/SetupWrapper.hs:23:1-23
(and originally defined in
‘directory-1.2.6.2:System.Directory.Internal.Config’)

/tmp/cabal-tmp-8475/glib-0.12.5.4/SetupWrapper.hs:91:17: error:
Ambiguous occurrence ‘die’
It could refer to either ‘Distribution.Simple.Utils.die’,
imported from ‘Distribution.Simple.Utils’ at
/tmp/cabal-tmp-8475/glib-0.12.5.4/SetupWrapper.hs:8:1-32
or ‘System.Exit.die’,
imported from ‘System.Exit’ at
/tmp/cabal-tmp-8475/glib-0.12.5.4/SetupWrapper.hs:21:1-18
)
gtk-0.12.5.7 depends on glib-0.12.5.4 which failed to install.
hstzaar-0.9.4 depends on glib-0.12.5.4 which failed to install.
pango-0.12.5.3 depends on glib-0.12.5.4 which failed to install.