Build #8 for hsubconvert-0.0.2

[all reports]

Package hsubconvert-0.0.2
Install DependencyFailed svndump-0.4.5
Docs NotTried
Tests NotTried
Time submitted 2016-12-23 17:59:08.433601 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, bytestring-0.10.8.1, cmdargs-0.10.14, general-prelude-0.1.2, gitlib-3.1.1, hslogger-1.2.10, lens-4.15.1, mtl-2.2.1, parallel-io-0.3.3, regex-posix-0.95.2, stringable-0.1.3, svndump-0.4.5, system-fileio-0.3.16.3, system-filepath-0.4.13.4, text-1.2.2.1, text-format-0.3.1.1, time-1.6.0.1, transformers-0.5.2.0, unix-2.7.2.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring base-orphans-0.5.4...
Configuring base16-bytestring-0.1.1.6...
Building base-orphans-0.5.4...
Building base16-bytestring-0.1.1.6...
Installed base-orphans-0.5.4
Configuring base64-bytestring-1.0.0.1...
Configuring cmdargs-0.10.14...
Installed base16-bytestring-0.1.1.6
Building base64-bytestring-1.0.0.1...
Building cmdargs-0.10.14...
Configuring extensible-exceptions-0.1.1.4...
Installed base64-bytestring-1.0.0.1
Building extensible-exceptions-0.1.1.4...
Configuring mtl-2.2.1...
Installed extensible-exceptions-0.1.1.4
Building mtl-2.2.1...
Configuring network-2.6.3.1...
Installed mtl-2.2.1
Building network-2.6.3.1...
Configuring old-locale-1.0.0.7...
Installed cmdargs-0.10.14
Configuring parallel-3.2.1.0...
Installed network-2.6.3.1
Building old-locale-1.0.0.7...
Building parallel-3.2.1.0...
Configuring pointless-fun-1.1.0.6...
Installed old-locale-1.0.0.7
Building pointless-fun-1.1.0.6...
Configuring primitive-0.6.1.0...
Installed parallel-3.2.1.0
Configuring random-1.1...
Installed pointless-fun-1.1.0.6
Building primitive-0.6.1.0...
Building random-1.1...
Configuring prelude-extras-0.4.0.3...
Installed random-1.1
Building prelude-extras-0.4.0.3...
Configuring reflection-2.1.2...
Installed primitive-0.6.1.0
Building reflection-2.1.2...
Configuring semigroups-0.18.2...
Installed prelude-extras-0.4.0.3
Building semigroups-0.18.2...
Configuring stm-2.4.4.1...
Installed semigroups-0.18.2
Building stm-2.4.4.1...
Configuring strict-0.3.2...
Installed reflection-2.1.2
Building strict-0.3.2...
Configuring split-0.2.3.1...
Installed strict-0.3.2
Configuring transformers-compat-0.5.1.4...
Installed stm-2.4.4.1
Building split-0.2.3.1...
Building transformers-compat-0.5.1.4...
Configuring unix-compat-0.4.3.1...
Installed split-0.2.3.1
Configuring text-1.2.2.1...
Installed transformers-compat-0.5.1.4
Building unix-compat-0.4.3.1...
Building text-1.2.2.1...
Configuring zlib-0.6.1.2...
Installed unix-compat-0.4.3.1
Building zlib-0.6.1.2...
Installed zlib-0.6.1.2
Configuring regex-base-0.93.2...
Building regex-base-0.93.2...
Configuring parallel-io-0.3.3...
Installed regex-base-0.93.2
Building parallel-io-0.3.3...
Configuring hslogger-1.2.10...
Installed parallel-io-0.3.3
Building hslogger-1.2.10...
Configuring StateVar-1.1.0.4...
Installed text-1.2.2.1
Building StateVar-1.1.0.4...
Configuring exceptions-0.8.3...
Installed hslogger-1.2.10
Building exceptions-0.8.3...
Configuring mmorph-1.0.9...
Installed StateVar-1.1.0.4
Building mmorph-1.0.9...
Configuring async-2.1.1...
Installed exceptions-0.8.3
Building async-2.1.1...
Configuring vector-0.11.0.0...
Installed mmorph-1.0.9
Building vector-0.11.0.0...
Configuring transformers-base-0.4.4...
Installed async-2.1.1
Building transformers-base-0.4.4...
Configuring tagged-0.8.5...
Installed transformers-base-0.4.4
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring regex-posix-0.95.2...
Building regex-posix-0.95.2...
Installed regex-posix-0.95.2
Configuring blaze-builder-0.4.0.2...
Building blaze-builder-0.4.0.2...
Configuring hashable-1.2.4.0...
Installed blaze-builder-0.4.0.2
Building hashable-1.2.4.0...
Configuring double-conversion-2.0.2.0...
Installed hashable-1.2.4.0
Building double-conversion-2.0.2.0...
Configuring system-filepath-0.4.13.4...
Installed vector-0.11.0.0
Configuring monad-control-1.0.1.0...
Installed double-conversion-2.0.2.0
Building monad-control-1.0.1.0...
Configuring distributive-0.5.0.2...
Installed monad-control-1.0.1.0
Building system-filepath-0.4.13.4...
Building distributive-0.5.0.2...
Installed system-filepath-0.4.13.4
Configuring constraints-0.8...
Building constraints-0.8...
Configuring streaming-commons-0.1.16...
Installed distributive-0.5.0.2
Building streaming-commons-0.1.16...
Configuring unordered-containers-0.2.7.1...
Installed constraints-0.8
Building unordered-containers-0.2.7.1...
Configuring void-0.7.1...
Installed streaming-commons-0.1.16
Building void-0.7.1...
Configuring scientific-0.3.4.9...
Installed void-0.7.1
Building scientific-0.3.4.9...
Configuring chunked-data-0.3.0...
Installed unordered-containers-0.2.7.1
Building chunked-data-0.3.0...
Configuring mwc-random-0.13.5.0...
Installed scientific-0.3.4.9
Building mwc-random-0.13.5.0...
Configuring text-format-0.3.1.1...
Installed chunked-data-0.3.0
Building text-format-0.3.1.1...
Configuring vector-algorithms-0.7.0.1...
Installed mwc-random-0.13.5.0
Configuring stringable-0.1.3...
Installed text-format-0.3.1.1
Building vector-algorithms-0.7.0.1...
Building stringable-0.1.3...
Configuring system-fileio-0.3.16.3...
Installed stringable-0.1.3
Building system-fileio-0.3.16.3...
Configuring lifted-base-0.2.3.8...
Installed system-fileio-0.3.16.3
Building lifted-base-0.2.3.8...
Installed vector-algorithms-0.7.0.1
Configuring contravariant-1.4...
Building contravariant-1.4...
Configuring mono-traversable-1.0.1...
Installed lifted-base-0.2.3.8
Building mono-traversable-1.0.1...
Configuring attoparsec-0.13.1.0...
Installed contravariant-1.4
Building attoparsec-0.13.1.0...
Configuring resourcet-1.1.9...
Installed attoparsec-0.13.1.0
Building resourcet-1.1.9...
Configuring lifted-async-0.9.0...
Installed mono-traversable-1.0.1
Building lifted-async-0.9.0...
Configuring comonad-5...
Installed resourcet-1.1.9
Installed lifted-async-0.9.0
Configuring svndump-0.4.5...
Building svndump-0.4.5...
Configuring conduit-1.2.8...
Failed to install svndump-0.4.5
Build log ( /home/builder/.cabal/logs/svndump-0.4.5.log ):
cabal: Entering directory '/tmp/cabal-tmp-13273/svndump-0.4.5'
Configuring svndump-0.4.5...
Building svndump-0.4.5...
Preprocessing library svndump-0.4.5...
[1 of 3] Compiling Subversion.Dump.Raw ( src/Subversion/Dump/Raw.hs, dist/build/Subversion/Dump/Raw.o )

src/Subversion/Dump/Raw.hs:12:1: warning: [-Wdeprecations]
    Module ‘Data.Attoparsec.Char8’ is deprecated:
      This module will be removed in the next major release.
[2 of 3] Compiling Subversion.Dump  ( src/Subversion/Dump.hs, dist/build/Subversion/Dump.o )

src/Subversion/Dump.hs:143:25: error:
    Ambiguous occurrence ‘defaultTimeLocale’
    It could refer to either ‘Data.Time.defaultTimeLocale’,
                             imported from ‘Data.Time’ at src/Subversion/Dump.hs:22:1-26
                             (and originally defined in ‘time-1.6.0.1:Data.Time.Format.Locale’)
                          or ‘System.Locale.defaultTimeLocale’,
                             imported from ‘System.Locale’ at src/Subversion/Dump.hs:23:1-30
cabal: Leaving directory '/tmp/cabal-tmp-13273/svndump-0.4.5'
Building conduit-1.2.8...
Building comonad-5...
Installed comonad-5
Configuring bifunctors-5.4.1...
Building bifunctors-5.4.1...
Installed conduit-1.2.8
Configuring conduit-extra-1.1.15...
Building conduit-extra-1.1.15...
Installed conduit-extra-1.1.15
Configuring conduit-combinators-1.0.8.3...
Building conduit-combinators-1.0.8.3...
Installed bifunctors-5.4.1
Configuring profunctors-5.2...
Building profunctors-5.2...
Configuring semigroupoids-5.1...
Installed conduit-combinators-1.0.8.3
Configuring gitlib-3.1.1...
Installed profunctors-5.2
Building gitlib-3.1.1...
Building semigroupoids-5.1...
Installed gitlib-3.1.1
Installed semigroupoids-5.1
Configuring free-4.12.4...
Building free-4.12.4...
Installed free-4.12.4
Configuring adjunctions-4.3...
Building adjunctions-4.3...
Installed adjunctions-4.3
Configuring kan-extensions-5.0.1...
Building kan-extensions-5.0.1...
Installed kan-extensions-5.0.1
Configuring lens-4.15.1...
Building lens-4.15.1...
Installed lens-4.15.1
Configuring general-prelude-0.1.2...
Building general-prelude-0.1.2...
Failed to install general-prelude-0.1.2
Build log ( /home/builder/.cabal/logs/general-prelude-0.1.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-13271/general-prelude-0.1.2'
Configuring general-prelude-0.1.2...
Building general-prelude-0.1.2...
Preprocessing library general-prelude-0.1.2...
[1 of 1] Compiling Prelude.General  ( Prelude/General.hs, dist/build/Prelude/General.o )

Prelude/General.hs:18:5: error:
    Conflicting exports for ‘uncons’:
       ‘module Control.Lens’ exports ‘Control.Lens.uncons’
         imported from ‘Control.Lens’ at Prelude/General.hs:43:1-29
         (and originally defined in ‘Control.Lens.Cons’)
       ‘module Data.List’ exports ‘Data.List.uncons’
         imported from ‘Data.List’ at Prelude/General.hs:(59,1)-(81,41)
         (and originally defined in ‘GHC.List’)
cabal: Leaving directory '/tmp/cabal-tmp-13271/general-prelude-0.1.2'
cabal: Error: some packages failed to install:
general-prelude-0.1.2 failed during the building phase. The exception was:
ExitFailure 1
hsubconvert-0.0.2 depends on svndump-0.4.5 which failed to install.
svndump-0.4.5 failed during the building phase. The exception was:
ExitFailure 1