Build #3 for ihaskell-graphviz-0.1.0.0

[all reports]

Package ihaskell-graphviz-0.1.0.0
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2019-04-26 19:46:43.709141126 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: ihaskell-graphviz-0.1.0.0 (user goal)
[__1] trying: ihaskell-0.10.0.0 (dependency of ihaskell-graphviz)
[__2] trying: ipython-kernel-0.10.0.0 (dependency of ihaskell)
[__3] next goal: zeromq4-haskell (dependency of ipython-kernel)
[__3] rejecting: zeromq4-haskell-0.8.0, zeromq4-haskell-0.7.0,
zeromq4-haskell-0.6.7, zeromq4-haskell-0.6.6, zeromq4-haskell-0.6.5,
zeromq4-haskell-0.6.4, zeromq4-haskell-0.6.3, zeromq4-haskell-0.6.2,
zeromq4-haskell-0.6.1, zeromq4-haskell-0.6, zeromq4-haskell-0.5.1,
zeromq4-haskell-0.5, zeromq4-haskell-0.4.1, zeromq4-haskell-0.4,
zeromq4-haskell-0.3.2, zeromq4-haskell-0.3.1, zeromq4-haskell-0.3 (conflict:
pkg-config package libzmq>=4.0 && <5.0, not found in the pkg-config database)
[__3] trying: zeromq4-haskell-0.2
[__4] next goal: async (dependency of zeromq4-haskell)
[__4] rejecting: async-2.2.1, async-2.1.1.1, async-2.1.1, async-2.1.0
(conflict: zeromq4-haskell => async==2.0.*)
[__4] trying: async-2.0.2
[__5] next goal: base (dependency of ihaskell-graphviz)
[__5] rejecting: base-4.12.0.0/installed-4.1... (conflict: async => base>=4.3
&& <4.9)
[__5] rejecting: base-4.12.0.0, base-4.11.1.0, base-4.11.0.0, base-4.10.1.0,
base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0,
base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1,
base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0,
base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0,
base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from
non-upgradeable package requires installed instance)
[__5] fail (backjumping, conflict set: async, base, ihaskell-graphviz)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: async, zeromq4-haskell, ihaskell,
base, ipython-kernel, ihaskell-graphviz