Build #7 for javasf-0.1.0

[all reports]

Package javasf-0.1.0
Install DependencyFailed bindings-libzip-1.0.1
Docs NotTried
Tests NotTried
Time submitted 2016-12-15 01:53:37.744848 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, binary-0.8.3.0, bytestring-0.10.8.1, language-java-classfile-0.2.0
Flags small_base

Build log

[view raw]

Resolving dependencies...
Configuring bindings-DSL-1.0.23...
Configuring data-binary-ieee754-0.4.4...
Building bindings-DSL-1.0.23...
Building data-binary-ieee754-0.4.4...
Installed bindings-DSL-1.0.23
Configuring data-flags-0.0.3.2...
Configuring mtl-2.2.1...
Installed data-binary-ieee754-0.4.4
Building data-flags-0.0.3.2...
Building mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Installed mtl-2.2.1
Configuring utf8-string-1.0.1.1...
Installed data-flags-0.0.3.2
Building old-locale-1.0.0.7...
Building utf8-string-1.0.1.1...
Configuring text-1.2.2.1...
Installed old-locale-1.0.0.7
Building text-1.2.2.1...
Configuring bindings-libzip-1.0.1...
Installed utf8-string-1.0.1.1
Configuring old-time-1.1.0.3...
Failed to install bindings-libzip-1.0.1
Build log ( /home/builder/.cabal/logs/bindings-libzip-1.0.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-12613/bindings-libzip-1.0.1'
Configuring bindings-libzip-1.0.1...
cabal: Missing dependency on a foreign library:
* Missing (or bad) header file: zip.h
* Missing C library: zip
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
If the header file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.
cabal: Leaving directory '/tmp/cabal-tmp-12613/bindings-libzip-1.0.1'
Building old-time-1.1.0.3...
Installed old-time-1.1.0.3
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Configuring polyparse-1.12...
Building polyparse-1.12...
Building parsec-3.1.11...
Installed parsec-3.1.11
Installed polyparse-1.12
Configuring cpphs-1.20.2...
Building cpphs-1.20.2...
Installed cpphs-1.20.2
Configuring language-java-0.2.8...
Building language-java-0.2.8...
Installed language-java-0.2.8
cabal: Error: some packages failed to install:
LibZip-1.0.1 depends on bindings-libzip-1.0.1 which failed to install.
bindings-libzip-1.0.1 failed during the configure step. The exception was:
ExitFailure 1
javasf-0.1.0 depends on bindings-libzip-1.0.1 which failed to install.
language-java-classfile-0.2.0 depends on bindings-libzip-1.0.1 which failed to
install.