Build #3 for juicy-gcode-0.1.0.5.1

[all reports]

Package juicy-gcode-0.1.0.5.1
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2018-08-08 19:50:33.949037297 UTC
Compiler ghc-8.4.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: juicy-gcode-0.1.0.5.1 (user goal)
[__1] next goal: optparse-applicative (dependency of juicy-gcode)
[__1] rejecting: optparse-applicative-0.14.2.0, optparse-applicative-0.14.1.0,
optparse-applicative-0.14.0.0 (conflict: juicy-gcode =>
optparse-applicative>=0.13 && <0.14)
[__1] trying: optparse-applicative-0.13.2.0
[__2] next goal: process (dependency of optparse-applicative)
[__2] rejecting: process-1.6.3.0/installed-1.6... (conflict:
optparse-applicative => base>=4 && <4.11, process =>
base==4.11.1.0/installed-4.1...)
[__2] trying: process-1.6.4.0
[__3] next goal: directory (dependency of process)
[__3] rejecting: directory-1.3.1.5/installed-1.3... (conflict:
optparse-applicative => base>=4 && <4.11, directory =>
base==4.11.1.0/installed-4.1...)
[__3] trying: directory-1.3.3.1
[__4] next goal: base (dependency of juicy-gcode)
[__4] rejecting: base-4.11.1.0/installed-4.1... (conflict:
optparse-applicative => base>=4 && <4.11)
[__4] rejecting: base-4.11.1.0, base-4.11.0.0, base-4.10.1.0, base-4.10.0.0,
base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0, base-4.8.0.0,
base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0,
base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0,
base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0,
base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable
package requires installed instance)
[__3] fail (backjumping, conflict set: base, juicy-gcode,
optparse-applicative)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: process, directory, base,
optparse-applicative, juicy-gcode