Build #3 for kafka-device-vrpn-1.0.0.0

[all reports]

Package kafka-device-vrpn-1.0.0.0
Install DependencyFailed kafka-device-vrpn-1.0.0.0
Docs NotTried
Tests NotTried
Time submitted 2019-02-20 16:15:01.165394138 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies base-4.12.0.0, kafka-device-1.0.0.0, vrpn-0.3.0.0, base-4.12.0.0, kafka-device-1.0.0.0, vrpn-0.3.0.0
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     StateVar-1.1.1.1
Starting     cabal-doctest-1.0.6
Starting     base-orphans-0.8
Starting     base-compat-0.10.5
Building     StateVar-1.1.1.1
Building     base-orphans-0.8
Building     cabal-doctest-1.0.6
Building     base-compat-0.10.5
Completed    base-orphans-0.8
Starting     call-stack-0.1.0
Completed    StateVar-1.1.1.1
Starting     cereal-0.5.8.0
Building     call-stack-0.1.0
Building     cereal-0.5.8.0
Completed    cabal-doctest-1.0.6
Starting     digest-0.0.1.2
Completed    call-stack-0.1.0
Starting     dlist-0.8.0.5
Building     digest-0.0.1.2
Building     dlist-0.8.0.5
Completed    digest-0.0.1.2
Starting     hashable-1.2.7.0
Building     hashable-1.2.7.0
Completed    base-compat-0.10.5
Starting     integer-logarithms-1.0.2.2
Completed    dlist-0.8.0.5
Starting     murmur-hash-0.1.0.9
Building     integer-logarithms-1.0.2.2
Building     murmur-hash-0.1.0.9
Completed    integer-logarithms-1.0.2.2
Starting     network-2.8.0.0
Completed    murmur-hash-0.1.0.9
Starting     parallel-3.2.2.0
Completed    hashable-1.2.7.0
Starting     primitive-0.6.4.0
Completed    cereal-0.5.8.0
Starting     random-1.1
Building     parallel-3.2.2.0
Building     primitive-0.6.4.0
Building     random-1.1
Building     network-2.8.0.0
Completed    parallel-3.2.2.0
Starting     reflection-2.1.4
Building     reflection-2.1.4
Completed    random-1.1
Starting     semigroups-0.18.5
Building     semigroups-0.18.5
Completed    semigroups-0.18.5
Starting     tagged-0.8.6
Building     tagged-0.8.6
Completed    reflection-2.1.4
Starting     th-abstraction-0.2.10.0
Building     th-abstraction-0.2.10.0
Completed    tagged-0.8.6
Starting     time-locale-compat-0.1.1.5
Building     time-locale-compat-0.1.1.5
Completed    time-locale-compat-0.1.1.5
Starting     transformers-compat-0.6.2
Building     transformers-compat-0.6.2
Completed    network-2.8.0.0
Starting     void-0.7.2
Building     void-0.7.2
Completed    primitive-0.6.4.0
Starting     vrpn-0.3.0.0
Completed    void-0.7.2
Starting     zlib-0.6.2
Completed    th-abstraction-0.2.10.0
Starting     contravariant-1.5
Building     zlib-0.6.2
Failed to install vrpn-0.3.0.0
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/vrpn-0.3.0.0-BQas3Bbsarn6S5JkRot1zT.log ):
cabal: Entering directory '/tmp/cabal-tmp-4740/vrpn-0.3.0.0'
Configuring vrpn-0.3.0.0...
cabal: Missing dependencies on foreign libraries:
* Missing (or bad) C libraries: vrpn, quat, vrpn, quat
This problem can usually be solved by installing the system packages that
provide these libraries (you may need the "-dev" versions). If the libraries
are already installed but in a non-standard location then you can use the
flags --extra-include-dirs= and --extra-lib-dirs= to specify where they are.If
the library files do exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-4740/vrpn-0.3.0.0'
Starting     unordered-containers-0.2.10.0
Building     contravariant-1.5
Completed    transformers-compat-0.6.2
Building     unordered-containers-0.2.10.0
Completed    contravariant-1.5
Completed    zlib-0.6.2
Completed    unordered-containers-0.2.10.0
cabal: Error: some packages failed to install:
kafka-device-vrpn-1.0.0.0-IlKBS5mSBe269fom0yqaSD depends on
kafka-device-vrpn-1.0.0.0 which failed to install.
vrpn-0.3.0.0-BQas3Bbsarn6S5JkRot1zT failed during the configure step. The
exception was:
ExitFailure 1