Build #3 for keera-hails-mvc-environment-gtk-0.6.0

[all reports]

Package keera-hails-mvc-environment-gtk-0.6.0
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2020-05-28 02:34:19.364531203 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: keera-hails-mvc-environment-gtk-0.6.0 (user goal)
[__1] trying: keera-hails-mvc-view-gtk-0.0.3.3 (dependency of
keera-hails-mvc-environment-gtk)
[__2] trying: gtk-helpers-0.0.9.1 (dependency of keera-hails-mvc-view-gtk)
[__3] trying: template-haskell-2.14.0.0/installed-2.14.0.0 (dependency of
gtk-helpers)
[__4] trying: pretty-1.1.3.6/installed-1.1.3.6 (dependency of
template-haskell)
[__5] trying: glib-0.13.8.0 (dependency of gtk-helpers)
[__6] trying: text-1.2.3.1/installed-1.2.3.1 (dependency of glib)
[__7] next goal: gtk (dependency of keera-hails-mvc-view-gtk)
[__7] rejecting: gtk-0.15.4, gtk-0.15.3, gtk-0.15.2, gtk-0.15.1, gtk-0.15.0,
gtk-0.14.7, gtk-0.14.6, gtk-0.14.5, gtk-0.14.4, gtk-0.14.3, gtk-0.14.2,
gtk-0.13.9, gtk-0.13.8.1, gtk-0.13.8, gtk-0.13.7, gtk-0.13.6, gtk-0.13.4,
gtk-0.13.3, gtk-0.13.2, gtk-0.13.1, gtk-0.13.0.3, gtk-0.13.0.2, gtk-0.13.0.1
(conflict: pkg-config package gtk+-2.0-any, not found in the pkg-config
database)
[__7] rejecting: gtk-0.13.0.0 (conflict: text==1.2.3.1/installed-1.2.3.1, gtk
=> text>=0.11.0.6 && <1.2)
[__7] rejecting: gtk-0.12.5.7 (conflict: glib==0.13.8.0, gtk => glib>=0.12.5.4
&& <0.13)
[__7] skipping: gtk-0.12.5.6, gtk-0.12.5.5, gtk-0.12.5.4, gtk-0.12.5.3,
gtk-0.12.5.2, gtk-0.12.5.1, gtk-0.12.5.0, gtk-0.12.4, gtk-0.12.3.1,
gtk-0.12.3, gtk-0.12.2, gtk-0.12.1, gtk-0.12.0, gtk-0.11.2, gtk-0.11.1,
gtk-0.11.0 (has the same characteristics that caused the previous version to
fail: excludes 'glib' version 0.13.8.0)
[__7] rejecting: gtk-0.14.10, gtk-0.14.9 (conflict: pkg-config package
gtk+-2.0-any, not found in the pkg-config database)
[__7] fail (backjumping, conflict set: glib, gtk, keera-hails-mvc-view-gtk,
text)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: glib, gtk, text, pretty,
keera-hails-mvc-view-gtk, base, template-haskell, gtk-helpers,
keera-hails-mvc-environment-gtk
Try running with --minimize-conflict-set to improve the error message.