The lambdabot package

[Tags: gpl, program]

Lambdabot is a Haskell development tool, written in Haskell. It operates as a command line tool, embedded in an editor, embedded in GHCi, via internet relay chat and on the web.


[Skip to ReadMe]

Properties

Versions4.0, 4.1, 4.2.1, 4.2.2, 4.2.2.1, 4.2.3.0, 4.2.3.1, 4.2.3.2, 4.2.3.3, 4.3, 4.3.0.1, 5.0, 5.0.1, 5.0.2, 5.0.2.1, 5.0.2.2, 5.0.3 (info)
Change logNone available
Dependenciesarray, arrows, base, binary (>=0.2), bytestring, containers, directory, haskell-src, mtl, network, oeis, old-time, parsec, plugins (>=1.0), pretty, process, QuickCheck, random, readline, regex-compat, regex-posix, unix, zlib [details]
LicenseGPL
AuthorDon Stewart
Maintainerdons@galois.com
CategoryWeb
Home pagehttp://haskell.org/haskellwiki/Lambdabot
Executablessmallcheck, quickcheck, runplugs, ft, djinn, hoogle, lambdabot, BotPP
UploadedThu Feb 14 04:41:00 UTC 2008 by GwernBranwen
DistributionsDebian:4.3.0.1, NixOS:5.0.2.2, Stackage:5.0.3
Downloads2780 total (198 in last 30 days)
Votes
0 []
StatusDocs not available [build log]
All reported builds failed as of 2015-06-02 [all 2 reports]

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for lambdabot-4.1

 _                   _          _         _             _
/ \                 / |        | \       / |           | \_
| |    ___ _  _ _ _ | \__    __/ | ___ _ | \__   ____  |  _|
| |   /  _` || ` ` ||  _ \  / _  |/  _` ||  _ \ /  _ \ | |
| \__ | |_| || | | || |_| || |_| || |_| || |_| || |_| || \__
\____|\___,_/|_|_|_|\____/  \____/\___,_/\____/ \____/ \____|

BUILDING:

You'll need GHC >= 6.4

If you're *not* using ghc 6.6, build the Data.ByteString library at
http://www.cse.unsw.edu.au/~dons, version 0.7 and later are ok.

You need the zlib library:
    http://hackage.haskell.org/cgi-bin/hackage-scripts/package/zlib

Build with cabal (simple)
    $ vi Config.hs
    $ ./build
    $ ./lambdabot { -e command }

If the ./Setup.hs step doesn't seem to like the cabal file, you likely
need to install an updated version of Cabal:
    $ cd $place_you_want_to_put_cabal
    $ darcs get http://darcs.haskell.org/packages/Cabal
    $ cd Cabal
    $ runghc -cpp Setup.lhs configure && runghc -cpp Setup.lhs build
    # runghc -cpp Setup.lhs install

Note: If you want lambdabot to be able to evaluate expressions
(e.g., "> 1 + 1" evaluates to 2) then you'll need hs-plugins and also
before './Setup.hs configure --bindir=`pwd`' you need to copy
lambdabot.cabal.plugins to lambdabot.cabal.

Or with ghci (fastest turn around). But first you have to build with
cabal as above anyway. So this is mostly for development purposes.
    $ vi Config.hs
    $ sh configure
    $ sh ghci Main.hs
then
    *Main> main
or
    *Main> online <list>
where <list> is a list of commands to execute, as with -e.

OFFLINE MODE:
    ./lambdabot

CONNECTING:
    ./lambdabot -e 'rc online.rc'

SSL MODE (with stunnel):

append the following to your stunnel.conf
    client = yes
    [irc]
    accept = 6667
    connect = ssl-irc-server.org:6667

and edit online.rc to use localhost as server, then restart the stunnel
server and restart lambdabot with:

    ./lambdabot -e 'rc online.rc'

SCRIPTS:
    The scripts directory contains some shell scripts for Vim editor support
    They are self-explanatory

BUGS:

Bug reports, patches, new modules etc, contact:

	Don Stewart <dons@cse.unsw.edu.au>
	aka dons on #haskell

REPOSITORY:

Our darcs repository is located at:
    http://code.haskell.org/lambdabot

CONTRIBUTING:

Use 'darcs send' to submit patches to dons. Add yourself to the AUTHORS
file if you haven't already.