Build #7 for lambdiff-0.1

[all reports]

Package lambdiff-0.1
Install DependencyFailed cairo-0.12.5.3
Docs NotTried
Tests NotTried
Time submitted 2016-12-26 13:47:11.26665 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies attoparsec-0.10.4.0, attoparsec-enumerator-0.2.0.5, base-4.9.0.0, bytestring-0.10.8.1, enumerator-0.4.20, gtk-0.12.5.7, mtl-2.2.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Configuring utf8-string-0.3.7...
Building mtl-2.2.1...
Building utf8-string-0.3.7...
Configuring text-1.2.2.1...
Installed utf8-string-0.3.7
Building text-1.2.2.1...
Installed mtl-2.2.1
Configuring cairo-0.12.5.3...
Configuring glib-0.12.5.4...
Failed to install cairo-0.12.5.3
Build log ( /home/builder/.cabal/logs/cairo-0.12.5.3.log ):
cabal: Entering directory '/tmp/cabal-tmp-15409/cairo-0.12.5.3'
cabal: Leaving directory '/tmp/cabal-tmp-15409/cairo-0.12.5.3'
Failed to install glib-0.12.5.4
Build log ( /home/builder/.cabal/logs/glib-0.12.5.4.log ):
cabal: Entering directory '/tmp/cabal-tmp-15412/glib-0.12.5.4'
cabal: Leaving directory '/tmp/cabal-tmp-15412/glib-0.12.5.4'
Installed text-1.2.2.1
Configuring attoparsec-0.10.4.0...
Configuring enumerator-0.4.20...
Building attoparsec-0.10.4.0...
Building enumerator-0.4.20...
Installed attoparsec-0.10.4.0
Installed enumerator-0.4.20
Configuring attoparsec-enumerator-0.2.0.5...
Building attoparsec-enumerator-0.2.0.5...
Installed attoparsec-enumerator-0.2.0.5
cabal: Error: some packages failed to install:
cairo-0.12.5.3 failed during the configure step. The exception was:
user error ('/opt/ghc/8.0.2/bin/ghc' exited with an error:

/tmp/cabal-tmp-15409/cairo-0.12.5.3/SetupWrapper.hs:60:49: error:
Ambiguous occurrence ‘exeExtension’
It could refer to either ‘Distribution.Simple.BuildPaths.exeExtension’,
imported from ‘Distribution.Simple.BuildPaths’ at
/tmp/cabal-tmp-15409/cairo-0.12.5.3/SetupWrapper.hs:11:40-51
or ‘System.Directory.exeExtension’,
imported from ‘System.Directory’ at
/tmp/cabal-tmp-15409/cairo-0.12.5.3/SetupWrapper.hs:23:1-23
(and originally defined in
‘directory-1.2.6.2:System.Directory.Internal.Config’)

/tmp/cabal-tmp-15409/cairo-0.12.5.3/SetupWrapper.hs:91:17: error:
Ambiguous occurrence ‘die’
It could refer to either ‘Distribution.Simple.Utils.die’,
imported from ‘Distribution.Simple.Utils’ at
/tmp/cabal-tmp-15409/cairo-0.12.5.3/SetupWrapper.hs:8:1-32
or ‘System.Exit.die’,
imported from ‘System.Exit’ at
/tmp/cabal-tmp-15409/cairo-0.12.5.3/SetupWrapper.hs:21:1-18
)
gio-0.12.5.3 depends on glib-0.12.5.4 which failed to install.
glib-0.12.5.4 failed during the configure step. The exception was:
user error ('/opt/ghc/8.0.2/bin/ghc' exited with an error:

/tmp/cabal-tmp-15412/glib-0.12.5.4/SetupWrapper.hs:60:49: error:
Ambiguous occurrence ‘exeExtension’
It could refer to either ‘Distribution.Simple.BuildPaths.exeExtension’,
imported from ‘Distribution.Simple.BuildPaths’ at
/tmp/cabal-tmp-15412/glib-0.12.5.4/SetupWrapper.hs:11:40-51
or ‘System.Directory.exeExtension’,
imported from ‘System.Directory’ at
/tmp/cabal-tmp-15412/glib-0.12.5.4/SetupWrapper.hs:23:1-23
(and originally defined in
‘directory-1.2.6.2:System.Directory.Internal.Config’)

/tmp/cabal-tmp-15412/glib-0.12.5.4/SetupWrapper.hs:91:17: error:
Ambiguous occurrence ‘die’
It could refer to either ‘Distribution.Simple.Utils.die’,
imported from ‘Distribution.Simple.Utils’ at
/tmp/cabal-tmp-15412/glib-0.12.5.4/SetupWrapper.hs:8:1-32
or ‘System.Exit.die’,
imported from ‘System.Exit’ at
/tmp/cabal-tmp-15412/glib-0.12.5.4/SetupWrapper.hs:21:1-18
)
gtk-0.12.5.7 depends on cairo-0.12.5.3 which failed to install.
lambdiff-0.1 depends on cairo-0.12.5.3 which failed to install.
pango-0.12.5.3 depends on cairo-0.12.5.3 which failed to install.