The language-puppet package

[Tags:bsd3, library, program, test]

This is a set of libraries designed to work with the Puppet DSL. It can be used to parse .pp files, compile and interpret them, evaluate the templates. It is still very experimental but is already pretty useful when working with the manifests.

Properties

Versions 0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.1.7.2, 0.1.8.0, 0.2.0, 0.2.0.1, 0.2.0.2, 0.2.2.0, 0.3.0.0, 0.3.1.0, 0.3.2, 0.4.0, 0.4.2, 0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.10.4, 0.10.5, 0.10.6, 0.11.0, 0.11.1, 0.11.1.1, 0.12.0, 0.12.1, 0.12.2, 0.12.3, 0.13.0, 0.14.0, 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.1.1.1, 1.1.1.2, 1.1.3, 1.1.3.1, 1.1.4, 1.1.4.1, 1.1.5, 1.1.5.1, 1.2, 1.3, 1.3.1, 1.3.1.1, 1.3.2
Dependencies base (>=3 && <5), base16-bytestring, bytestring, containers, cryptohash, filepath, Glob, hslogger, MissingH, mtl, parsec, pretty, process, regex-pcre-builtin, regexpr, unix [details]
License GPL-3
Author Simon Marechal
Maintainer bartavelle@gmail.com
Stability Unknown
Category Language
Home page http://lpuppet.banquise.net
Uploaded Fri Aug 24 09:29:20 UTC 2012 by SimonMarechal
Distributions LTSHaskell:1.3.1.1, NixOS:1.3.2, Stackage:1.3.1.1, Tumbleweed:1.2
Downloads 6574 total (84 in the last 30 days)
Votes
1 []
Status Docs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees