Metadata revisions for lattices-1.7.1.1

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User Changes
-r2 Tue Apr 16 08:25:09 UTC 2019 phadej
  • Changed the library component's library dependency on 'universe-base' from

    >=1.0 && <1.1
    to
    >=1.0 && <1.2

  • Changed the library component's library dependency on 'universe-reverse-instances' from

    >=1.0 && <1.1
    to
    >=1.0 && <1.2

  • Changed the test suite 'test' component's library dependency on 'QuickCheck' from

    >=2.10 && <2.13
    to
    >=2.10 && <2.14

  • Changed the test suite 'test' component's library dependency on 'tasty' from

    >=0.10 && <1.2
    to
    >=0.10 && <1.3

  • Changed the test suite 'test' component's library dependency on 'universe-instances-base' from

    >=1.0 && <1.1
    to
    >=1.0 && <1.2

-r1 Mon Sep 24 17:02:31 UTC 2018 phadej
  • Changed tested-with from

    ghc ==7.4.2: ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.3
    to
    ghc ==7.4.2: ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.3: ghc ==8.6.1

  • Changed the library component's library dependency on 'base' from

    >=4.5 && <4.12
    to
    >=4.5 && <4.13

  • Changed the library component's library dependency on 'containers' from

    >=0.4.2.1 && <0.6
    to
    >=0.4.2.1 && <0.7

  • Changed the test suite 'test' component's library dependency on 'QuickCheck' from

    >=2.10 && <2.12
    to
    >=2.10 && <2.13

-r0 Thu Jul 5 14:04:18 UTC 2018 phadej