Build #2 for libarchive-conduit-0.1.0.0

[all reports]

Package libarchive-conduit-0.1.0.0
Install ConfigureFailed
Docs NotTried
Tests NotTried
Time submitted 2015-09-27 03:58:36.753948 UTC
Compiler ghc-7.10.2
OS linux
Arch x86_64
Dependencies transformers-0.4.2.0, resourcet-1.1.6, conduit-1.2.5, bytestring-0.10.6.0, base-4.8.1.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring mmorph-1.0.4...
Building mmorph-1.0.4...
Preprocessing library mmorph-1.0.4...
[1 of 2] Compiling Control.Monad.Morph ( src/Control/Monad/Morph.hs, dist/build/Control/Monad/Morph.o )

src/Control/Monad/Morph.hs:76:1: Warning:
    Module ‘Control.Monad.Trans.Error’ is deprecated:
      Use Control.Monad.Trans.Except instead

src/Control/Monad/Morph.hs:116:20: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/Control/Monad/Morph.hs:117:19: Warning:
    In the use of data constructor ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/Control/Monad/Morph.hs:117:34: Warning:
    In the use of ‘E.runErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/Control/Monad/Morph.hs:241:11: Warning:
    In the use of type constructor or class ‘E.Error’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/Control/Monad/Morph.hs:241:33: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/Control/Monad/Morph.hs:242:17: Warning:
    In the use of data constructor ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/Control/Monad/Morph.hs:243:14: Warning:
    In the use of ‘E.runErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/Control/Monad/Morph.hs:243:30: Warning:
    In the use of ‘E.runErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"
[2 of 2] Compiling Control.Monad.Trans.Compose ( src/Control/Monad/Trans/Compose.hs, dist/build/Control/Monad/Trans/Compose.o )
In-place registering mmorph-1.0.4...
Running Haddock for mmorph-1.0.4...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-mmorph-1.0336465782861021530.4
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/mmorph-1.0.4-8dNpUU8QFPe77rrwKAb20b
Registering mmorph-1.0.4...
Installed mmorph-1.0.4
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Preprocessing library mtl-2.2.1...
[ 1 of 22] Compiling Control.Monad.Writer.Class ( Control/Monad/Writer/Class.hs, dist/build/Control/Monad/Writer/Class.o )
[ 2 of 22] Compiling Control.Monad.State.Class ( Control/Monad/State/Class.hs, dist/build/Control/Monad/State/Class.o )
[ 3 of 22] Compiling Control.Monad.Reader.Class ( Control/Monad/Reader/Class.hs, dist/build/Control/Monad/Reader/Class.o )
[ 4 of 22] Compiling Control.Monad.RWS.Class ( Control/Monad/RWS/Class.hs, dist/build/Control/Monad/RWS/Class.o )
[ 5 of 22] Compiling Control.Monad.Identity ( Control/Monad/Identity.hs, dist/build/Control/Monad/Identity.o )
[ 6 of 22] Compiling Control.Monad.Error.Class ( Control/Monad/Error/Class.hs, dist/build/Control/Monad/Error/Class.o )
[ 7 of 22] Compiling Control.Monad.Cont.Class ( Control/Monad/Cont/Class.hs, dist/build/Control/Monad/Cont/Class.o )
[ 8 of 22] Compiling Control.Monad.Trans ( Control/Monad/Trans.hs, dist/build/Control/Monad/Trans.o )
[ 9 of 22] Compiling Control.Monad.Error ( Control/Monad/Error.hs, dist/build/Control/Monad/Error.o )
[10 of 22] Compiling Control.Monad.Except ( Control/Monad/Except.hs, dist/build/Control/Monad/Except.o )
[11 of 22] Compiling Control.Monad.List ( Control/Monad/List.hs, dist/build/Control/Monad/List.o )
[12 of 22] Compiling Control.Monad.RWS.Lazy ( Control/Monad/RWS/Lazy.hs, dist/build/Control/Monad/RWS/Lazy.o )
[13 of 22] Compiling Control.Monad.RWS ( Control/Monad/RWS.hs, dist/build/Control/Monad/RWS.o )
[14 of 22] Compiling Control.Monad.Reader ( Control/Monad/Reader.hs, dist/build/Control/Monad/Reader.o )
[15 of 22] Compiling Control.Monad.RWS.Strict ( Control/Monad/RWS/Strict.hs, dist/build/Control/Monad/RWS/Strict.o )
[16 of 22] Compiling Control.Monad.State.Lazy ( Control/Monad/State/Lazy.hs, dist/build/Control/Monad/State/Lazy.o )
[17 of 22] Compiling Control.Monad.State ( Control/Monad/State.hs, dist/build/Control/Monad/State.o )
[18 of 22] Compiling Control.Monad.State.Strict ( Control/Monad/State/Strict.hs, dist/build/Control/Monad/State/Strict.o )
[19 of 22] Compiling Control.Monad.Writer.Lazy ( Control/Monad/Writer/Lazy.hs, dist/build/Control/Monad/Writer/Lazy.o )
[20 of 22] Compiling Control.Monad.Writer ( Control/Monad/Writer.hs, dist/build/Control/Monad/Writer.o )
[21 of 22] Compiling Control.Monad.Writer.Strict ( Control/Monad/Writer/Strict.hs, dist/build/Control/Monad/Writer/Strict.o )
[22 of 22] Compiling Control.Monad.Cont ( Control/Monad/Cont.hs, dist/build/Control/Monad/Cont.o )
In-place registering mtl-2.2.1...
Running Haddock for mtl-2.2.1...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file: /tmp/pkgConf-mtl-2.25117023052084420925.1
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/mtl-2.2.1-KMpng31YRYc5JfMWFZ3FCU
Registering mtl-2.2.1...
Installed mtl-2.2.1
Configuring stm-2.4.4...
Building stm-2.4.4...
Preprocessing library stm-2.4.4...
[ 1 of 10] Compiling Control.Sequential.STM ( Control/Sequential/STM.hs, dist/build/Control/Sequential/STM.o )
[ 2 of 10] Compiling Control.Concurrent.STM.TBQueue ( Control/Concurrent/STM/TBQueue.hs, dist/build/Control/Concurrent/STM/TBQueue.o )
[ 3 of 10] Compiling Control.Concurrent.STM.TQueue ( Control/Concurrent/STM/TQueue.hs, dist/build/Control/Concurrent/STM/TQueue.o )
[ 4 of 10] Compiling Control.Concurrent.STM.TChan ( Control/Concurrent/STM/TChan.hs, dist/build/Control/Concurrent/STM/TChan.o )
[ 5 of 10] Compiling Control.Concurrent.STM.TMVar ( Control/Concurrent/STM/TMVar.hs, dist/build/Control/Concurrent/STM/TMVar.o )
[ 6 of 10] Compiling Control.Concurrent.STM.TVar ( Control/Concurrent/STM/TVar.hs, dist/build/Control/Concurrent/STM/TVar.o )
[ 7 of 10] Compiling Control.Concurrent.STM.TArray ( Control/Concurrent/STM/TArray.hs, dist/build/Control/Concurrent/STM/TArray.o )
[ 8 of 10] Compiling Control.Monad.STM ( Control/Monad/STM.hs, dist/build/Control/Monad/STM.o )
[ 9 of 10] Compiling Control.Concurrent.STM ( Control/Concurrent/STM.hs, dist/build/Control/Concurrent/STM.o )
[10 of 10] Compiling Control.Concurrent.STM.TSem ( Control/Concurrent/STM/TSem.hs, dist/build/Control/Concurrent/STM/TSem.o )
In-place registering stm-2.4.4...
Running Haddock for stm-2.4.4...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file: /tmp/pkgConf-stm-2.4350322227841148365.4
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/stm-2.4.4-C1kFMnPqFjvDhFjgMZGUpr
Registering stm-2.4.4...
Installed stm-2.4.4
Configuring transformers-compat-0.4.0.4...
Building transformers-compat-0.4.0.4...
Preprocessing library transformers-compat-0.4.0.4...
[1 of 1] Compiling Paths_transformers_compat ( dist/build/autogen/Paths_transformers_compat.hs, dist/build/Paths_transformers_compat.o )
In-place registering transformers-compat-0.4.0.4...
Running Haddock for transformers-compat-0.4.0.4...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-transformers-compat-0.4.01529195746392035568.4
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/transformers-compat-0.4.0.4-DCQioW2d4vYEa3T0AmFBPv
Registering transformers-compat-0.4.0.4...
Installed transformers-compat-0.4.0.4
Configuring exceptions-0.8.0.2...
Building exceptions-0.8.0.2...
Preprocessing library exceptions-0.8.0.2...
[1 of 2] Compiling Control.Monad.Catch ( src/Control/Monad/Catch.hs, dist/build/Control/Monad/Catch.o )
[2 of 2] Compiling Control.Monad.Catch.Pure ( src/Control/Monad/Catch/Pure.hs, dist/build/Control/Monad/Catch/Pure.o )
In-place registering exceptions-0.8.0.2...
Running Haddock for exceptions-0.8.0.2...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-exceptions-0.8.01665947468619290071.2
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/exceptions-0.8.0.2-8GsEeHgaIks3pVGk6GaELJ
Registering exceptions-0.8.0.2...
Installed exceptions-0.8.0.2
Configuring transformers-base-0.4.4...
Building transformers-base-0.4.4...
Preprocessing library transformers-base-0.4.4...
[1 of 1] Compiling Control.Monad.Base ( src/Control/Monad/Base.hs, dist/build/Control/Monad/Base.o )

src/Control/Monad/Base.hs:22:1: Warning:
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()

src/Control/Monad/Base.hs:24:1: Warning:
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()
In-place registering transformers-base-0.4.4...
Running Haddock for transformers-base-0.4.4...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-transformers-base-0.41065103348625032172.4
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/transformers-base-0.4.4-88TAFm21vtn2NrYUppy50c
Registering transformers-base-0.4.4...
Installed transformers-base-0.4.4
Configuring monad-control-1.0.0.4...
Building monad-control-1.0.0.4...
Preprocessing library monad-control-1.0.0.4...
[1 of 1] Compiling Control.Monad.Trans.Control ( Control/Monad/Trans/Control.hs, dist/build/Control/Monad/Trans/Control.o )
In-place registering monad-control-1.0.0.4...
Running Haddock for monad-control-1.0.0.4...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-monad-control-1.0.0780821396619054081.4
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/monad-control-1.0.0.4-3XCDr1mqlERGZgaxuwJF6b
Registering monad-control-1.0.0.4...
Installed monad-control-1.0.0.4
Configuring lifted-base-0.2.3.6...
Building lifted-base-0.2.3.6...
Preprocessing library lifted-base-0.2.3.6...
[1 of 9] Compiling System.Timeout.Lifted ( System/Timeout/Lifted.hs, dist/build/System/Timeout/Lifted.o )

System/Timeout/Lifted.hs:4:14: Warning:
    ‘System.Timeout.Lifted’ is marked as Trustworthy but has been inferred as safe!
[2 of 9] Compiling Foreign.Marshal.Utils.Lifted ( Foreign/Marshal/Utils/Lifted.hs, dist/build/Foreign/Marshal/Utils/Lifted.o )

Foreign/Marshal/Utils/Lifted.hs:6:14: Warning:
    ‘Foreign.Marshal.Utils.Lifted’ is marked as Trustworthy but has been inferred as safe!
[3 of 9] Compiling Data.IORef.Lifted ( Data/IORef/Lifted.hs, dist/build/Data/IORef/Lifted.o )

Data/IORef/Lifted.hs:6:14: Warning:
    ‘Data.IORef.Lifted’ is marked as Trustworthy but has been inferred as safe!
[4 of 9] Compiling Control.Concurrent.QSemN.Lifted ( Control/Concurrent/QSemN/Lifted.hs, dist/build/Control/Concurrent/QSemN/Lifted.o )

Control/Concurrent/QSemN/Lifted.hs:7:14: Warning:
    ‘Control.Concurrent.QSemN.Lifted’ is marked as Trustworthy but has been inferred as safe!
[5 of 9] Compiling Control.Concurrent.QSem.Lifted ( Control/Concurrent/QSem/Lifted.hs, dist/build/Control/Concurrent/QSem/Lifted.o )

Control/Concurrent/QSem/Lifted.hs:7:14: Warning:
    ‘Control.Concurrent.QSem.Lifted’ is marked as Trustworthy but has been inferred as safe!
[6 of 9] Compiling Control.Concurrent.Chan.Lifted ( Control/Concurrent/Chan/Lifted.hs, dist/build/Control/Concurrent/Chan/Lifted.o )

Control/Concurrent/Chan/Lifted.hs:6:14: Warning:
    ‘Control.Concurrent.Chan.Lifted’ is marked as Trustworthy but has been inferred as safe!
[7 of 9] Compiling Control.Concurrent.MVar.Lifted ( Control/Concurrent/MVar/Lifted.hs, dist/build/Control/Concurrent/MVar/Lifted.o )

Control/Concurrent/MVar/Lifted.hs:7:14: Warning:
    ‘Control.Concurrent.MVar.Lifted’ is marked as Trustworthy but has been inferred as safe!
[8 of 9] Compiling Control.Exception.Lifted ( Control/Exception/Lifted.hs, dist/build/Control/Exception/Lifted.o )

Control/Exception/Lifted.hs:11:14: Warning:
    ‘Control.Exception.Lifted’ is marked as Trustworthy but has been inferred as safe!
[9 of 9] Compiling Control.Concurrent.Lifted ( Control/Concurrent/Lifted.hs, dist/build/Control/Concurrent/Lifted.o )

Control/Concurrent/Lifted.hs:4:14: Warning:
    ‘Control.Concurrent.Lifted’ is marked as Trustworthy but has been inferred as safe!
In-place registering lifted-base-0.2.3.6...
Running Haddock for lifted-base-0.2.3.6...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-lifted-base-0.2.3630668850246247255.6
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/lifted-base-0.2.3.6-K3cQFA6mRg85rpDaA9numU
Registering lifted-base-0.2.3.6...
Installed lifted-base-0.2.3.6
Configuring resourcet-1.1.6...
Building resourcet-1.1.6...
Preprocessing library resourcet-1.1.6...
[1 of 4] Compiling Data.Acquire.Internal ( Data/Acquire/Internal.hs, dist/build/Data/Acquire/Internal.o )

Data/Acquire/Internal.hs:18:1: Warning:
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()
[2 of 4] Compiling Control.Monad.Trans.Resource.Internal ( Control/Monad/Trans/Resource/Internal.hs, dist/build/Control/Monad/Trans/Resource/Internal.o )

Control/Monad/Trans/Resource/Internal.hs:31:1: Warning:
    The import of ‘Applicative’
    from module ‘Control.Applicative’ is redundant

Control/Monad/Trans/Resource/Internal.hs:47:1: Warning:
    Module ‘Control.Monad.Trans.Error’ is deprecated:
      Use Control.Monad.Trans.Except instead

Control/Monad/Trans/Resource/Internal.hs:73:1: Warning:
    The import of ‘Data.Word’ is redundant
      except perhaps to import instances from ‘Data.Word’
    To import instances alone, use: import Data.Word()

Control/Monad/Trans/Resource/Internal.hs:74:1: Warning:
    Module ‘Prelude’ does not export ‘catch’

Control/Monad/Trans/Resource/Internal.hs:288:11: Warning:
    In the use of type constructor or class ‘Error’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Control/Monad/Trans/Resource/Internal.hs:288:56: Warning:
    In the use of type constructor or class ‘ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"
[3 of 4] Compiling Control.Monad.Trans.Resource ( Control/Monad/Trans/Resource.hs, dist/build/Control/Monad/Trans/Resource.o )

Control/Monad/Trans/Resource.hs:57:7: Warning:
    The export item ‘ExceptionT(..)’ suggests that
    ‘ExceptionT’ has (in-scope) constructors or class methods,
    but it has none

Control/Monad/Trans/Resource.hs:67:1: Warning:
    The import of ‘throw’ from module ‘Control.Exception’ is redundant

Control/Monad/Trans/Resource.hs:72:1: Warning:
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()

Control/Monad/Trans/Resource.hs:76:1: Warning:
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()

Control/Monad/Trans/Resource.hs:209:1: Warning:
    Defined but not used: ‘finally’
[4 of 4] Compiling Data.Acquire     ( Data/Acquire.hs, dist/build/Data/Acquire.o )

Data/Acquire.hs:18:1: Warning:
    The import of ‘Control.Monad.Trans.Resource’ is redundant
      except perhaps to import instances from ‘Control.Monad.Trans.Resource’
    To import instances alone, use: import Control.Monad.Trans.Resource()

Data/Acquire.hs:20:1: Warning:
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()

Data/Acquire.hs:21:1: Warning:
    The import of ‘Control.Monad.Base’ is redundant
      except perhaps to import instances from ‘Control.Monad.Base’
    To import instances alone, use: import Control.Monad.Base()

Data/Acquire.hs:23:1: Warning:
    The import of ‘Control.Monad.Trans.Control’ is redundant
      except perhaps to import instances from ‘Control.Monad.Trans.Control’
    To import instances alone, use: import Control.Monad.Trans.Control()

Data/Acquire.hs:25:1: Warning:
    The import of ‘Data.Typeable’ is redundant
      except perhaps to import instances from ‘Data.Typeable’
    To import instances alone, use: import Data.Typeable()

Data/Acquire.hs:26:1: Warning:
    The import of ‘Control.Monad’ is redundant
      except perhaps to import instances from ‘Control.Monad’
    To import instances alone, use: import Control.Monad()
In-place registering resourcet-1.1.6...
Running Haddock for resourcet-1.1.6...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-resourcet-1.116798954361545032460.6
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/resourcet-1.1.6-Ic1TzDDmqYbFNHpzRsDmfS
Registering resourcet-1.1.6...
Installed resourcet-1.1.6
Configuring conduit-1.2.5...
Building conduit-1.2.5...
Preprocessing library conduit-1.2.5...
[1 of 8] Compiling Data.Conduit.Internal.Pipe ( Data/Conduit/Internal/Pipe.hs, dist/build/Data/Conduit/Internal/Pipe.o )

Data/Conduit/Internal/Pipe.hs:48:1: Warning:
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()

Data/Conduit/Internal/Pipe.hs:60:1: Warning:
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()
[2 of 8] Compiling Data.Conduit.Internal.Conduit ( Data/Conduit/Internal/Conduit.hs, dist/build/Data/Conduit/Internal/Conduit.o )

Data/Conduit/Internal/Conduit.hs:86:1: Warning:
    Module ‘Prelude’ does not export ‘catch’

Data/Conduit/Internal/Conduit.hs:87:1: Warning:
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()

Data/Conduit/Internal/Conduit.hs:100:1: Warning:
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()

Data/Conduit/Internal/Conduit.hs:107:1: Warning:
    The import of ‘Data.Traversable’ is redundant
      except perhaps to import instances from ‘Data.Traversable’
    To import instances alone, use: import Data.Traversable()
[3 of 8] Compiling Data.Conduit.Internal.Fusion ( Data/Conduit/Internal/Fusion.hs, dist/build/Data/Conduit/Internal/Fusion.o )
[4 of 8] Compiling Data.Conduit.Internal.List.Stream ( Data/Conduit/Internal/List/Stream.hs, dist/build/Data/Conduit/Internal/List/Stream.o )
[5 of 8] Compiling Data.Conduit.Internal ( Data/Conduit/Internal.hs, dist/build/Data/Conduit/Internal.o )
[6 of 8] Compiling Data.Conduit     ( Data/Conduit.hs, dist/build/Data/Conduit.o )
[7 of 8] Compiling Data.Conduit.List ( Data/Conduit/List.hs, dist/build/Data/Conduit/List.o )
[8 of 8] Compiling Data.Conduit.Lift ( Data/Conduit/Lift.hs, dist/build/Data/Conduit/Lift.o )

Data/Conduit/Lift.hs:74:1: Warning:
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()

Data/Conduit/Lift.hs:77:1: Warning:
    Module ‘Control.Monad.Trans.Error’ is deprecated:
      Use Control.Monad.Trans.Except instead

Data/Conduit/Lift.hs:128:26: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:128:56: Warning:
    In the use of type constructor or class ‘E.Error’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:130:29: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:133:12: Warning:
    In the use of data constructor ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:139:16: Warning:
    In the use of type constructor or class ‘E.Error’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:140:20: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:145:25: Warning:
    In the use of ‘E.runErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:150:56: Warning:
    In the use of ‘E.runErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:159:16: Warning:
    In the use of type constructor or class ‘E.Error’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:160:20: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:161:29: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:162:23: Warning:
    In the use of type constructor or class ‘E.ErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

Data/Conduit/Lift.hs:167:32: Warning:
    In the use of ‘E.runErrorT’
    (imported from Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"
In-place registering conduit-1.2.5...
Running Haddock for conduit-1.2.5...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file: /tmp/pkgConf-conduit-1.2241694912260289.5
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/conduit-1.2.5-9wHaNJrxyyq9dFXfK2u9W6
Registering conduit-1.2.5...
Installed conduit-1.2.5
Configuring libarchive-conduit-0.1.0.0...
cabal: Missing dependency on a foreign library:
* Missing C library: archive
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
Failed to install libarchive-conduit-0.1.0.0
cabal: Error: some packages failed to install:
libarchive-conduit-0.1.0.0 failed during the configure step. The exception
was:
ExitFailure 1