lvish: preferred and deprecated versions

Preferred and deprecated versions can be used to influence Cabal's decisions about which versions of lvish to install. If a range of versions is preferred, it means that the installer won't install a non-preferred package version unless it is explicitly specified or if it's the only choice the installer has. Deprecating a version adds a range which excludes just that version. All of this information is collected in the preferred-versions file that's included in the index tarball. [maintainers: edit]

If all the available versions of a package are non-preferred or deprecated, cabal-install will treat this the same as if none of them are. This feature doesn't affect whether or not to install a package, only for selecting versions after a given package has decided to be installed. Entire-package deprecation is also available, but it's separate from preferred versions.

Stored information

lvish has no preferred version ranges.

Explicitly deprecated versions for lvish include: 1.0, 1.0.0.2

The version range given to this package, therefore, is <1.0 || >1.0 && <1.0.0.2 || >1.0.0.2

Versions affected

Blue versions are normal versions. Green are those out of any preferred version ranges. Gray are deprecated.

1.0, 1.0.0.2, 1.0.0.4, 1.0.0.6, 1.1.1.1, 1.1.1.2, 1.1.1.3, 1.1.2