Build #2 for maxent-learner-hw-gui-0.2.0

[all reports]

Package maxent-learner-hw-gui-0.2.0
Install DependencyFailed frpnow-gtk3-0.2.0
Docs NotTried
Tests NotTried
Time submitted 2017-05-05 05:27:58.275629452 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies Chart-1.8.2, Chart-cairo-1.8.2, array-0.5.1.1, async-2.1.1.1, base-4.9.0.0, bytestring-0.10.8.1, cairo-0.13.3.1, containers-0.5.7.1, deepseq-1.4.2.0, file-embed-0.0.10, frpnow-0.18, frpnow-gtk3-0.2.0, glib-0.13.4.1, gtk3-0.14.6, maxent-learner-hw-0.2.0, mtl-2.2.1, parallel-3.2.1.1, random-1.1, raw-strings-qq-1.1, text-1.2.2.1, transformers-0.5.2.0, tuple-0.3.0.2
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring OneTuple-0.2.1...
Configuring ansi-terminal-0.6.2.3...
Building OneTuple-0.2.1...
Building ansi-terminal-0.6.2.3...
Installed OneTuple-0.2.1
Configuring base-orphans-0.6...
Building base-orphans-0.6...
Configuring cabal-doctest-1...
Installed ansi-terminal-0.6.2.3
Building cabal-doctest-1...
Configuring colour-2.3.3...
Installed base-orphans-0.6
Building colour-2.3.3...
Configuring data-default-class-0.1.2.0...
Installed cabal-doctest-1
Building data-default-class-0.1.2.0...
Configuring fail-4.9.0.0...
Installed data-default-class-0.1.2.0
Building fail-4.9.0.0...
Configuring file-embed-0.0.10...
Installed fail-4.9.0.0
Building file-embed-0.0.10...
Configuring mtl-2.2.1...
Installed colour-2.3.3
Building mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Installed file-embed-0.0.10
Building old-locale-1.0.0.7...
Configuring parallel-3.2.1.1...
Installed old-locale-1.0.0.7
Building parallel-3.2.1.1...
Configuring prelude-extras-0.4.0.3...
Installed mtl-2.2.1
Building prelude-extras-0.4.0.3...
Configuring primitive-0.6.2.0...
Installed parallel-3.2.1.1
Building primitive-0.6.2.0...
Configuring random-1.1...
Installed prelude-extras-0.4.0.3
Building random-1.1...
Configuring raw-strings-qq-1.1...
Installed random-1.1
Building raw-strings-qq-1.1...
Configuring readcsv-0.1.1...
Installed primitive-0.6.2.0
Building readcsv-0.1.1...
Configuring reflection-2.1.2...
Installed raw-strings-qq-1.1
Building reflection-2.1.2...
Configuring semigroups-0.18.3...
Installed readcsv-0.1.1
Building semigroups-0.18.3...
Configuring stm-2.4.4.1...
Installed semigroups-0.18.3
Building stm-2.4.4.1...
Configuring text-1.2.2.1...
Installed reflection-2.1.2
Configuring transformers-compat-0.5.1.4...
Installed stm-2.4.4.1
Building text-1.2.2.1...
Building transformers-compat-0.5.1.4...
Configuring utf8-string-1.0.1.1...
Installed transformers-compat-0.5.1.4
Building utf8-string-1.0.1.1...
Configuring void-0.7.2...
Installed utf8-string-1.0.1.1
Building void-0.7.2...
Configuring tuple-0.3.0.2...
Installed void-0.7.2
Building tuple-0.3.0.2...
Installed text-1.2.2.1
Configuring ansi-wl-pprint-0.6.7.3...
Building ansi-wl-pprint-0.6.7.3...
Configuring frpnow-0.18...
Installed ansi-wl-pprint-0.6.7.3
Building frpnow-0.18...
Configuring operational-0.2.3.5...
Installed frpnow-0.18
Building operational-0.2.3.5...
Installed tuple-0.3.0.2
Configuring vector-0.12.0.1...
Building vector-0.12.0.1...
Configuring StateVar-1.1.0.4...
Installed operational-0.2.3.5
Building StateVar-1.1.0.4...
Configuring async-2.1.1.1...
Installed StateVar-1.1.0.4
Building async-2.1.1.1...
Configuring MonadRandom-0.5.1...
Installed async-2.1.1.1
Building MonadRandom-0.5.1...
Configuring exceptions-0.8.3...
Installed MonadRandom-0.5.1
Building exceptions-0.8.3...
Configuring tagged-0.8.5...
Installed exceptions-0.8.3
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring hashable-1.2.6.0...
Building hashable-1.2.6.0...
Installed hashable-1.2.6.0
Configuring optparse-applicative-0.13.2.0...
Building optparse-applicative-0.13.2.0...
Configuring contravariant-1.4...
Installed vector-0.12.0.1
Building contravariant-1.4...
Configuring random-shuffle-0.0.4...
Installed optparse-applicative-0.13.2.0
Building random-shuffle-0.0.4...
Configuring distributive-0.5.2...
Installed contravariant-1.4
Configuring unordered-containers-0.2.8.0...
Installed random-shuffle-0.0.4
Building unordered-containers-0.2.8.0...
Building distributive-0.5.2...
Installed distributive-0.5.2
Configuring maxent-learner-hw-0.2.0...
Building maxent-learner-hw-0.2.0...
Configuring hashtables-1.2.1.1...
Installed unordered-containers-0.2.8.0
Building hashtables-1.2.1.1...
Configuring comonad-5.0.1...
Installed hashtables-1.2.1.1
Installed maxent-learner-hw-0.2.0
Configuring gtk2hs-buildtools-0.13.2.2...
Building gtk2hs-buildtools-0.13.2.2...
Building comonad-5.0.1...
Installed comonad-5.0.1
Configuring bifunctors-5.4.2...
Building bifunctors-5.4.2...
Installed bifunctors-5.4.2
Configuring profunctors-5.2...
Building profunctors-5.2...
Configuring semigroupoids-5.2...
Installed profunctors-5.2
Building semigroupoids-5.2...
Installed gtk2hs-buildtools-0.13.2.2
Configuring glib-0.13.4.1...
Configuring cairo-0.13.3.1...
Installed semigroupoids-5.2
Building glib-0.13.4.1...
Building cairo-0.13.3.1...
Installed cairo-0.13.3.1
Configuring free-4.12.4...
Building free-4.12.4...
Installed glib-0.13.4.1
Configuring pango-0.13.3.1...
Building pango-0.13.3.1...
Configuring gio-0.13.3.1...
Installed free-4.12.4
Building gio-0.13.3.1...
Installed pango-0.13.3.1
Configuring adjunctions-4.3...
Building adjunctions-4.3...
Installed adjunctions-4.3
Configuring kan-extensions-5.0.1...
Building kan-extensions-5.0.1...
Installed kan-extensions-5.0.1
Configuring lens-4.15.2...
Building lens-4.15.2...
Installed gio-0.13.3.1
Configuring gtk3-0.14.6...
Building gtk3-0.14.6...
Installed lens-4.15.2
Configuring Chart-1.8.2...
Building Chart-1.8.2...
Installed Chart-1.8.2
Configuring Chart-cairo-1.8.2...
Building Chart-cairo-1.8.2...
Installed Chart-cairo-1.8.2
Installed gtk3-0.14.6
Configuring frpnow-gtk3-0.2.0...
Building frpnow-gtk3-0.2.0...
Failed to install frpnow-gtk3-0.2.0
Build log ( /home/builder/.cabal/logs/frpnow-gtk3-0.2.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-9746/frpnow-gtk3-0.2.0'
Configuring frpnow-gtk3-0.2.0...
Building frpnow-gtk3-0.2.0...
Preprocessing library frpnow-gtk3-0.2.0...
[1 of 8] Compiling Control.FRPNow.GTK.MissingFFI ( Control/FRPNow/GTK/MissingFFI.hs, dist/build/Control/FRPNow/GTK/MissingFFI.o )
[2 of 8] Compiling Control.FRPNow.GTK.Core ( Control/FRPNow/GTK/Core.hs, dist/build/Control/FRPNow/GTK/Core.o )
[3 of 8] Compiling Control.FRPNow.GTK.DataWidgets ( Control/FRPNow/GTK/DataWidgets.hs, dist/build/Control/FRPNow/GTK/DataWidgets.o )
[4 of 8] Compiling Control.FRPNow.GTK.Misc ( Control/FRPNow/GTK/Misc.hs, dist/build/Control/FRPNow/GTK/Misc.o )
[5 of 8] Compiling Control.FRPNow.GTK.TreeView ( Control/FRPNow/GTK/TreeView.hs, dist/build/Control/FRPNow/GTK/TreeView.o )
[6 of 8] Compiling Control.FRPNow.GTK.Containers ( Control/FRPNow/GTK/Containers.hs, dist/build/Control/FRPNow/GTK/Containers.o )

Control/FRPNow/GTK/Containers.hs:100:39: error:
    Not in scope: type constructor or class ‘Stack’

Control/FRPNow/GTK/Containers.hs:100:56: error:
    Not in scope: type constructor or class ‘Stack’

Control/FRPNow/GTK/Containers.hs:107:54: error:
    Not in scope: type constructor or class ‘Stack’

Control/FRPNow/GTK/Containers.hs:111:68: error:
    Not in scope: type constructor or class ‘Stack’

Control/FRPNow/GTK/Containers.hs:115:39: error:
    Not in scope: type constructor or class ‘Stack’
cabal: Leaving directory '/tmp/cabal-tmp-9746/frpnow-gtk3-0.2.0'
cabal: Error: some packages failed to install:
frpnow-gtk3-0.2.0 failed during the building phase. The exception was:
ExitFailure 1
maxent-learner-hw-gui-0.2.0 depends on frpnow-gtk3-0.2.0 which failed to
install.