mono-traversable-keys: Type-classes for interacting with monomorphic containers with a key

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain]

This is the extension of two other popular packages, mono-traversable and keys, designed to provided the functionality of the keys package to the monomorphic containers enhanced by the mono-traversable package.


[Skip to ReadMe]

Properties

Versions0.1.0, 0.1.0
Change logCHANGELOG.md
Dependenciesbase (>=4.5 && <5.0), bytestring (>=0.9 && <1.0), containers (>=0.3 && <0.7), hashable (>=1.2 && <2.0), keys (>=3 && <4.0), mono-traversable (>=1 && <2.0), semigroups (>=0.8.3.1 && <1.0), text (>=0.11 && <2.0), transformers (>=0.2 && <1.0), unordered-containers (>=0.2.4 && <1.0), vector (>=0.10 && <1.0), vector-instances (>=3.4 && <4.0) [details]
LicenseBSD-3-Clause
Copyright(c) Alex Washburn 2019
AuthorAlex Washburn
Maintainerhackage@recursion.ninja
CategoryContainers, Data, Data Structures
Home pagehttps://github.com/recursion-ninja/mono-traversable-keys#readme
Bug trackerhttps://github.com/recursion-ninja/mono-traversable-keys/issues
Source repositoryhead: git clone https://github.com/recursion-ninja/mono-traversable-keys
UploadedWed Jan 30 15:24:04 UTC 2019 by recursion_ninja

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees


Readme for mono-traversable-keys-0.1.0

[back to package description]

mono-traversable-keys

Provides type-classes for interacting with monomorphic containers in the following was:

This package is the extension of two other popular libraries, mono-traversable and keys, designed to provided the functionality of the keys package to the monomorphic containers enhanced by the mono-traversable package.