Build #7 for nymphaea-0.1

[all reports]

Package nymphaea-0.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-03 21:15:59.273352 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, cairo-0.13.3.1, containers-0.5.7.1, glade-0.13.1, glib-0.13.4.1, gtk-0.14.6, mtl-2.2.1, parsec-3.1.11, random-1.1
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring primitive-0.6.1.0...
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Building primitive-0.6.1.0...
Installed mtl-2.2.1
Configuring random-1.1...
Configuring text-1.2.2.1...
Installed primitive-0.6.1.0
Building random-1.1...
Building text-1.2.2.1...
Configuring utf8-string-1.0.1.1...
Installed random-1.1
Building utf8-string-1.0.1.1...
Installed utf8-string-1.0.1.1
Configuring vector-0.11.0.0...
Building vector-0.11.0.0...
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Configuring hashable-1.2.5.0...
Installed parsec-3.1.11
Building hashable-1.2.5.0...
Installed hashable-1.2.5.0
Installed vector-0.11.0.0
Configuring hashtables-1.2.1.0...
Building hashtables-1.2.1.0...
Installed hashtables-1.2.1.0
Configuring gtk2hs-buildtools-0.13.2.1...
Building gtk2hs-buildtools-0.13.2.1...
Installed gtk2hs-buildtools-0.13.2.1
Configuring glib-0.13.4.1...
Configuring cairo-0.13.3.1...
Building cairo-0.13.3.1...
Building glib-0.13.4.1...
Installed cairo-0.13.3.1
Installed glib-0.13.4.1
Configuring gio-0.13.3.1...
Configuring pango-0.13.3.1...
Building gio-0.13.3.1...
Building pango-0.13.3.1...
Installed pango-0.13.3.1
Installed gio-0.13.3.1
Configuring gtk-0.14.6...
Building gtk-0.14.6...
Installed gtk-0.14.6
Configuring glade-0.13.1...
Building glade-0.13.1...
Installed glade-0.13.1
Configuring nymphaea-0.1...
Building nymphaea-0.1...
Failed to install nymphaea-0.1
Build log ( /home/builder/.cabal/logs/nymphaea-0.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-27677/nymphaea-0.1'
Configuring nymphaea-0.1...
Warning: 'ghc-options: -prof' is not necessary and will lead to problems when
used on a library. Use the configure flag --enable-library-profiling and/or
--enable-profiling.
Building nymphaea-0.1...
Preprocessing executable 'nymphaea' for nymphaea-0.1...

src/LSystem.hs:1:16: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

src/MonadRandom.hs:1:16: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead
[1 of 5] Compiling Parser           ( src/Parser.hs, dist/build/nymphaea/nymphaea-tmp/Parser.o )

src/Parser.hs:36:5: warning: [-Wunused-do-bind]
    A do-notation statement discarded a result of type ‘String’
    Suppress this warning by saying ‘_ <- symbol "->"’

src/Parser.hs:57:9: warning: [-Wunused-do-bind]
    A do-notation statement discarded a result of type ‘String’
    Suppress this warning by saying ‘_ <- symbol ":"’

src/Parser.hs:68:22: warning: [-Wunused-do-bind]
    A do-notation statement discarded a result of type ‘Char’
    Suppress this warning by saying ‘_ <- char '.'’

src/Parser.hs:72:32: warning: [-Wunused-do-bind]
    A do-notation statement discarded a result of type ‘Char’
    Suppress this warning by saying ‘_ <- char '/'’
[2 of 5] Compiling MonadRandom      ( src/MonadRandom.hs, dist/build/nymphaea/nymphaea-tmp/MonadRandom.o )

src/MonadRandom.hs:22:22: error:
    • No instance for (Applicative (RandomT m))
        arising from the 'deriving' clause of a data type declaration
      Possible fix:
        use a standalone 'deriving instance' declaration,
          so you can specify the instance context yourself
    • When deriving the instance for (Monad (RandomT m))

src/MonadRandom.hs:38:22: error:
    • No instance for (Applicative Rand)
        arising from the 'deriving' clause of a data type declaration
      Possible fix:
        use a standalone 'deriving instance' declaration,
          so you can specify the instance context yourself
    • When deriving the instance for (Monad Rand)
cabal: Leaving directory '/tmp/cabal-tmp-27677/nymphaea-0.1'
cabal: Error: some packages failed to install:
nymphaea-0.1 failed during the building phase. The exception was:
ExitFailure 1