Build #2 for optparse-version-0.2.0.0

[all reports]

Package optparse-version-0.2.0.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-07-25 16:15:03.085484635 UTC
Compiler ghc-8.0.2
OS linux
Arch x86_64
Dependencies base-4.9.1.0, optparse-applicative-0.14.0.0, base-4.9.1.0, file-embed-0.0.10, optparse-applicative-0.14.0.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring ansi-terminal-0.6.3.1...
Configuring file-embed-0.0.10...
Building ansi-terminal-0.6.3.1...
Building file-embed-0.0.10...
Configuring transformers-compat-0.5.1.4...
Installed file-embed-0.0.10
Installed ansi-terminal-0.6.3.1
Configuring ansi-wl-pprint-0.6.7.3...
Building transformers-compat-0.5.1.4...
Building ansi-wl-pprint-0.6.7.3...
Installed transformers-compat-0.5.1.4
Installed ansi-wl-pprint-0.6.7.3
Configuring optparse-applicative-0.14.0.0...
Building optparse-applicative-0.14.0.0...
Installed optparse-applicative-0.14.0.0
Configuring optparse-version-0.2.0.0...
Building optparse-version-0.2.0.0...
Failed to install optparse-version-0.2.0.0
Build log ( /home/builder/.cabal/logs/optparse-version-0.2.0.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-22187/optparse-version-0.2.0.0'
Configuring optparse-version-0.2.0.0...
Building optparse-version-0.2.0.0...
Preprocessing library optparse-version-0.2.0.0...
[1 of 1] Compiling Options.Applicative.Version ( src/Options/Applicative/Version.hs, dist/build/Options/Applicative/Version.o )
Preprocessing executable 'optparse-version-exe' for
optparse-version-0.2.0.0...
[1 of 1] Compiling Main             ( app/Main.hs, dist/build/optparse-version-exe/optparse-version-exe-tmp/Main.o )

app/Main.hs:10:19: error:
    • Exception when trying to run compile-time code:
        version.txt: openFile: does not exist (No such file or directory)
      Code: embedStringFile "version.txt"
    • In the untyped splice: $(embedStringFile "version.txt")
cabal: Leaving directory '/tmp/cabal-tmp-22187/optparse-version-0.2.0.0'
cabal: Error: some packages failed to install:
optparse-version-0.2.0.0 failed during the building phase. The exception was:
ExitFailure 1