Dependencies for penny-0.32.0.10

library
penny-gibberish
penny
  • base (>=4.5.0.0 && <4.8)
  • penny (==0.32.0.10)
  • if !flag(build-penny)
    • buildable: False
penny-selloff
  • base (>=4.5.0.0 && <4.8)
  • penny (==0.32.0.10)
  • if !flag(build-selloff)
    • buildable: False
penny-diff
  • base (>=4.5.0.0 && <4.8)
  • penny (==0.32.0.10)
  • if !flag(build-diff)
    • buildable: False
penny-reprint
  • base (>=4.5.0.0 && <4.8)
  • penny (==0.32.0.10)
  • if !flag(build-reprint)
    • buildable: False
penny-reconcile
  • base (>=4.5.0.0 && <4.8)
  • penny (==0.32.0.10)
  • if !flag(build-reconcile)
    • buildable: False

Flags

NameDescriptionDefaultType
build-gibberish

Build the penny-gibberish executable

DisabledAutomatic
build-penny

Build the penny executable

EnabledAutomatic
build-selloff

Build the penny-selloff executable

EnabledAutomatic
build-diff

Build the penny-diff executable

EnabledAutomatic
build-reprint

Build the penny-reprint executable

EnabledAutomatic
build-reconcile

Build the penny-reconcile executable

EnabledAutomatic
debug

turns on some debugging options

DisabledAutomatic
test

enables QuickCheck tests

DisabledAutomatic
incabal

enables imports that only Cabal makes available

EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info