The pipes-errors package

[maintain]
Warnings:

This package is analogous to the errors package but for base monad manipulation in the presence of Proxy monad transformers.

It also provides orphan MFunctor instances for EitherT and EitherRT.


[Skip to ReadMe]

Properties

Versions0.1, 0.2, 0.2.1, 0.2.1, 0.3
Dependenciesbase (>=4.6 && <4.9), errors (>=1.3 && <2.0), pipes (>=4.0) [details]
LicenseBSD3
AuthorDanny Navarro
MaintainerDanny Navarro <j@dannynavarro.net>
CategoryControl, Monad, Pipes, Error Handling
Home pagehttps://github.com/jdnavarro/pipes-errors
Bug trackerhttps://github.com/jdnavarro/pipes-errors/issues
Source repositoryhead: git clone https://github.com/jdnavarro/pipes-errors
UploadedMon Apr 13 10:50:28 UTC 2015 by jdnavarro

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for pipes-errors-0.2.1

Pipes Errors

This package is analogous to the errors package but for base monad manipulation in the presence of Proxy monad transformers.

It also provides orphan MFunctor instances for EitherT and EitherRT.