postgresql-libpq: low-level binding to libpq

[ bsd3, database, library ] [ Propose Tags ]

This is a binding to libpq: the C application programmer's interface to PostgreSQL. libpq is a set of library functions that allow client programs to pass queries to the PostgreSQL backend server and to receive the results of these queries.

Versions 0.5, 0.6, 0.6.1, 0.6.2, 0.7, 0.7.1, 0.7.2, 0.8, 0.8.1, 0.8.2, 0.8.2.1, 0.8.2.2, 0.8.2.3, 0.8.2.4, 0.8.2.5, 0.8.2.6, 0.9.0.0, 0.9.0.1, 0.9.0.2, 0.9.1.0, 0.9.1.1, 0.9.2.0, 0.9.3.0, 0.9.3.1, 0.9.4.0, 0.9.4.1, 0.9.4.2 (info)
Dependencies base (>=4.3 && <5), bytestring, unix, Win32 [details]
License BSD-3-Clause
Copyright (c) 2010 Grant Monroe (c) 2011 Leon P Smith
Author Grant Monroe, Leon P Smith, Joey Adams
Maintainer Oleg Grenrus <oleg.grenrus@iki.fi>
Revised Revision 3 made by phadej at Mon Sep 24 21:12:02 UTC 2018
Category Database
Home page https://github.com/phadej/postgresql-libpq
Source repo head: git clone https://github.com/phadej/postgresql-libpq
this: git clone https://github.com/phadej/postgresql-libpq(tag v0.9.4.0)
Uploaded by LeonSmith at Thu Jan 25 22:23:12 UTC 2018
Distributions Arch:0.9.4.2, Debian:0.9.4.1, LTSHaskell:0.9.4.2, NixOS:0.9.4.2, Stackage:0.9.4.2
Downloads 35685 total (195 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2018-01-25 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Flags

NameDescriptionDefaultType
use-pkg-configDisabledManual

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees