prelude-safeenum: A redefinition of the Prelude's Enum class in order to render it safe.

[ bsd3, library, prelude ] [ Propose Tags ]
Versions 0.1.0,, 0.1.1,,
Dependencies base (<5) [details]
License BSD-3-Clause
Copyright Copyright (c) 2012--2013 wren ng thornton
Author wren ng thornton
Category Prelude
Home page
Source repo head: darcs get
Uploaded by WrenThornton at Sat Jun 1 22:57:57 UTC 2013
Distributions LTSHaskell:, NixOS:, Stackage:, openSUSE:
Downloads 1792 total (15 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

A redefinition of the Prelude's Enum class in order to render it safe. That is, the Haskell Language Report defines pred, succ, fromEnum, and toEnum to be partial functions when the type is Bounded, but this is unacceptable. We define a new type-class hierarchy for enumeration which is safe and also generalizes to cover types which can only be enumerated in one direction.

[Skip to Readme]





base-4.0 emits "Prelude deprecated" messages in order to get people to be explicit about which version of base they use.


Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info


Maintainer's Corner

For package maintainers and hackage trustees

Readme for prelude-safeenum-

[back to package description]

This is a very simple package and should be easy to install. You
should be able to use any of the following standard methods to
install it.

    -- With cabal-install and without the source:
    $> cabal install prelude-safeenum
    -- With cabal-install and with the source already:
    $> cd prelude-safeenum
    $> cabal install
    -- Without cabal-install, but with the source already:
    $> cd prelude-safeenum
    $> runhaskell Setup.hs configure --user
    $> runhaskell Setup.hs build
    $> runhaskell Setup.hs test
    $> runhaskell Setup.hs haddock --hyperlink-source
    $> runhaskell Setup.hs copy
    $> runhaskell Setup.hs register

The test step is optional and currently does nothing. The Haddock
step is also optional.


An attempt has been made to keep this library portable; however,
it does rely on a few language extensions. All the required language
extensions are:

    MagicHash    -- only for GHC
    Trustworthy  -- only for GHC >= 7.1

The GeneralizedNewtypeDeriving extension is used for brevity in
Data.Number.CalkinWilf. If you'd like to use this package with a
compiler that does not support that extension, contact the maintainer
and it can be removed.

This package is only "Trustworthy" rather than "Safe" for two
reasons: (1) Data.Number.CalkinWilf uses GeneralizedNewtypeDeriving,
and (2) Prelude.SafeEnum imports GHC.Exts for build/foldr fusion
and for the Char instances.

----------------------------------------------------------- fin.