Build #1 for pretty-show-1.6.3

[all reports]

Package pretty-show-1.6.3
Install ConfigureFailed
Docs NotTried
Tests NotTried
Time submitted unknown
Compiler ghc-7.6.3
OS linux
Arch x86_64
Dependencies pretty-1.1.1.0, haskell-lexer-1.0, ghc-prim-0.3.0.0, filepath-1.3.0.1, base-4.6.0.1, array-0.4.0.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring haskell-lexer-1.0...
Building haskell-lexer-1.0...
Preprocessing library haskell-lexer-1.0...
[1 of 6] Compiling Language.Haskell.Lexer.Tokens ( Language/Haskell/Lexer/Tokens.hs, dist/build/Language/Haskell/Lexer/Tokens.o )
[2 of 6] Compiling Language.Haskell.Lexer.Utils ( Language/Haskell/Lexer/Utils.hs, dist/build/Language/Haskell/Lexer/Utils.o )
[3 of 6] Compiling Language.Haskell.Lexer.Lex ( Language/Haskell/Lexer/Lex.hs, dist/build/Language/Haskell/Lexer/Lex.o )
[4 of 6] Compiling Language.Haskell.Lexer.Position ( Language/Haskell/Lexer/Position.hs, dist/build/Language/Haskell/Lexer/Position.o )

Language/Haskell/Lexer/Position.hs:25:5: Warning:
    Pattern match(es) are overlapped
    In a case alternative: '\n' -> ...
[5 of 6] Compiling Language.Haskell.Lexer.Layout ( Language/Haskell/Lexer/Layout.hs, dist/build/Language/Haskell/Lexer/Layout.o )
[6 of 6] Compiling Language.Haskell.Lexer ( Language/Haskell/Lexer.hs, dist/build/Language/Haskell/Lexer.o )
In-place registering haskell-lexer-1.0...
Running Haddock for haskell-lexer-1.0...
Running hscolour for haskell-lexer-1.0...
Preprocessing library haskell-lexer-1.0...
Preprocessing library haskell-lexer-1.0...
Haddock coverage:
  50% (  1 /  2) in 'Language.Haskell.Lexer.Tokens'
  17% (  1 /  6) in 'Language.Haskell.Lexer.Utils'
   0% (  0 /  2) in 'Language.Haskell.Lexer.Lex'
  83% (  5 /  6) in 'Language.Haskell.Lexer.Position'
  33% (  1 /  3) in 'Language.Haskell.Lexer.Layout'
  85% ( 11 / 13) in 'Language.Haskell.Lexer'
Documentation created: dist/doc/html/haskell-lexer/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/x86_64-linux-ghc-7.6.3/haskell-lexer-1.0
Registering haskell-lexer-1.0...
Installed haskell-lexer-1.0
Configuring pretty-show-1.6.3...
cabal: The program happy version >=1.19 is required but the version found at
/usr/bin/happy is version 1.18.9
Failed to install pretty-show-1.6.3
cabal: Error: some packages failed to install:
pretty-show-1.6.3 failed during the configure step. The exception was:
ExitFailure 1