Build #9 for puppetresources-0.4.2

[all reports]

Package puppetresources-0.4.2
Install DependencyFailed hruby-0.3.4.2
Docs NotTried
Tests NotTried
Time submitted 2016-12-21 07:59:44.485323 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies Diff-0.3.4, base-4.9.0.0, bytestring-0.10.8.1, containers-0.5.7.1, hsfacter-0.2.1, hslogger-1.2.10, language-puppet-1.3.4, mtl-2.2.1, text-1.2.2.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring ansi-terminal-0.6.2.3...
Configuring Diff-0.3.4...
Building ansi-terminal-0.6.2.3...
Building Diff-0.3.4...
Installed Diff-0.3.4
Configuring base-orphans-0.5.4...
Configuring base-compat-0.9.1...
Installed ansi-terminal-0.6.2.3
Building base-orphans-0.5.4...
Building base-compat-0.9.1...
Configuring base16-bytestring-0.1.1.6...
Installed base-orphans-0.5.4
Building base16-bytestring-0.1.1.6...
Configuring base64-bytestring-1.0.0.1...
Installed base16-bytestring-0.1.1.6
Building base64-bytestring-1.0.0.1...
Configuring call-stack-0.1.0...
Installed base-compat-0.9.1
Building call-stack-0.1.0...
Configuring cereal-0.5.4.0...
Installed call-stack-0.1.0
Configuring byteable-0.1.1...
Installed base64-bytestring-1.0.0.1
Building cereal-0.5.4.0...
Building byteable-0.1.1...
Configuring clock-0.7.2...
Installed byteable-0.1.1
Building clock-0.7.2...
Configuring data-default-class-0.1.2.0...
Installed clock-0.7.2
Building data-default-class-0.1.2.0...
Configuring dlist-0.8.0.2...
Installed cereal-0.5.4.0
Building dlist-0.8.0.2...
Configuring extensible-exceptions-0.1.1.4...
Installed data-default-class-0.1.2.0
Building extensible-exceptions-0.1.1.4...
Configuring hourglass-0.2.10...
Installed extensible-exceptions-0.1.1.4
Building hourglass-0.2.10...
Configuring foundation-0.0.2...
Installed dlist-0.8.0.2
Building foundation-0.0.2...
Configuring hspec-discover-2.3.2...
Installed hourglass-0.2.10
Building hspec-discover-2.3.2...
Configuring mtl-2.2.1...
Installed hspec-discover-2.3.2
Building mtl-2.2.1...
Configuring network-2.6.3.1...
Installed mtl-2.2.1
Building network-2.6.3.1...
Configuring old-locale-1.0.0.7...
Installed network-2.6.3.1
Building old-locale-1.0.0.7...
Configuring parallel-3.2.1.0...
Installed old-locale-1.0.0.7
Building parallel-3.2.1.0...
Configuring prelude-extras-0.4.0.3...
Installed parallel-3.2.1.0
Building prelude-extras-0.4.0.3...
Configuring primitive-0.6.1.0...
Installed foundation-0.0.2
Building primitive-0.6.1.0...
Configuring random-1.1...
Installed prelude-extras-0.4.0.3
Building random-1.1...
Configuring reflection-2.1.2...
Installed primitive-0.6.1.0
Building reflection-2.1.2...
Configuring safe-0.3.10...
Installed random-1.1
Building safe-0.3.10...
Configuring semigroups-0.18.2...
Installed safe-0.3.10
Building semigroups-0.18.2...
Configuring setenv-0.1.1.3...
Installed reflection-2.1.2
Building setenv-0.1.1.3...
Configuring split-0.2.3.1...
Installed semigroups-0.18.2
Building split-0.2.3.1...
Configuring stm-2.4.4.1...
Installed setenv-0.1.1.3
Building stm-2.4.4.1...
Configuring strict-0.3.2...
Installed split-0.2.3.1
Building strict-0.3.2...
Configuring text-1.2.2.1...
Installed stm-2.4.4.1
Building text-1.2.2.1...
Configuring time-locale-compat-0.1.1.3...
Installed strict-0.3.2
Building time-locale-compat-0.1.1.3...
Configuring transformers-compat-0.5.1.4...
Installed time-locale-compat-0.1.1.3
Building transformers-compat-0.5.1.4...
Configuring utf8-string-1.0.1.1...
Installed transformers-compat-0.5.1.4
Building utf8-string-1.0.1.1...
Configuring zlib-0.6.1.2...
Installed utf8-string-1.0.1.1
Building zlib-0.6.1.2...
Installed zlib-0.6.1.2
Configuring ansi-wl-pprint-0.6.7.3...
Building ansi-wl-pprint-0.6.7.3...
Configuring pem-0.2.2...
Installed text-1.2.2.1
Building pem-0.2.2...
Configuring regex-base-0.93.2...
Installed ansi-wl-pprint-0.6.7.3
Building regex-base-0.93.2...
Configuring HUnit-1.5.0.0...
Installed pem-0.2.2
Building HUnit-1.5.0.0...
Configuring socks-0.5.5...
Installed regex-base-0.93.2
Building socks-0.5.5...
Configuring hslogger-1.2.10...
Installed HUnit-1.5.0.0
Building hslogger-1.2.10...
Configuring memory-0.14...
Installed socks-0.5.5
Building memory-0.14...
Configuring operational-0.2.3.5...
Installed hslogger-1.2.10
Building operational-0.2.3.5...
Configuring vector-0.11.0.0...
Installed operational-0.2.3.5
Building vector-0.11.0.0...
Configuring tf-random-0.5...
Installed memory-0.14
Building tf-random-0.5...
Configuring parallel-io-0.3.3...
Installed tf-random-0.5
Building parallel-io-0.3.3...
Configuring StateVar-1.1.0.4...
Installed parallel-io-0.3.3
Building StateVar-1.1.0.4...
Configuring async-2.1.1...
Installed StateVar-1.1.0.4
Building async-2.1.1...
Configuring MonadRandom-0.4.2.3...
Installed async-2.1.1
Building MonadRandom-0.4.2.3...
Configuring exceptions-0.8.3...
Installed MonadRandom-0.4.2.3
Building exceptions-0.8.3...
Configuring Glob-0.7.13...
Installed exceptions-0.8.3
Building Glob-0.7.13...
Configuring mmorph-1.0.9...
Installed vector-0.11.0.0
Configuring tagged-0.8.5...
Installed Glob-0.7.13
Building mmorph-1.0.9...
Building tagged-0.8.5...
Configuring transformers-base-0.4.4...
Installed mmorph-1.0.9
Building transformers-base-0.4.4...
Installed tagged-0.8.5
Configuring blaze-builder-0.4.0.2...
Building blaze-builder-0.4.0.2...
Configuring mime-types-0.1.0.7...
Installed transformers-base-0.4.4
Building mime-types-0.1.0.7...
Configuring hashable-1.2.4.0...
Installed blaze-builder-0.4.0.2
Building hashable-1.2.4.0...
Configuring double-conversion-2.0.2.0...
Installed hashable-1.2.4.0
Building double-conversion-2.0.2.0...
Configuring string-conversions-0.4...
Installed mime-types-0.1.0.7
Building string-conversions-0.4...
Configuring parsec-3.1.11...
Installed string-conversions-0.4
Building parsec-3.1.11...
Configuring regex-pcre-builtin-0.94.4.8.8.35...
Installed double-conversion-2.0.2.0
Building regex-pcre-builtin-0.94.4.8.8.35...
Configuring optparse-applicative-0.13.0.0...
Installed parsec-3.1.11
Building optparse-applicative-0.13.0.0...
Configuring asn1-types-0.3.2...
Installed optparse-applicative-0.13.0.0
Configuring hspec-expectations-0.8.2...
Installed regex-pcre-builtin-0.94.4.8.8.35
Building asn1-types-0.3.2...
Building hspec-expectations-0.8.2...
Configuring QuickCheck-2.9.2...
Installed hspec-expectations-0.8.2
Building QuickCheck-2.9.2...
Configuring cryptonite-0.21...
Installed asn1-types-0.3.2
Building cryptonite-0.21...
Configuring hinotify-0.3.9...
Installed QuickCheck-2.9.2
Building hinotify-0.3.9...
Configuring distributive-0.5.0.2...
Installed hinotify-0.3.9
Building distributive-0.5.0.2...
Installed distributive-0.5.0.2
Configuring cookie-0.4.2.1...
Building cookie-0.4.2.1...
Configuring monad-control-1.0.1.0...
Installed cookie-0.4.2.1
Building monad-control-1.0.1.0...
Configuring streaming-commons-0.1.16...
Installed monad-control-1.0.1.0
Building streaming-commons-0.1.16...
Configuring case-insensitive-1.2.0.7...
Installed cryptonite-0.21
Building case-insensitive-1.2.0.7...
Configuring scientific-0.3.4.9...
Installed case-insensitive-1.2.0.7
Configuring unordered-containers-0.2.7.1...
Installed streaming-commons-0.1.16
Building scientific-0.3.4.9...
Building unordered-containers-0.2.7.1...
Configuring uuid-types-1.0.3...
Installed scientific-0.3.4.9
Building uuid-types-1.0.3...
Configuring void-0.7.1...
Installed uuid-types-1.0.3
Configuring text-format-0.3.1.1...
Installed unordered-containers-0.2.7.1
Building void-0.7.1...
Building text-format-0.3.1.1...
Configuring network-uri-2.6.1.0...
Installed void-0.7.1
Building network-uri-2.6.1.0...
Configuring asn1-encoding-0.9.4...
Installed text-format-0.3.1.1
Building asn1-encoding-0.9.4...
Configuring quickcheck-io-0.1.4...
Installed network-uri-2.6.1.0
Building quickcheck-io-0.1.4...
Installed quickcheck-io-0.1.4
Configuring http-media-0.6.4...
Building http-media-0.6.4...
Configuring lifted-base-0.2.3.8...
Installed asn1-encoding-0.9.4
Building lifted-base-0.2.3.8...
Configuring http-types-0.9.1...
Installed http-media-0.6.4
Building http-types-0.9.1...
Configuring attoparsec-0.13.1.0...
Installed lifted-base-0.2.3.8
Building attoparsec-0.13.1.0...
Configuring vault-0.3.0.6...
Installed http-types-0.9.1
Building vault-0.3.0.6...
Configuring contravariant-1.4...
Installed vault-0.3.0.6
Building contravariant-1.4...
Configuring megaparsec-5.1.2...
Installed attoparsec-0.13.1.0
Building megaparsec-5.1.2...
Configuring formatting-6.2.4...
Installed contravariant-1.4
Building formatting-6.2.4...
Configuring hspec-core-2.3.2...
Installed formatting-6.2.4
Building hspec-core-2.3.2...
Installed megaparsec-5.1.2
Configuring asn1-parse-0.9.4...
Building asn1-parse-0.9.4...
Configuring resourcet-1.1.9...
Installed asn1-parse-0.9.4
Building resourcet-1.1.9...
Configuring enclosed-exceptions-1.0.2...
Installed hspec-core-2.3.2
Building enclosed-exceptions-1.0.2...
Configuring http-client-0.5.4...
Installed enclosed-exceptions-1.0.2
Building http-client-0.5.4...
Configuring pcre-utils-0.1.8.1...
Installed resourcet-1.1.9
Building pcre-utils-0.1.8.1...
Configuring aeson-1.0.2.1...
Installed pcre-utils-0.1.8.1
Building aeson-1.0.2.1...
Configuring uri-bytestring-0.2.2.1...
Installed http-client-0.5.4
Building uri-bytestring-0.2.2.1...
Configuring comonad-5...
Installed uri-bytestring-0.2.2.1
Building comonad-5...
Installed comonad-5
Configuring x509-1.6.5...
Building x509-1.6.5...
Installed aeson-1.0.2.1
Configuring hspec-2.3.2...
Building hspec-2.3.2...
Configuring conduit-1.2.8...
Installed hspec-2.3.2
Configuring http-api-data-0.3.3...
Installed x509-1.6.5
Building conduit-1.2.8...
Building http-api-data-0.3.3...
Configuring bifunctors-5.4.1...
Installed conduit-1.2.8
Installed http-api-data-0.3.3
Configuring hruby-0.3.4.2...
Building bifunctors-5.4.1...
Failed to install hruby-0.3.4.2
Build log ( /home/builder/.cabal/logs/hruby-0.3.4.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-3906/hruby-0.3.4.2'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-3906/hruby-0.3.4.2/dist/setup/setup.hs, /tmp/cabal-tmp-3906/hruby-0.3.4.2/dist/setup/Main.o )
Linking /tmp/cabal-tmp-3906/hruby-0.3.4.2/dist/setup/setup ...
Configuring hruby-0.3.4.2...
Warning: Could not find the ruby library. Ensure that it is present on your
system (on Debian/Ubuntu, make sure you installed the ruby1.8-dev package).
If you know it to be installed, please install hruby in the following way
(example for nix):

$ cabal install hruby -p --configure-option="--rubyversion=19 --rubylib=ruby
--rubyinc=/nix/store/v0w14mdpcy9c0qwvhqa7154qsv53ifqn-ruby-1.9.3-p484/include/ruby-1.9.1
--rubyinc=/nix/store/v0w14mdpcy9c0qwvhqa7154qsv53ifqn-ruby-1.9.3-p484/include/ruby-1.9.1/x86_64-linux'
--extra-lib-dirs=$HOME/.nix-profile/lib/"

--rubylib : Should be the name of the library passed to the linker (ruby for
libruby.so).
--rubyinc : There can be several instances of this flag. Should be the path of
the various ruby header files.
--rubyversion : Mandatory for ruby 2.0 and 2.1, should have the values 20 or
21.
setup: Missing dependency on a foreign library:
* Missing (or bad) header file: ruby.h
* Missing C library: ruby
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
If the header file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.
cabal: Leaving directory '/tmp/cabal-tmp-3906/hruby-0.3.4.2'
Configuring x509-store-1.6.2...
Building x509-store-1.6.2...
Configuring yaml-0.8.21.1...
Installed x509-store-1.6.2
Building yaml-0.8.21.1...
Configuring servant-0.9.1.1...
Installed bifunctors-5.4.1
Building servant-0.9.1.1...
Installed servant-0.9.1.1
Configuring x509-system-1.6.4...
Building x509-system-1.6.4...
Configuring x509-validation-1.6.5...
Installed x509-system-1.6.4
Building x509-validation-1.6.5...
Configuring semigroupoids-5.1...
Installed x509-validation-1.6.5
Configuring profunctors-5.2...
Installed yaml-0.8.21.1
Building profunctors-5.2...
Building semigroupoids-5.1...
Installed profunctors-5.2
Configuring tls-1.3.9...
Building tls-1.3.9...
Installed semigroupoids-5.1
Configuring free-4.12.4...
Building free-4.12.4...
Installed free-4.12.4
Configuring either-4.4.1.1...
Building either-4.4.1.1...
Configuring adjunctions-4.3...
Installed tls-1.3.9
Building adjunctions-4.3...
Configuring connection-0.2.6...
Installed either-4.4.1.1
Building connection-0.2.6...
Installed connection-0.2.6
Configuring http-client-tls-0.3.3...
Installed adjunctions-4.3
Configuring kan-extensions-5.0.1...
Building http-client-tls-0.3.3...
Building kan-extensions-5.0.1...
Installed http-client-tls-0.3.3
Configuring servant-client-0.9.1.1...
Building servant-client-0.9.1.1...
Installed kan-extensions-5.0.1
Configuring lens-4.15.1...
Installed servant-client-0.9.1.1
Building lens-4.15.1...
Installed lens-4.15.1
Configuring strict-base-types-0.5.0...
Configuring lens-aeson-1.0.0.5...
Building strict-base-types-0.5.0...
Building lens-aeson-1.0.0.5...
Installed strict-base-types-0.5.0
Configuring filecache-0.2.9...
Building filecache-0.2.9...
Installed lens-aeson-1.0.0.5
Installed filecache-0.2.9
cabal: Error: some packages failed to install:
hruby-0.3.4.2 failed during the configure step. The exception was:
ExitFailure 1
hsfacter-0.2.1 depends on hruby-0.3.4.2 which failed to install.
language-puppet-1.3.4 depends on hruby-0.3.4.2 which failed to install.
puppetresources-0.4.2 depends on hruby-0.3.4.2 which failed to install.