semialign-optics: SemialignWithIndex, i.e. izipWith and ialignWith

[ bsd3, data, deprecated, library, these ] [ Propose Tags ]
Deprecated. in favor of semialign

This package is deprecated. It simply re-exports semialign (and adds a optics-core constraint).

Versions [RSS] [faq] 1.1, 1.2
Change log CHANGELOG.md
Dependencies base (>=4.10.0.0 && <4.17), optics-core (==0.4.*), semialign (>=1.2 && <1.2.1) [details]
License BSD-3-Clause
Author C. McCann, Oleg Grenrus
Maintainer Oleg Grenrus <oleg.grenrus@iki.fi>
Revised Revision 1 made by phadej at 2022-01-02T18:33:33Z
Category Data, These
Home page https://github.com/haskellari/these
Source repo head: git clone https://github.com/haskellari/these.git(semialign-optics)
Uploaded by phadej at 2021-02-25T11:44:00Z
Distributions LTSHaskell:1.1, NixOS:1.1, Stackage:1.2
Downloads 519 total (15 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs not available [build log]
Last success reported on 2021-02-25 [all 2 reports]

Modules

  • Data
    • Semialign
      • Data.Semialign.Indexed

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees

Candidates