The snap package

[Tags: bsd3, library, program]

This is the top-level package for the official Snap Framework libraries. It includes:

To get started, issue the following sequence of commands:

$ cabal install snap
$ mkdir myproject
$ cd myproject
$ snap init

If you have trouble or any questions, see our FAQ page (http://snapframework.com/faq) or the documentation (http://snapframework.com/docs).


Properties

Versions0.3.0, 0.3.0.1, 0.3.1, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.5.0, 0.5.1, 0.5.1.1, 0.5.1.2, 0.5.1.3, 0.5.2, 0.5.3, 0.5.3.1, 0.5.4, 0.5.5, 0.5.5.1, 0.6.0, 0.6.0.1, 0.6.0.2, 0.7, 0.8.0, 0.8.0.1, 0.8.0.2, 0.8.1, 0.9.0, 0.9.0.1, 0.9.1, 0.9.1.1, 0.9.2, 0.9.2.1, 0.9.2.2, 0.10.0, 0.10.0.1, 0.11.0, 0.11.1, 0.11.2, 0.11.2.1, 0.11.2.2, 0.11.3, 0.11.3.1, 0.12.0, 0.12.1, 0.13.0, 0.13.0.1, 0.13.0.2, 0.13.0.3, 0.13.0.4, 0.13.1, 0.13.1.1, 0.13.1.2, 0.13.2.0, 0.13.2.1, 0.13.2.2, 0.13.2.3, 0.13.2.4, 0.13.2.5, 0.13.2.6, 0.13.2.7, 0.13.2.8, 0.13.2.9, 0.13.3, 0.13.3.1
Dependenciesaeson (==0.6.*), attoparsec (>=0.10 && <0.12), base (>=4 && <4.4), bytestring (>=0.9.1 && <0.11), cereal (>=0.3 && <0.5), clientsession (>=0.8 && <0.10), comonad (>=1.1 && <4.1), configurator (>=0.1 && <0.3), containers (>=0.3 && <0.6), directory (>=1.0 && <1.3), directory-tree (==0.11.*), dlist (>=0.5 && <0.7), errors (==1.4.*), filepath (>=1.1 && <1.4), hashable (==1.1.*), heist (==0.13.*), lens (>=3.7.6 && <3.8), logict (>=0.4.2 && <0.7), MonadCatchIO-transformers (>=0.2 && <0.4), mtl (>2.0 && <2.2), mwc-random (>=0.8 && <0.14), old-time (>=1.0 && <1.2), pwstore-fast (>=2.2 && <2.5), regex-posix (>=0.95 && <1), snap-core (>=0.9 && <0.11), snap-server (>=0.9 && <0.11), stm (>=2.2 && <2.5), syb (>=0.1 && <0.5), template-haskell (>=2.2 && <2.9), text (>=0.11 && <1.2), time (>=1.1 && <1.5), transformers (>=0.2 && <0.4), unordered-containers (>=0.1.4 && <0.3), vector (>=0.7.1 && <0.11), vector-algorithms (>=0.4 && <0.7), xmlhtml (>=0.1 && <0.3) or
aeson (==0.6.*), attoparsec (>=0.10 && <0.12), base (>=4 && <4.4), bytestring (>=0.9.1 && <0.11), cereal (>=0.3 && <0.5), clientsession (>=0.8 && <0.10), comonad (>=1.1 && <4.1), configurator (>=0.1 && <0.3), containers (>=0.3 && <0.6), directory (>=1.0 && <1.3), directory-tree (==0.11.*), dlist (>=0.5 && <0.7), errors (==1.4.*), filepath (>=1.1 && <1.4), hashable (>=1.2.0.6 && <1.3), heist (==0.13.*), lens (>=3.7.6 && <3.8), logict (>=0.4.2 && <0.7), MonadCatchIO-transformers (>=0.2 && <0.4), mtl (>2.0 && <2.2), mwc-random (>=0.8 && <0.14), old-time (>=1.0 && <1.2), pwstore-fast (>=2.2 && <2.5), regex-posix (>=0.95 && <1), snap-core (>=0.9 && <0.11), snap-server (>=0.9 && <0.11), stm (>=2.2 && <2.5), syb (>=0.1 && <0.5), template-haskell (>=2.2 && <2.9), text (>=0.11 && <1.2), time (>=1.1 && <1.5), transformers (>=0.2 && <0.4), unordered-containers (>=0.1.4 && <0.3), vector (>=0.7.1 && <0.11), vector-algorithms (>=0.4 && <0.7), xmlhtml (>=0.1 && <0.3) or
aeson (==0.6.*), attoparsec (>=0.10 && <0.12), base (>=4.4 && <5), bytestring (>=0.9.1 && <0.11), cereal (>=0.3 && <0.5), clientsession (>=0.8 && <0.10), comonad (>=1.1 && <4.1), configurator (>=0.1 && <0.3), containers (>=0.3 && <0.6), directory (>=1.0 && <1.3), directory-tree (==0.11.*), dlist (>=0.5 && <0.7), errors (==1.4.*), filepath (>=1.1 && <1.4), hashable (==1.1.*), heist (==0.13.*), lens (>=3.7.6 && <3.11), logict (>=0.4.2 && <0.7), MonadCatchIO-transformers (>=0.2 && <0.4), mtl (>2.0 && <2.2), mwc-random (>=0.8 && <0.14), old-time (>=1.0 && <1.2), pwstore-fast (>=2.2 && <2.5), regex-posix (>=0.95 && <1), snap-core (>=0.9 && <0.11), snap-server (>=0.9 && <0.11), stm (>=2.2 && <2.5), syb (>=0.1 && <0.5), template-haskell (>=2.2 && <2.9), text (>=0.11 && <1.2), time (>=1.1 && <1.5), transformers (>=0.2 && <0.4), unordered-containers (>=0.1.4 && <0.3), vector (>=0.7.1 && <0.11), vector-algorithms (>=0.4 && <0.7), xmlhtml (>=0.1 && <0.3) or
aeson (==0.6.*), attoparsec (>=0.10 && <0.12), base (>=4.4 && <5), bytestring (>=0.9.1 && <0.11), cereal (>=0.3 && <0.5), clientsession (>=0.8 && <0.10), comonad (>=1.1 && <4.1), configurator (>=0.1 && <0.3), containers (>=0.3 && <0.6), directory (>=1.0 && <1.3), directory-tree (==0.11.*), dlist (>=0.5 && <0.7), errors (==1.4.*), filepath (>=1.1 && <1.4), hashable (>=1.2.0.6 && <1.3), heist (==0.13.*), lens (>=3.7.6 && <3.11), logict (>=0.4.2 && <0.7), MonadCatchIO-transformers (>=0.2 && <0.4), mtl (>2.0 && <2.2), mwc-random (>=0.8 && <0.14), old-time (>=1.0 && <1.2), pwstore-fast (>=2.2 && <2.5), regex-posix (>=0.95 && <1), snap-core (>=0.9 && <0.11), snap-server (>=0.9 && <0.11), stm (>=2.2 && <2.5), syb (>=0.1 && <0.5), template-haskell (>=2.2 && <2.9), text (>=0.11 && <1.2), time (>=1.1 && <1.5), transformers (>=0.2 && <0.4), unordered-containers (>=0.1.4 && <0.3), vector (>=0.7.1 && <0.11), vector-algorithms (>=0.4 && <0.7), xmlhtml (>=0.1 && <0.3)
LicenseBSD3
AuthorOzgun Ataman, Doug Beardsley, Gregory Collins, Carl Howells, Chris Smith
Maintainersnap@snapframework.com
CategoryWeb, Snap
Home pagehttp://snapframework.com/
Source repositoryhead: git clone https://github.com/snapframework/snap.git
Executablessnap
Upload dateMon Jan 13 16:32:46 UTC 2014
Uploaded byGregoryCollins
DistributionsDebian:0.13.2.5, FreeBSD:0.12.0, NixOS:0.13.3.1
Downloads13142 total (1089 in last 30 days)

Modules

[Index]

Flags

NameDescriptionDefault
old-baseDisabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees