Build #2 for snaplet-scoped-session-0.1.1

[all reports]

Package snaplet-scoped-session-0.1.1
Install DependencyFailed vector-0.11.0.0
Docs NotTried
Tests NotTried
Time submitted 2016-11-21 08:13:56.759205 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies async-2.1.1, base-4.9.0.0, classy-prelude-1.0.1, configurator-0.3.0.0, data-default-0.7.1.1, lens-4.15.1, mtl-2.2.1, snap-1.0.0.1, time-1.6.0.1, unordered-containers-0.2.7.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring base-compat-0.9.1...
Configuring base-orphans-0.5.4...
Building base-compat-0.9.1...
Building base-orphans-0.5.4...
Installed base-orphans-0.5.4
Configuring base64-bytestring-1.0.0.1...
Building base64-bytestring-1.0.0.1...
Installed base-compat-0.9.1
Configuring byteable-0.1.1...
Building byteable-0.1.1...
Configuring bytestring-builder-0.10.8.1.0...
Installed base64-bytestring-1.0.0.1
Building bytestring-builder-0.10.8.1.0...
Configuring call-stack-0.1.0...
Installed bytestring-builder-0.10.8.1.0
Configuring cereal-0.5.4.0...
Installed byteable-0.1.1
Building call-stack-0.1.0...
Building cereal-0.5.4.0...
Configuring clock-0.7.2...
Installed call-stack-0.1.0
Building clock-0.7.2...
Configuring data-default-class-0.1.2.0...
Installed clock-0.7.2
Building data-default-class-0.1.2.0...
Configuring directory-tree-0.12.1...
Installed cereal-0.5.4.0
Configuring dlist-0.8.0.2...
Installed data-default-class-0.1.2.0
Building directory-tree-0.12.1...
Building dlist-0.8.0.2...
Configuring entropy-0.3.7...
Installed directory-tree-0.12.1
Configuring mtl-2.2.1...
Installed dlist-0.8.0.2
Building mtl-2.2.1...
Building entropy-0.3.7...
Configuring memory-0.13...
Installed mtl-2.2.1
Configuring old-locale-1.0.0.7...
Installed entropy-0.3.7
Building memory-0.13...
Building old-locale-1.0.0.7...
Configuring parallel-3.2.1.0...
Installed old-locale-1.0.0.7
Building parallel-3.2.1.0...
Configuring network-2.6.3.1...
Installed parallel-3.2.1.0
Configuring prelude-extras-0.4.0.3...
Installed memory-0.13
Building prelude-extras-0.4.0.3...
Building network-2.6.3.1...
Configuring primitive-0.6.2.0...
Installed prelude-extras-0.4.0.3
Building primitive-0.6.2.0...
Configuring reflection-2.1.2...
Installed network-2.6.3.1
Building reflection-2.1.2...
Configuring safe-0.3.10...
Installed primitive-0.6.2.0
Building safe-0.3.10...
Configuring random-1.1...
Installed reflection-2.1.2
Configuring semigroups-0.18.2...
Installed safe-0.3.10
Building random-1.1...
Building semigroups-0.18.2...
Configuring stm-2.4.4.1...
Installed semigroups-0.18.2
Building stm-2.4.4.1...
Configuring split-0.2.3.1...
Installed random-1.1
Building split-0.2.3.1...
Configuring setenv-0.1.1.3...
Installed stm-2.4.4.1
Building setenv-0.1.1.3...
Configuring time-locale-compat-0.1.1.3...
Installed split-0.2.3.1
Building time-locale-compat-0.1.1.3...
Configuring transformers-compat-0.5.1.4...
Installed setenv-0.1.1.3
Building transformers-compat-0.5.1.4...
Configuring unix-compat-0.4.2.0...
Installed time-locale-compat-0.1.1.3
Building unix-compat-0.4.2.0...
Configuring text-1.2.2.1...
Installed transformers-compat-0.5.1.4
Building text-1.2.2.1...
Configuring zlib-0.6.1.2...
Installed unix-compat-0.4.2.0
Building zlib-0.6.1.2...
Installed zlib-0.6.1.2
Configuring data-default-instances-containers-0.0.1...
Building data-default-instances-containers-0.0.1...
Configuring data-default-instances-dlist-0.0.1...
Installed data-default-instances-containers-0.0.1
Building data-default-instances-dlist-0.0.1...
Configuring map-syntax-0.2.0.1...
Installed data-default-instances-dlist-0.0.1
Building map-syntax-0.2.0.1...
Configuring regex-base-0.93.2...
Installed map-syntax-0.2.0.1
Building regex-base-0.93.2...
Configuring HUnit-1.5.0.0...
Installed regex-base-0.93.2
Building HUnit-1.5.0.0...
Configuring data-default-instances-old-locale-0.0.1...
Installed text-1.2.2.1
Building data-default-instances-old-locale-0.0.1...
Configuring securemem-0.1.9...
Installed data-default-instances-old-locale-0.0.1
Building securemem-0.1.9...
Configuring cryptonite-0.20...
Installed HUnit-1.5.0.0
Building cryptonite-0.20...
Configuring dlist-instances-0.1.1.1...
Installed securemem-0.1.9
Building dlist-instances-0.1.1.1...
Configuring StateVar-1.1.0.4...
Installed dlist-instances-0.1.1.1
Building StateVar-1.1.0.4...
Configuring stm-chans-3.0.0.4...
Installed StateVar-1.1.0.4
Building stm-chans-3.0.0.4...
Configuring async-2.1.1...
Installed stm-chans-3.0.0.4
Building async-2.1.1...
Configuring vector-0.11.0.0...
Installed async-2.1.1
Building vector-0.11.0.0...
Configuring exceptions-0.8.3...
Failed to install vector-0.11.0.0
Build log ( /home/builder/.cabal/logs/vector-0.11.0.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-26029/vector-0.11.0.0'
Configuring vector-0.11.0.0...
Building vector-0.11.0.0...
Preprocessing library vector-0.11.0.0...
[ 1 of 21] Compiling Data.Vector.Storable.Internal ( Data/Vector/Storable/Internal.hs, dist/build/Data/Vector/Storable/Internal.o )

Data/Vector/Storable/Internal.hs:17:1: warning: [-Wunused-imports]
    The import of ‘Foreign.ForeignPtr’ is redundant
      except perhaps to import instances from ‘Foreign.ForeignPtr’
    To import instances alone, use: import Foreign.ForeignPtr()

Data/Vector/Storable/Internal.hs:18:1: warning: [-Wunused-imports]
    The import of ‘Foreign.Ptr’ is redundant
      except perhaps to import instances from ‘Foreign.Ptr’
    To import instances alone, use: import Foreign.Ptr()
[ 2 of 21] Compiling Data.Vector.Internal.Check ( Data/Vector/Internal/Check.hs, dist/build/Data/Vector/Internal/Check.o )
[ 3 of 21] Compiling Data.Vector.Generic.Mutable.Base ( Data/Vector/Generic/Mutable/Base.hs, dist/build/Data/Vector/Generic/Mutable/Base.o )
[ 4 of 21] Compiling Data.Vector.Generic.Base ( Data/Vector/Generic/Base.hs, dist/build/Data/Vector/Generic/Base.o )
[ 5 of 21] Compiling Data.Vector.Fusion.Util ( Data/Vector/Fusion/Util.hs, dist/build/Data/Vector/Fusion/Util.o )
[ 6 of 21] Compiling Data.Vector.Fusion.Stream.Monadic ( Data/Vector/Fusion/Stream/Monadic.hs, dist/build/Data/Vector/Fusion/Stream/Monadic.o )
[ 7 of 21] Compiling Data.Vector.Fusion.Bundle.Size ( Data/Vector/Fusion/Bundle/Size.hs, dist/build/Data/Vector/Fusion/Bundle/Size.o )
[ 8 of 21] Compiling Data.Vector.Fusion.Bundle.Monadic ( Data/Vector/Fusion/Bundle/Monadic.hs, dist/build/Data/Vector/Fusion/Bundle/Monadic.o )
[ 9 of 21] Compiling Data.Vector.Fusion.Bundle ( Data/Vector/Fusion/Bundle.hs, dist/build/Data/Vector/Fusion/Bundle.o )

Data/Vector/Fusion/Bundle.hs:114:1: warning: [-Wtabs]
    Tab character found here.
    Please use spaces instead.
[10 of 21] Compiling Data.Vector.Generic.Mutable ( Data/Vector/Generic/Mutable.hs, dist/build/Data/Vector/Generic/Mutable.o )
[11 of 21] Compiling Data.Vector.Mutable ( Data/Vector/Mutable.hs, dist/build/Data/Vector/Mutable.o )
[12 of 21] Compiling Data.Vector.Primitive.Mutable ( Data/Vector/Primitive/Mutable.hs, dist/build/Data/Vector/Primitive/Mutable.o )
[13 of 21] Compiling Data.Vector.Storable.Mutable ( Data/Vector/Storable/Mutable.hs, dist/build/Data/Vector/Storable/Mutable.o )

Data/Vector/Storable/Mutable.hs:72:1: warning: [-Wunused-imports]
    The import of ‘Foreign.Ptr’ is redundant
      except perhaps to import instances from ‘Foreign.Ptr’
    To import instances alone, use: import Foreign.Ptr()
[14 of 21] Compiling Data.Vector.Generic.New ( Data/Vector/Generic/New.hs, dist/build/Data/Vector/Generic/New.o )
[15 of 21] Compiling Data.Vector.Generic ( Data/Vector/Generic.hs, dist/build/Data/Vector/Generic.o )
[16 of 21] Compiling Data.Vector.Primitive ( Data/Vector/Primitive.hs, dist/build/Data/Vector/Primitive.o )
[17 of 21] Compiling Data.Vector.Unboxed.Base ( Data/Vector/Unboxed/Base.hs, dist/build/Data/Vector/Unboxed/Base.o )
[18 of 21] Compiling Data.Vector.Unboxed.Mutable ( Data/Vector/Unboxed/Mutable.hs, dist/build/Data/Vector/Unboxed/Mutable.o )
[19 of 21] Compiling Data.Vector.Storable ( Data/Vector/Storable.hs, dist/build/Data/Vector/Storable.o )
[20 of 21] Compiling Data.Vector.Unboxed ( Data/Vector/Unboxed.hs, dist/build/Data/Vector/Unboxed.o )
[21 of 21] Compiling Data.Vector      ( Data/Vector.hs, dist/build/Data/Vector.o )

Data/Vector.hs:223:14: error:
    Ambiguous occurrence ‘fromList’
    It could refer to either ‘Exts.fromList’,
                             imported from ‘Data.Primitive.Array’ at Data/Vector.hs:164:1-37
                             (and originally defined in ‘GHC.Exts’)
                          or ‘Data.Vector.fromList’, defined at Data/Vector.hs:1528:1

Data/Vector.hs:224:15: error:
    Ambiguous occurrence ‘fromListN’
    It could refer to either ‘Exts.fromListN’,
                             imported from ‘Data.Primitive.Array’ at Data/Vector.hs:164:1-37
                             (and originally defined in ‘GHC.Exts’)
                          or ‘Data.Vector.fromListN’, defined at Data/Vector.hs:1537:1

Data/Vector.hs:344:19: error:
    Ambiguous occurrence ‘fromList’
    It could refer to either ‘Exts.fromList’,
                             imported from ‘Data.Primitive.Array’ at Data/Vector.hs:164:1-37
                             (and originally defined in ‘GHC.Exts’)
                          or ‘Data.Vector.fromList’, defined at Data/Vector.hs:1528:1
cabal: Leaving directory '/tmp/cabal-tmp-26029/vector-0.11.0.0'
Building exceptions-0.8.3...
Configuring tagged-0.8.5...
Installed cryptonite-0.20
Configuring transformers-base-0.4.4...
Installed exceptions-0.8.3
Building tagged-0.8.5...
Building transformers-base-0.4.4...
Configuring zlib-bindings-0.1.1.5...
Installed transformers-base-0.4.4
Building zlib-bindings-0.1.1.5...
Installed tagged-0.8.5
Configuring regex-posix-0.95.2...
Building regex-posix-0.95.2...
Configuring blaze-builder-0.4.0.2...
Installed zlib-bindings-0.1.1.5
Building blaze-builder-0.4.0.2...
Configuring hashable-1.2.4.0...
Installed regex-posix-0.95.2
Building hashable-1.2.4.0...
Configuring parsec-3.1.11...
Installed blaze-builder-0.4.0.2
Building parsec-3.1.11...
Configuring readable-0.3.1...
Installed hashable-1.2.4.0
Building readable-0.3.1...
Configuring say-0.1.0.0...
Installed readable-0.3.1
Building say-0.1.0.0...
Configuring system-filepath-0.4.13.4...
Installed parsec-3.1.11
Configuring data-default-0.7.1.1...
Installed say-0.1.0.0
Building data-default-0.7.1.1...
Configuring crypto-cipher-types-0.0.9...
Installed data-default-0.7.1.1
Building crypto-cipher-types-0.0.9...
Building system-filepath-0.4.13.4...
Configuring cryptohash-0.11.9...
Installed crypto-cipher-types-0.0.9
Building cryptohash-0.11.9...
Configuring safe-exceptions-0.1.4.0...
Installed system-filepath-0.4.13.4
Building safe-exceptions-0.1.4.0...
Configuring monad-control-1.0.1.0...
Installed safe-exceptions-0.1.4.0
Building monad-control-1.0.1.0...
Configuring crypto-api-0.13.2...
Installed cryptohash-0.11.9
Building crypto-api-0.13.2...
Configuring distributive-0.5.0.2...
Installed monad-control-1.0.1.0
Building distributive-0.5.0.2...
Installed crypto-api-0.13.2
Configuring blaze-markup-0.7.1.0...
Building blaze-markup-0.7.1.0...
Configuring case-insensitive-1.2.0.7...
Installed distributive-0.5.0.2
Building case-insensitive-1.2.0.7...
Configuring constraints-0.8...
Installed blaze-markup-0.7.1.0
Installed case-insensitive-1.2.0.7
Configuring void-0.7.1...
Building constraints-0.8...
Building void-0.7.1...
Configuring cipher-aes-0.2.11...
Installed void-0.7.1
Building cipher-aes-0.2.11...
Configuring unordered-containers-0.2.7.1...
Installed constraints-0.8
Configuring ReadArgs-1.2.2...
Installed cipher-aes-0.2.11
Building unordered-containers-0.2.7.1...
Building ReadArgs-1.2.2...
Configuring pwstore-fast-2.4.4...
Installed ReadArgs-1.2.2
Building pwstore-fast-2.4.4...
Configuring lifted-base-0.2.3.8...
Installed pwstore-fast-2.4.4
Building lifted-base-0.2.3.8...
Installed unordered-containers-0.2.7.1
Configuring skein-1.0.9.4...
Building skein-1.0.9.4...
Installed lifted-base-0.2.3.8
Configuring blaze-html-0.8.1.2...
Building blaze-html-0.8.1.2...
Configuring contravariant-1.4...
Installed skein-1.0.9.4
Building contravariant-1.4...
Configuring monad-unlift-0.2.0...
Installed contravariant-1.4
Building monad-unlift-0.2.0...
Configuring lifted-async-0.9.0...
Installed monad-unlift-0.2.0
Building lifted-async-0.9.0...
Installed lifted-async-0.9.0
Configuring comonad-5...
Installed blaze-html-0.8.1.2
Configuring xmlhtml-0.2.3.5...
Building xmlhtml-0.2.3.5...
Building comonad-5...
Installed comonad-5
Configuring bifunctors-5.4.1...
Building bifunctors-5.4.1...
Installed bifunctors-5.4.1
Configuring semigroupoids-5.1...
Configuring profunctors-5.2...
Installed xmlhtml-0.2.3.5
Building profunctors-5.2...
Building semigroupoids-5.1...
Installed profunctors-5.2
Installed semigroupoids-5.1
Configuring free-4.12.4...
Building free-4.12.4...
Installed free-4.12.4
Configuring adjunctions-4.3...
Configuring keys-3.11...
Building adjunctions-4.3...
Building keys-3.11...
Installed keys-3.11
Installed adjunctions-4.3
Configuring kan-extensions-5.0.1...
Building kan-extensions-5.0.1...
Installed kan-extensions-5.0.1
Configuring pointed-5...
Building pointed-5...
Installed pointed-5
cabal: Error: some packages failed to install:
aeson-1.0.2.1 depends on vector-0.11.0.0 which failed to install.
attoparsec-0.13.1.0 depends on vector-0.11.0.0 which failed to install.
basic-prelude-0.6.1 depends on vector-0.11.0.0 which failed to install.
chunked-data-0.3.0 depends on vector-0.11.0.0 which failed to install.
classy-prelude-1.0.1 depends on vector-0.11.0.0 which failed to install.
clientsession-0.9.1.2 depends on vector-0.11.0.0 which failed to install.
configurator-0.3.0.0 depends on vector-0.11.0.0 which failed to install.
cprng-aes-0.6.1 depends on vector-0.11.0.0 which failed to install.
crypto-random-0.0.9 depends on vector-0.11.0.0 which failed to install.
heist-1.0.1.0 depends on vector-0.11.0.0 which failed to install.
io-streams-1.3.5.0 depends on vector-0.11.0.0 which failed to install.
io-streams-haproxy-1.0.0.1 depends on vector-0.11.0.0 which failed to install.
lens-4.15.1 depends on vector-0.11.0.0 which failed to install.
mono-traversable-1.0.1 depends on vector-0.11.0.0 which failed to install.
mono-traversable-instances-0.1.0.0 depends on vector-0.11.0.0 which failed to
install.
mutable-containers-0.3.3 depends on vector-0.11.0.0 which failed to install.
mwc-random-0.13.4.0 depends on vector-0.11.0.0 which failed to install.
scientific-0.3.4.9 depends on vector-0.11.0.0 which failed to install.
snap-1.0.0.1 depends on vector-0.11.0.0 which failed to install.
snap-core-1.0.1.0 depends on vector-0.11.0.0 which failed to install.
snap-server-1.0.1.1 depends on vector-0.11.0.0 which failed to install.
snaplet-scoped-session-0.1.1 depends on vector-0.11.0.0 which failed to
install.
vector-0.11.0.0 failed during the building phase. The exception was:
ExitFailure 1
vector-algorithms-0.7.0.1 depends on vector-0.11.0.0 which failed to install.
vector-instances-3.3.1 depends on vector-0.11.0.0 which failed to install.