Build #3 for sparkle-0.7.4

[all reports]

Package sparkle-0.7.4
Install DependencyFailed sparkle-0.7.4
Docs NotTried
Tests NotTried
Time submitted 2018-02-28 12:20:18.429566133 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies base-4.10.1.0, binary-0.8.5.1, bytestring-0.10.8.2, choice-0.2.2, constraints-0.10, distributed-closure-0.4.0, inline-java-0.8.2, jni-0.6.0, jvm-0.4.2, jvm-streaming-0.3, singletons-2.3.1, streaming-0.2.0.0, text-1.2.2.2, vector-0.12.0.1, base-4.10.1.0, bytestring-0.10.8.2, filepath-1.4.1.2, process-1.6.1.0, regex-tdfa-1.2.2, temporary-1.2.1.1, text-1.2.2.2, unix-2.7.2.2, zip-archive-0.3.2.4
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring base-orphans-0.6...
Configuring choice-0.2.2...
Building choice-0.2.2...
Building base-orphans-0.6...
Installed base-orphans-0.6
Configuring colour-2.3.4...
Installed choice-0.2.2
Configuring digest-0.0.1.2...
Building colour-2.3.4...
Building digest-0.0.1.2...
Installed digest-0.0.1.2
Configuring old-locale-1.0.0.7...
Building old-locale-1.0.0.7...
Installed old-locale-1.0.0.7
Configuring polyparse-1.12...
Building polyparse-1.12...
Installed colour-2.3.4
Configuring regex-tdfa-1.2.2...
Building regex-tdfa-1.2.2...
Installed polyparse-1.12
Configuring safe-0.3.16...
Building safe-0.3.16...
Installed safe-0.3.16
Configuring semigroups-0.18.4...
Building semigroups-0.18.4...
Installed semigroups-0.18.4
Configuring th-expand-syns-0.4.4.0...
Building th-expand-syns-0.4.4.0...
Installed regex-tdfa-1.2.2
Configuring th-lift-0.7.8...
Building th-lift-0.7.8...
Installed th-expand-syns-0.4.4.0
Configuring transformers-compat-0.6.0.5...
Building transformers-compat-0.6.0.5...
Installed th-lift-0.7.8
Configuring old-time-1.1.0.3...
Building old-time-1.1.0.3...
Installed transformers-compat-0.6.0.5
Configuring ansi-terminal-0.8.0.1...
Building ansi-terminal-0.8.0.1...
Installed old-time-1.1.0.3
Configuring charset-0.3.7.1...
Building charset-0.3.7.1...
Installed ansi-terminal-0.8.0.1
Configuring th-reify-many-0.1.8...
Building th-reify-many-0.1.8...
Installed th-reify-many-0.1.8
Configuring th-lift-instances-0.1.11...
Building th-lift-instances-0.1.11...
Installed charset-0.3.7.1
Configuring transformers-base-0.4.4...
Building transformers-base-0.4.4...
Installed th-lift-instances-0.1.11
Configuring mmorph-1.1.1...
Building mmorph-1.1.1...
Installed transformers-base-0.4.4
Configuring exceptions-0.8.3...
Building exceptions-0.8.3...
Installed mmorph-1.1.1
Configuring constraints-0.10...
Building constraints-0.10...
Installed exceptions-0.8.3
Configuring zip-archive-0.3.2.4...
Building zip-archive-0.3.2.4...
Installed constraints-0.10
Configuring cpphs-1.20.8...
Building cpphs-1.20.8...
Installed zip-archive-0.3.2.4
Configuring ansi-wl-pprint-0.6.8.2...
Building ansi-wl-pprint-0.6.8.2...
Installed ansi-wl-pprint-0.6.8.2
Configuring parsers-0.12.8...
Building parsers-0.12.8...
Installed cpphs-1.20.8
Configuring th-orphans-0.13.5...
Building th-orphans-0.13.5...
Installed parsers-0.12.8
Configuring temporary-1.2.1.1...
Building temporary-1.2.1.1...
Installed temporary-1.2.1.1
Configuring streaming-0.2.0.0...
Installed th-orphans-0.13.5
Configuring distributed-closure-0.4.0...
Building streaming-0.2.0.0...
Building distributed-closure-0.4.0...
Installed streaming-0.2.0.0
Configuring language-java-0.2.8...
Installed distributed-closure-0.4.0
Configuring inline-c-0.6.0.5...
Building language-java-0.2.8...
Building inline-c-0.6.0.5...
Installed inline-c-0.6.0.5
Configuring th-desugar-1.7...
Building th-desugar-1.7...
Installed language-java-0.2.8
Installed th-desugar-1.7
Configuring singletons-2.3.1...
Building singletons-2.3.1...
Installed singletons-2.3.1
Configuring jni-0.6.0...
Failed to install jni-0.6.0
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/jni-0.6.0-EYXfY9EkukXfGvAtYWruA.log ):
cabal: Entering directory '/tmp/cabal-tmp-5041/jni-0.6.0'
Configuring jni-0.6.0...
cabal: Missing dependency on a foreign library:
* Missing C library: jvm
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
cabal: Leaving directory '/tmp/cabal-tmp-5041/jni-0.6.0'
cabal: Error: some packages failed to install:
inline-java-0.8.2-DjMF1FihzHR6OMaqJpeHvE depends on inline-java-0.8.2 which
failed to install.
jni-0.6.0-EYXfY9EkukXfGvAtYWruA failed during the configure step. The
exception was:
ExitFailure 1
jvm-0.4.2-GUkOTJ69MLz6zexy5qNgyD depends on jvm-0.4.2 which failed to install.
jvm-batching-0.1.1-FDF3nZFKEADGmAM6J4mGuh depends on jvm-batching-0.1.1 which
failed to install.
jvm-streaming-0.3-DeaIPXAiqd0EI1OrJZkDcQ depends on jvm-streaming-0.3 which
failed to install.
sparkle-0.7.4-RBZDm4eSUOK1Yo07Bh2r6 depends on sparkle-0.7.4 which failed to
install.