The speculation package

[Tags: bsd3, library]

A framework for safe, programmable, speculative parallelism, loosely based on http://research.microsoft.com/pubs/118795/pldi026-vaswani.pdf


Properties

Versions0.0.0, 0.0.1, 0.0.2, 0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.5.1, 0.6.0, 0.7.0, 0.8.0, 0.8.0.1, 0.8.0.2, 0.8.1.0, 0.8.2.0, 0.9.0.0, 1.0.0.0, 1.1.0.0, 1.2.0.0, 1.2.0.1, 1.2.0.2, 1.3, 1.4, 1.4.1, 1.4.1.1, 1.4.1.2, 1.5, 1.5.0.1
Dependenciesarray (>=0.2 && <0.4), base (>=4 && <6), containers (>=0.2.0.1), parallel (==2.2.*)
LicenseBSD3
Copyright(c) 2010 Edward A. Kmett
AuthorEdward A. Kmett
MaintainerEdward A. Kmett <ekmett@gmail.com>
Stabilityexperimental
CategoryConcurrency
Home pagehttp://github.com/ekmett/speculation
Upload dateSun Jun 27 07:45:35 UTC 2010
Uploaded byEdwardKmett
Downloads1342 total (153 in last 30 days)

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees