Metadata revisions for step-function-0.2

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User SHA256
-r5 2021-02-20T21:38:57Z phadej 4a37dbcd27ad6321aee432e8247014de754320b550ad45e9f0e37cdf8e35af0f
  • Changed tested-with from

    ghc ==7.6.3 || ==7.8.4 || ==7.10.3 || ==8.0.2 || ==8.2.2 || ==8.4.4 || ==8.6.5 || ==8.8.3 || ==8.10.1
    to
    ghc ==7.6.3 || ==7.8.4 || ==7.10.3 || ==8.0.2 || ==8.2.2 || ==8.4.4 || ==8.6.5 || ==8.8.4 || ==8.10.4 || ==9.0.1

  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.15
    to
    >=4.6 && <4.16

-r4 2020-03-28T11:33:54Z phadej dbce30740e6214ed3aa9ad5cd7446b2ab493d092d7d5e2e6b9c53c5294ceb27f
  • Changed tested-with from

    ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.4: ghc ==8.6.5: ghc ==8.8.1
    to
    ghc ==7.6.3 || ==7.8.4 || ==7.10.3 || ==8.0.2 || ==8.2.2 || ==8.4.4 || ==8.6.5 || ==8.8.3 || ==8.10.1

  • Changed the library component's library dependency on 'QuickCheck' from

    >=2.11.3 && <2.14
    to
    >=2.11.3 && <2.15

  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.14
    to
    >=4.6 && <4.15

-r3 2019-09-10T06:59:22Z phadej ea800ae9ef2c4a3880c7e9bb725dbaac9729824e32d4759acf9bfa6285e84729
  • Changed tested-with from

    ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.4: ghc ==8.6.4
    to
    ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.4: ghc ==8.6.5: ghc ==8.8.1

  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.13
    to
    >=4.6 && <4.14

  • Changed the library component's library dependency on 'base-compat-batteries' from

    >=0.10.1 && <0.11
    to
    >=0.10.1 && <0.12

-r2 2019-03-26T10:22:03Z phadej fb3be5bb25c3f3a37c38b5da666b499eea3ba31b2a319c13991a5c226b4a831c
  • Changed tested-with from

    ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.3: ghc ==8.6.1
    to
    ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.4: ghc ==8.6.4

  • Changed the library component's library dependency on 'QuickCheck' from

    >=2.11.3 && <2.13
    to
    >=2.11.3 && <2.14

-r1 2018-09-24T17:02:58Z phadej 04bb05b6ca362ab43c7cdda8a0fc9bf4d022529d5b45e6c661c0e9aef84eea0d
  • Changed tested-with from

    ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.2
    to
    ghc ==7.6.3: ghc ==7.8.4: ghc ==7.10.3: ghc ==8.0.2: ghc ==8.2.2: ghc ==8.4.3: ghc ==8.6.1

  • Changed the library component's library dependency on 'QuickCheck' from

    >=2.11.3 && <2.12
    to
    >=2.11.3 && <2.13

  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.12
    to
    >=4.6 && <4.13

  • Changed the library component's library dependency on 'containers' from

    >=0.5.0.0 && <0.6
    to
    >=0.5.0.0 && <0.7

-r0 2018-05-21T15:58:55Z phadej 20be72748c615d17d24345023aba9597505da8f0c4ed7d3ddcff46cc9d8ef1b7