Build #6 for tkhs-0.3.0

[all reports]

Package tkhs-0.3.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-12 21:20:31.017398 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, mtl-2.2.1, parsec-3.1.11, pretty-1.1.3.3, utf8-string-1.0.1.1, vty-5.14
Flags -test

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring data-default-class-0.1.2.0...
Configuring dlist-0.8.0.2...
Building data-default-class-0.1.2.0...
Building dlist-0.8.0.2...
Installed data-default-class-0.1.2.0
Configuring microlens-0.4.7.0...
Building microlens-0.4.7.0...
Installed dlist-0.8.0.2
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Installed microlens-0.4.7.0
Building old-locale-1.0.0.7...
Configuring primitive-0.6.1.0...
Installed old-locale-1.0.0.7
Configuring parallel-3.2.1.0...
Installed mtl-2.2.1
Building primitive-0.6.1.0...
Building parallel-3.2.1.0...
Configuring stm-2.4.4.1...
Installed parallel-3.2.1.0
Building stm-2.4.4.1...
Configuring transformers-compat-0.5.1.4...
Installed primitive-0.6.1.0
Building transformers-compat-0.5.1.4...
Configuring text-1.2.2.1...
Installed stm-2.4.4.1
Building text-1.2.2.1...
Configuring utf8-string-1.0.1.1...
Installed transformers-compat-0.5.1.4
Building utf8-string-1.0.1.1...
Installed utf8-string-1.0.1.1
Configuring data-default-instances-containers-0.0.1...
Building data-default-instances-containers-0.0.1...
Installed data-default-instances-containers-0.0.1
Configuring data-default-instances-dlist-0.0.1...
Building data-default-instances-dlist-0.0.1...
Configuring microlens-th-0.4.1.0...
Installed data-default-instances-dlist-0.0.1
Building microlens-th-0.4.1.0...
Configuring data-default-instances-old-locale-0.0.1...
Installed microlens-th-0.4.1.0
Configuring microlens-mtl-0.1.10.0...
Installed text-1.2.2.1
Building data-default-instances-old-locale-0.0.1...
Building microlens-mtl-0.1.10.0...
Configuring vector-0.11.0.0...
Installed data-default-instances-old-locale-0.0.1
Building vector-0.11.0.0...
Installed microlens-mtl-0.1.10.0
Configuring blaze-builder-0.4.0.2...
Building blaze-builder-0.4.0.2...
Configuring hashable-1.2.4.0...
Installed blaze-builder-0.4.0.2
Building hashable-1.2.4.0...
Configuring data-default-0.7.1.1...
Installed hashable-1.2.4.0
Building data-default-0.7.1.1...
Configuring parsec-3.1.11...
Installed data-default-0.7.1.1
Building parsec-3.1.11...
Installed parsec-3.1.11
Installed vector-0.11.0.0
Configuring vty-5.14...
Building vty-5.14...
Installed vty-5.14
Configuring tkhs-0.3.0...
Building tkhs-0.3.0...
Failed to install tkhs-0.3.0
Build log ( /home/builder/.cabal/logs/tkhs-0.3.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-26780/tkhs-0.3.0'
Configuring tkhs-0.3.0...
Building tkhs-0.3.0...
Preprocessing executable 'tkhs' for tkhs-0.3.0...
[1 of 5] Compiling Zipper           ( src/Zipper.hs, dist/build/tkhs/tkhs-tmp/Zipper.o )

src/Zipper.hs:3:1: warning: [-Wunused-imports]
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()

src/Zipper.hs:4:1: warning: [-Wunused-imports]
    The import of ‘Data.Traversable’ is redundant
      except perhaps to import instances from ‘Data.Traversable’
    To import instances alone, use: import Data.Traversable()

src/Zipper.hs:5:1: warning: [-Wunused-imports]
    The import of ‘Data.Foldable’ is redundant
      except perhaps to import instances from ‘Data.Foldable’
    To import instances alone, use: import Data.Foldable()

src/Zipper.hs:6:1: warning: [-Wunused-imports]
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()
[2 of 5] Compiling Vty              ( src/Vty.hs, dist/build/tkhs/tkhs-tmp/Vty.o )

src/Vty.hs:36:1: warning: [-Wunused-imports]
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()
[3 of 5] Compiling Tkhs             ( src/Tkhs.hs, dist/build/tkhs/tkhs-tmp/Tkhs.o )

src/Tkhs.hs:21:1: warning: [-Wunused-imports]
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()
[4 of 5] Compiling Parser           ( src/Parser.hs, dist/build/tkhs/tkhs-tmp/Parser.o )
[5 of 5] Compiling Main             ( src/Main.hs, dist/build/tkhs/tkhs-tmp/Main.o )

src/Main.hs:7:1: error:
    Failed to load interface for ‘System.IO.UTF8’
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-26780/tkhs-0.3.0'
cabal: Error: some packages failed to install:
tkhs-0.3.0 failed during the building phase. The exception was:
ExitFailure 1