The vty package

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain]

Warnings:

vty is terminal GUI library in the niche of ncurses. It is intended to be easy to use, have no confusing corner cases, and good support for common terminal types.

Included in the source distribution is a program test/interactive_terminal_test.hs that demonstrates the various features.

Developers: See the Graphics.Vty module.

Users: See the Graphics.Vty.Config module.

If your terminal is not behaving as expected the results of the vty-interactive-terminal-test executable should be sent to the Vty maintainter to aid in debugging the issue.

Notable infelicities: Assumes UTF-8 character encoding support by the terminal; Poor signal handling; Requires terminfo.

Project is hosted on github.com: https://github.com/coreyoconnor/vty

git clone git://github.com/coreyoconnor/vty.git

© 2006-2007 Stefan O'Rear; BSD3 license.

© Corey O'Connor; BSD3 license.


[Skip to ReadMe]

Properties

Versions3.0.0, 3.0.1, 3.0.2, 3.0.4, 3.1.0, 3.1.2, 3.1.4, 3.1.6, 3.1.8, 3.1.8.2, 3.1.8.4, 4.0.0, 4.0.0.1, 4.2.1.0, 4.4.0.0, 4.4.0.0.1, 4.6.0.1, 4.6.0.2, 4.6.0.4, 4.6.0.6, 4.7.0.0, 4.7.0.4, 4.7.0.6, 4.7.0.8, 4.7.0.10, 4.7.0.12, 4.7.0.14, 4.7.0.18, 4.7.0.20, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.7.5, 5.0.0, 5.0.0, 5.0.1, 5.0.2, 5.1.0, 5.1.1, 5.1.3, 5.1.4, 5.2.0, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 5.2.5, 5.2.6, 5.2.7, 5.2.8, 5.2.9, 5.2.10, 5.2.11, 5.3, 5.3.1, 5.4.0, 5.5.0, 5.6, 5.7, 5.7.1, 5.8, 5.8.1, 5.9, 5.9.1, 5.10, 5.11, 5.11.1, 5.11.2, 5.11.3, 5.12, 5.13, 5.14, 5.15, 5.15.1
Change logCHANGELOG
Dependenciesbase (==4.*), blaze-builder (>=0.3.3.2 && <0.4), bytestring, containers, data-default (>=0.5.3), deepseq (>=1.1 && <1.4), directory, filepath (>=1.0 && <2.0), hashable (>=1.2), lens (>=3.9.0.2 && <4.2), mtl (>=1.1.1.0 && <2.2), parallel (>=2.2 && <3.3), parsec (>=2 && <4), terminfo (>=0.3 && <0.5), text (>=0.11.3), transformers (>=0.3.0.0), unix, utf8-string (==0.3.*), vector (>=0.7), vty [details]
LicenseBSD3
AuthorAUTHORS
MaintainerCorey O'Connor (coreyoconnor@gmail.com)
CategoryUser Interfaces
Home pagehttps://github.com/coreyoconnor/vty
Executablesvty-demo
UploadedThu Jun 5 07:48:10 UTC 2014 by CoreyOConnor

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for vty-5.0.0

vty is a terminal interface library.

Project is hosted on github.com: https://github.com/coreyoconnor/vty

git clone git://github.com/coreyoconnor/vty.git

Features

Known Issues

Platform Support

Posix Terminals

Uses terminfo to determine terminal protocol. Some special rules for Mac terminal applications. The special rules might be invalid on newer Mac OS.

Windows

None!

Development Notes

Coverage

Profiling appears to cause issues with coverage when enabled. To evaluate coverage configure as follows:

rm -rf dist ; cabal configure --enable-tests --enable-library-coverage \
  --disable-library-profiling \
  --disable-executable-profiling

Profiling

rm -rf dist ; cabal configure --enable-tests --disable-library-coverage \
  --enable-library-profiling \
  --enable-executable-profiling