Build #3 for wild-bind-task-x11-0.2.0.3

[all reports]

Package wild-bind-task-x11-0.2.0.3
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2021-03-25 14:02:33.593257879 UTC
Compiler ghc-8.10.2
OS linux
Arch x86_64
Dependencies
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: wild-bind-task-x11-0.2.0.3 (user goal)
[__1] trying: wild-bind-indicator-1.0.0.1 (dependency of wild-bind-task-x11)
[__2] next goal: gi-gtk (dependency of wild-bind-indicator)
[__2] rejecting: gi-gtk-4.0.4 (conflict: wild-bind-indicator => gi-gtk>=3.0.3
&& <3.1)
[__2] skipping: gi-gtk-4.0.3, gi-gtk-4.0.2, gi-gtk-4.0.1 (has the same
characteristics that caused the previous version to fail: excluded by
constraint '>=3.0.3 && <3.1' from 'wild-bind-indicator')
[__2] rejecting: gi-gtk-3.0.37, gi-gtk-3.0.36, gi-gtk-3.0.35, gi-gtk-3.0.34,
gi-gtk-3.0.33, gi-gtk-3.0.32, gi-gtk-3.0.31, gi-gtk-3.0.30, gi-gtk-3.0.29,
gi-gtk-3.0.28, gi-gtk-3.0.27, gi-gtk-3.0.26, gi-gtk-3.0.25, gi-gtk-3.0.24,
gi-gtk-3.0.23, gi-gtk-3.0.22, gi-gtk-3.0.21, gi-gtk-3.0.20, gi-gtk-3.0.19,
gi-gtk-3.0.18, gi-gtk-3.0.17, gi-gtk-3.0.16, gi-gtk-3.0.15, gi-gtk-3.0.14,
gi-gtk-3.0.13, gi-gtk-3.0.12, gi-gtk-3.0.11, gi-gtk-3.0.10, gi-gtk-3.0.9,
gi-gtk-3.0.8, gi-gtk-3.0.7, gi-gtk-3.0.6, gi-gtk-3.0.5, gi-gtk-3.0.4,
gi-gtk-3.0.3 (conflict: pkg-config package gtk+-3.0-any, not found in the
pkg-config database)
[__2] rejecting: gi-gtk-3.0.2 (conflict: wild-bind-indicator => gi-gtk>=3.0.3
&& <3.1)
[__2] skipping: gi-gtk-3.0.1, gi-gtk-0.3.18.15, gi-gtk-0.3.18.14,
gi-gtk-0.3.18.13, gi-gtk-0.3.18.12, gi-gtk-0.3.16.12, gi-gtk-0.3.18.10,
gi-gtk-0.3.16.11, gi-gtk-0.3.16.10, gi-gtk-0.3.16.9, gi-gtk-0.3.16.8 (has the
same characteristics that caused the previous version to fail: excluded by
constraint '>=3.0.3 && <3.1' from 'wild-bind-indicator')
[__2] fail (backjumping, conflict set: gi-gtk, wild-bind-indicator)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: gi-gtk, wild-bind-indicator, gtk,
wild-bind-task-x11
Try running with --minimize-conflict-set to improve the error message.