Build #3 for winery-0.3

[all reports]

Package winery-0.3
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-09-11 08:29:39.589443376 UTC
Compiler ghc-8.4.3
OS linux
Arch x86_64
Dependencies aeson-1.4.0.0, base-4.11.1.0, bytestring-0.10.8.2, containers-0.5.11.0, cpu-0.1.2, hashable-1.2.7.0, megaparsec-7.0.0, mtl-2.2.2, prettyprinter-1.2.1, prettyprinter-ansi-terminal-1.1.1.2, scientific-0.3.6.2, semigroups-0.18.5, text-1.2.3.0, time-1.8.0.2, transformers-0.5.5.0, unordered-containers-0.2.9.0, vector-0.12.0.1, aeson-1.4.0.0, base-4.11.1.0, bytestring-0.10.8.2, containers-0.5.11.0, cpu-0.1.2, hashable-1.2.7.0, megaparsec-7.0.0, mtl-2.2.2, prettyprinter-1.2.1, prettyprinter-ansi-terminal-1.1.1.2, scientific-0.3.6.2, semigroups-0.18.5, text-1.2.3.0, time-1.8.0.2, transformers-0.5.5.0, unordered-containers-0.2.9.0, vector-0.12.0.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring colour-2.3.4...
Configuring base-compat-0.10.4...
Building colour-2.3.4...
Building base-compat-0.10.4...
Installed colour-2.3.4
Configuring cpu-0.1.2...
Building cpu-0.1.2...
Installed base-compat-0.10.4
Configuring dlist-0.8.0.4...
Building dlist-0.8.0.4...
Installed cpu-0.1.2
Configuring hashable-1.2.7.0...
Building hashable-1.2.7.0...
Installed dlist-0.8.0.4
Configuring integer-logarithms-1.0.2.2...
Building integer-logarithms-1.0.2.2...
Installed integer-logarithms-1.0.2.2
Configuring parser-combinators-1.0.0...
Installed hashable-1.2.7.0
Configuring prettyprinter-1.2.1...
Building parser-combinators-1.0.0...
Building prettyprinter-1.2.1...
Installed parser-combinators-1.0.0
Configuring primitive-0.6.4.0...
Building primitive-0.6.4.0...
Installed prettyprinter-1.2.1
Configuring random-1.1...
Building random-1.1...
Installed random-1.1
Configuring semigroups-0.18.5...
Building semigroups-0.18.5...
Installed semigroups-0.18.5
Configuring tagged-0.8.6...
Building tagged-0.8.6...
Installed primitive-0.6.4.0
Configuring th-abstraction-0.2.8.0...
Installed tagged-0.8.6
Configuring time-locale-compat-0.1.1.5...
Building th-abstraction-0.2.8.0...
Building time-locale-compat-0.1.1.5...
Installed time-locale-compat-0.1.1.5
Configuring ansi-terminal-0.8.1...
Building ansi-terminal-0.8.1...
Installed th-abstraction-0.2.8.0
Configuring unordered-containers-0.2.9.0...
Building unordered-containers-0.2.9.0...
Installed ansi-terminal-0.8.1
Configuring case-insensitive-1.2.0.11...
Building case-insensitive-1.2.0.11...
Installed case-insensitive-1.2.0.11
Configuring uuid-types-1.0.3...
Building uuid-types-1.0.3...
Installed uuid-types-1.0.3
Configuring vector-0.12.0.1...
Building vector-0.12.0.1...
Installed unordered-containers-0.2.9.0
Configuring scientific-0.3.6.2...
Building scientific-0.3.6.2...
Installed scientific-0.3.6.2
Configuring prettyprinter-ansi-terminal-1.1.1.2...
Building prettyprinter-ansi-terminal-1.1.1.2...
Installed prettyprinter-ansi-terminal-1.1.1.2
Configuring megaparsec-7.0.0...
Building megaparsec-7.0.0...
Installed megaparsec-7.0.0
Configuring attoparsec-0.13.2.2...
Building attoparsec-0.13.2.2...
Installed vector-0.12.0.1
Installed attoparsec-0.13.2.2
Configuring aeson-1.4.0.0...
Building aeson-1.4.0.0...
Installed aeson-1.4.0.0
Configuring winery-0.3...
Building winery-0.3...
Failed to install winery-0.3
Build log ( /home/builder/.cabal/logs/ghc-8.4.3/winery-0.3-4hN6x4UB3CT7M5maM54xLX.log ):
cabal: Entering directory '/tmp/cabal-tmp-19565/winery-0.3'
Configuring winery-0.3...
Preprocessing library for winery-0.3..
Building library for winery-0.3..
[1 of 7] Compiling Data.Winery.Internal.Builder ( src/Data/Winery/Internal/Builder.hs, dist/build/Data/Winery/Internal/Builder.o )
[2 of 7] Compiling Data.Winery.Internal ( src/Data/Winery/Internal.hs, dist/build/Data/Winery/Internal.o )
[3 of 7] Compiling Data.Winery      ( src/Data/Winery.hs, dist/build/Data/Winery.o )

src/Data/Winery.hs:93:1: warning: [-Wunused-imports]
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()
   |
93 | import Data.Monoid
   | ^^^^^^^^^^^^^^^^^^
[4 of 7] Compiling Data.Winery.Query ( src/Data/Winery/Query.hs, dist/build/Data/Winery/Query.o )
[5 of 7] Compiling Data.Winery.Query.Parser ( src/Data/Winery/Query/Parser.hs, dist/build/Data/Winery/Query/Parser.o )
[6 of 7] Compiling Data.Winery.Term ( src/Data/Winery/Term.hs, dist/build/Data/Winery/Term.o )
[7 of 7] Compiling Paths_winery     ( dist/build/autogen/Paths_winery.hs, dist/build/Paths_winery.o )
ignoring (possibly broken) abi-depends field for packages
Preprocessing executable 'winery' for winery-0.3..
Building executable 'winery' for winery-0.3..
[1 of 2] Compiling Main             ( app/Main.hs, dist/build/winery/winery-tmp/Main.o )

app/Main.hs:86:45: error:
    • Couldn't match expected type ‘ParseError s0 e0’
                  with actual type ‘ParseErrorBundle T.Text Data.Void.Void’
    • In the first argument of ‘parseErrorPretty’, namely ‘e’
      In the second argument of ‘($)’, namely ‘parseErrorPretty e’
      In a stmt of a 'do' block: hPutStrLn stderr $ parseErrorPretty e
   |
86 |         hPutStrLn stderr $ parseErrorPretty e
   |                                             ^
cabal: Leaving directory '/tmp/cabal-tmp-19565/winery-0.3'
cabal: Error: some packages failed to install:
winery-0.3-4hN6x4UB3CT7M5maM54xLX failed during the building phase. The
exception was:
ExitFailure 1