The yesod-core package

[Tags: library, mit]

Yesod is a framework designed to foster creation of RESTful web application that have strong compile-time guarantees of correctness. It also affords space efficient code and portability to many deployment backends, from CGI to stand-alone serving.

The Yesod documentation site http://www.yesodweb.com/ has much more information, tutorials and information on some of the supporting packages, like Hamlet and Persistent.

Properties

Versions0.7.0, 0.7.0.1, 0.7.0.2, 0.8.0, 0.8.0.1, 0.8.1, 0.8.2, 0.8.3, 0.8.3.1, 0.8.3.2, 0.9.1, 0.9.1.1, 0.9.2, 0.9.3, 0.9.3.1, 0.9.3.2, 0.9.3.3, 0.9.3.4, 0.9.3.5, 0.9.3.6, 0.9.4, 0.9.4.1, 0.10.1, 0.10.2, 0.10.2.1, 0.10.2.2, 0.10.3, 1.0.0, 1.0.0.1, 1.0.0.2, 1.0.1, 1.0.1.1, 1.0.1.2, 1.0.1.3, 1.1.0, 1.1.0.1, 1.1.1, 1.1.1.1, 1.1.1.2, 1.1.2, 1.1.2.1, 1.1.2.2, 1.1.3, 1.1.3.1, 1.1.4, 1.1.4.1, 1.1.4.2, 1.1.5, 1.1.6, 1.1.6.1, 1.1.7, 1.1.7.1, 1.1.7.2, 1.1.8, 1.1.8.1, 1.1.8.2, 1.1.8.3, 1.2.0, 1.2.0.1, 1.2.0.2, 1.2.0.3, 1.2.0.4, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.4.1, 1.2.4.2, 1.2.4.3, 1.2.4.4, 1.2.4.5, 1.2.5, 1.2.6, 1.2.6.1, 1.2.6.2, 1.2.6.3, 1.2.6.4, 1.2.6.5, 1.2.6.6, 1.2.6.7, 1.2.7, 1.2.8, 1.2.9, 1.2.9.1, 1.2.9.2, 1.2.10, 1.2.11, 1.2.11.1, 1.2.12, 1.2.13, 1.2.13.1, 1.2.14, 1.2.15, 1.2.15.1, 1.2.15.2, 1.2.16, 1.2.16.1, 1.2.17, 1.2.18, 1.2.19, 1.2.19.1, 1.2.19.2, 1.2.20, 1.2.20.1, 1.4.0, 1.4.0.1, 1.4.0.2, 1.4.1, 1.4.1.1, 1.4.2, 1.4.3, 1.4.3.1, 1.4.4, 1.4.4.1, 1.4.4.2, 1.4.4.3, 1.4.4.4, 1.4.4.5, 1.4.5, 1.4.6, 1.4.6.1, 1.4.6.2, 1.4.7, 1.4.7.1, 1.4.7.2, 1.4.7.3, 1.4.8, 1.4.8.1, 1.4.8.2, 1.4.8.3, 1.4.9, 1.4.9.1, 1.4.10, 1.4.11, 1.4.11.1, 1.4.12, 1.4.13, 1.4.14, 1.4.15
Change logNone available
Dependenciesaeson (>=0.5), base (>=4.3 && <5), blaze-builder (>=0.2.1.4 && <0.4), blaze-html (>=0.4 && <0.6), blaze-markup (>=0.5.1 && <0.6), bytestring (>=0.9.1.4), case-insensitive (>=0.2), cereal (==0.3.*), clientsession (>=0.7.3.1 && <0.8), conduit (==0.4.*), containers (>=0.2), cookie (==0.4.*), directory (>=1 && <1.2), failure (==0.2.*), fast-logger (>=0.0.2), hamlet (==1.0.*), http-types (>=0.6.5 && <0.7), lifted-base (==0.1.*), monad-control (==0.3.*), old-locale (>=1.0.0.2 && <1.1), parsec (>=2 && <3.2), path-pieces (==0.1.*), random (>=1.0.0.2 && <1.1), resourcet (==0.3.*), shakespeare (==1.0.*), shakespeare-css (==1.0.*), shakespeare-i18n (==1.0.*), shakespeare-js (==1.0.*), template-haskell, text (>=0.7 && <0.12), time (>=1.1.4), transformers (>=0.2.2 && <0.4), transformers-base (>=0.4), vector (==0.9.*), wai (==1.2.*), wai-extra (==1.2.*), wai-logger (>=0.0.1), wai-test, yesod-routes (==1.0.*) [details]
LicenseMIT
AuthorMichael Snoyman <michael@snoyman.com>
MaintainerMichael Snoyman <michael@snoyman.com>
StabilityStable
CategoryWeb, Yesod
Home pagehttp://www.yesodweb.com/
Source repositoryhead: git clone https://github.com/yesodweb/yesod
UploadedMon May 14 11:12:45 UTC 2012 by MichaelSnoyman
DistributionsDebian:1.4.12, FreeBSD:1.4.13, LTSHaskell:1.4.15, NixOS:1.4.15, Stackage:1.4.15
Downloads49351 total (1361 in last 30 days)
Votes
0 []
StatusDocs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Flags

NameDescriptionDefaultType
testBuild the executable to run unit testsDisabledAutomatic
blaze_html_0_5use blaze-html 0.5 and blaze-markup 0.5EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees