Build #7 for yi-0.5.0.1

[all reports]

Package yi-0.5.0.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-03 00:40:01.546241 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies
Flags -vty testing pango -gtk -ghcapi -cocoa

Build log

[view raw]

Resolving dependencies...
Configuring yi-0.5.0.1...
Building yi-0.5.0.1...
Failed to install yi-0.5.0.1
Build log ( /home/builder/.cabal/logs/yi-0.5.0.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-8982/yi-0.5.0.1'
Configuring yi-0.5.0.1...
Building yi-0.5.0.1...
Preprocessing library yi-0.5.0.1...

Yi/Core.hs:1:14: warning:
    -XPatternSignatures is deprecated: use -XScopedTypeVariables or pragma {-# LANGUAGE ScopedTypeVariables #-} instead

Yi/Eval.hs:1:14: warning:
    -XPatternSignatures is deprecated: use -XScopedTypeVariables or pragma {-# LANGUAGE ScopedTypeVariables #-} instead

Yi/History.hs:1:14: warning:
    -XPatternSignatures is deprecated: use -XScopedTypeVariables or pragma {-# LANGUAGE ScopedTypeVariables #-} instead
[ 1 of 95] Compiling Yi.UI.Common[boot] ( Yi/UI/Common.hs-boot, dist/build/Yi/UI/Common.o-boot )

Yi/UI/Common.hs-boot:1:8: error:
    Failed to load interface for ‘Prelude’
    It is a member of the hidden package ‘base-4.9.0.0’.
    Perhaps you need to add ‘base’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-8982/yi-0.5.0.1'
cabal: Error: some packages failed to install:
yi-0.5.0.1 failed during the building phase. The exception was:
ExitFailure 1