Changelog for zmidi-core-0.4.0

0.2.1 to 0.3.0: * Revised naming of the MIDI data types. All data types now have the prefix Midi (previously only MidiFile followed this scheme). The rationale for this is client software, that might want a higher-level representation, is then free to use the more generic names Track, Message, etc. * @DeltaTime@ made a newtype wrapper rather than a type synonym. * Renamed the pretty print functions @track@ to @printMidiTrack@ and @header@ to @printMidiHeader@. * Moved internal dataypes (SplitByte, Varlen) into a private module. 0.2.0 to 0.2.1: * Added Show class constraints to various type signatures to accommodate changes to Num superclass hierarchy in GHC 7.4. Thanks to R�my Mou�za for the patches. 0.1.0 to 0.2.0: * Added a top-level /shim/ module to import all the exposed modules. Added a version number module 0.1.0: * Initial release.