Ticket #4002 (closed feature request: fixed)
Base new top-level names on the binder the code originated from (if any)
|Reported by:||tibbe||Owned by:|
|Type of failure:||None/Unknown||Difficulty:||Unknown|
|Test Case:||Blocked By:|
Generated top-level names currently starts with a followed by some unique string. It would be nice if it the new name was based on the binder the code originated from, making the Core easier to read.
In ticket #3693 batterseapower made such a change in an unrelated patch. http://hackage.haskell.org/trac/ghc/attachment/ticket/3693/StackTraces.dpatch
If someone has a good suggestion for naming I could try to implement this. How about changing <a>_<unique string> to <originating binder>_<unique string>?