Ticket #101 (closed enhancement: fixed)
Rejig the names of hooks provided by Cabal
|Reported by:||igloo@…||Owned by:||ijones|
Currently, if you want add a hook then there seem to be two starting sets of hooks you can use.
One is emptyHooks, but this really is empty. If you use these hooks then setup build will do nothing, for example.
The other is defaultHooks, but this does more than the defaults; for example, it will also run configure.
The actual defaults should be available as a !UserHooks, and a !UserHooks rather than a Maybe !UserHooks should be passed around. At first look, the current code is quite hard to follow.
It would also be nicer if extra hooks could be composed with suitable combinators, e.g.
theRealDefaultHooks :+: runConfigureHooks :+: someOtherHooks
and the extra stuff in defaultHooks was broken up into smaller pieces.