Ticket #395 (assigned enhancement)
Warn about dependencies like parsec <= 22.214.171.124
|Reported by:||duncan||Owned by:||kmcallister|
|Cc:||Saizan||Difficulty:||very easy (<1 hour)|
Cabal should warn about dependencies like parsec <= 126.96.36.199. It's almost certainly a mistake given the conventional semantics of version numvers.
Something like foo < 2.0 is quite common and it's relatively harmless so there's probably no point in warning. On the other hand foo < 2.0.0 is weird. It says foo-2.0 is ok, but foo-2.0.0 or foo-188.8.131.52 is not.
Something like foo <= 2.0 is a definately weird though since it excludes bug fixes like foo-184.108.40.206