Dependencies for HTTP-4000.2.17

library
  • array (>=0.2.0.0 && <0.6)
  • base (>=3.0.3.1 && <4.8)
  • bytestring (>=0.9.1.3 && <0.11)
  • old-time (>=1.0.0.0 && <1.2)
  • parsec (>=2.0 && <3.2)
  • if flag(mtl1)
    • mtl (>=1.1.0.0 && <1.2)
    else
    • mtl (>=2.0 && <2.3)
  • if impl(ghc<6.12)
    else
  • if os(windows)
    • Win32 (>=2.2.0.0 && <2.4)

Flags

NameDescriptionDefaultType
mtl1

Use the old mtl version 1.

DisabledAutomatic
warn-as-error

Build with warnings-as-errors

DisabledManual
network23

Use version 2.3.x or below of the network package

DisabledAutomatic
conduit10

Use version 1.0.x or below of the conduit package (for the test suite)

DisabledAutomatic
warp-tests

Test against warp

EnabledManual

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info