Build #8 for barrie-0.4

[all reports]

Package barrie-0.4
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-02 10:39:16.620985 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, containers-0.5.7.1, filepath-1.4.1.0, glib-0.13.4.1, gtk-0.14.6
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Configuring primitive-0.6.1.0...
Building mtl-2.2.1...
Building primitive-0.6.1.0...
Installed mtl-2.2.1
Configuring random-1.1...
Configuring utf8-string-1.0.1.1...
Installed primitive-0.6.1.0
Building random-1.1...
Building utf8-string-1.0.1.1...
Configuring text-1.2.2.1...
Installed random-1.1
Building text-1.2.2.1...
Installed utf8-string-1.0.1.1
Configuring vector-0.11.0.0...
Building vector-0.11.0.0...
Installed text-1.2.2.1
Configuring hashable-1.2.5.0...
Building hashable-1.2.5.0...
Installed hashable-1.2.5.0
Installed vector-0.11.0.0
Configuring hashtables-1.2.1.0...
Building hashtables-1.2.1.0...
Installed hashtables-1.2.1.0
Configuring gtk2hs-buildtools-0.13.2.1...
Building gtk2hs-buildtools-0.13.2.1...
Installed gtk2hs-buildtools-0.13.2.1
Configuring cairo-0.13.3.1...
Configuring glib-0.13.4.1...
Building cairo-0.13.3.1...
Building glib-0.13.4.1...
Installed cairo-0.13.3.1
Installed glib-0.13.4.1
Configuring pango-0.13.3.1...
Configuring gio-0.13.3.1...
Building gio-0.13.3.1...
Building pango-0.13.3.1...
Installed pango-0.13.3.1
Installed gio-0.13.3.1
Configuring gtk-0.14.6...
Building gtk-0.14.6...
Installed gtk-0.14.6
Configuring barrie-0.4...
Building barrie-0.4...
Failed to install barrie-0.4
Build log ( /home/builder/.cabal/logs/barrie-0.4.log ):
cabal: Entering directory '/tmp/cabal-tmp-17892/barrie-0.4'
Warning: barrie.cabal: A package using section syntax must specify at least
'cabal-version: >= 1.2'.
Configuring barrie-0.4...
Warning: 'ghc-options: -prof' is not necessary and will lead to problems when
used on a library. Use the configure flag --enable-library-profiling and/or
--enable-profiling.
Building barrie-0.4...
Preprocessing library barrie-0.4...
[ 1 of 10] Compiling Barrie.Trace     ( src/Barrie/Trace.hs, dist/build/Barrie/Trace.o )
[ 2 of 10] Compiling Barrie.Style     ( src/Barrie/Style.hs, dist/build/Barrie/Style.o )

src/Barrie/Style.hs:13:1: warning: [-Wunused-imports]
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()
[ 3 of 10] Compiling Barrie.Widgets   ( src/Barrie/Widgets.hs, dist/build/Barrie/Widgets.o )
[ 4 of 10] Compiling Barrie.DrawPrimitive ( src/Barrie/DrawPrimitive.hs, dist/build/Barrie/DrawPrimitive.o )

src/Barrie/DrawPrimitive.hs:75:11: error:
    Not in scope: type constructor or class ‘Gtk.GC’
    Perhaps you meant ‘Gtk.FD’ (imported from Graphics.UI.Gtk)
    Module ‘Graphics.UI.Gtk’ does not export ‘GC’.

src/Barrie/DrawPrimitive.hs:94:13: error:
    Not in scope: ‘Gtk.gcSetValues’
    Module ‘Graphics.UI.Gtk’ does not export ‘gcSetValues’.

src/Barrie/DrawPrimitive.hs:94:32: error:
    Not in scope: ‘Gtk.newGCValues’
    Module ‘Graphics.UI.Gtk’ does not export ‘newGCValues’.

src/Barrie/DrawPrimitive.hs:94:50: error:
    Not in scope: ‘Gtk.lineWidth’
    Module ‘Graphics.UI.Gtk’ does not export ‘lineWidth’.

src/Barrie/DrawPrimitive.hs:114:13: error:
    Not in scope: ‘Gtk.gcSetValues’
    Module ‘Graphics.UI.Gtk’ does not export ‘gcSetValues’.

src/Barrie/DrawPrimitive.hs:114:34: error:
    Not in scope: ‘Gtk.newGCValues’
    Module ‘Graphics.UI.Gtk’ does not export ‘newGCValues’.

src/Barrie/DrawPrimitive.hs:115:15: error:
    Not in scope: ‘Gtk.foreground’
    Module ‘Graphics.UI.Gtk’ does not export ‘foreground’.

src/Barrie/DrawPrimitive.hs:119:23: error:
    Not in scope: ‘Gtk.gcNew’
    Module ‘Graphics.UI.Gtk’ does not export ‘gcNew’.

src/Barrie/DrawPrimitive.hs:121:13: error:
    Not in scope: ‘Gtk.gcSetValues’
    Module ‘Graphics.UI.Gtk’ does not export ‘gcSetValues’.

src/Barrie/DrawPrimitive.hs:121:36: error:
    Not in scope: ‘Gtk.newGCValues’
    Module ‘Graphics.UI.Gtk’ does not export ‘newGCValues’.

src/Barrie/DrawPrimitive.hs:122:15: error:
    Not in scope: ‘Gtk.foreground’
    Module ‘Graphics.UI.Gtk’ does not export ‘foreground’.
cabal: Leaving directory '/tmp/cabal-tmp-17892/barrie-0.4'
cabal: Error: some packages failed to install:
barrie-0.4 failed during the building phase. The exception was:
ExitFailure 1