cublas: FFI bindings to the CUDA CUBLAS and CUSPARSE libraries

[ bsd3, foreign, library ] [ Propose Tags ]

This package provides FFI bindings to the NVIDIA CUDA CUBLAS and CUSPARSE linear algebra GPU BLAS implementations. The modules Foreign.CUDA.Cublas and Foreign.CUDA.Cusparse are probably the most useful.

Requires CUDA version 6.5.

If you have trouble installing this package, it may help to view the Github page: http://github.com/bmsherman/cublas

Versions [RSS] [faq] 0.2.0.0, 0.2.0.1, 0.2.0.2, 0.2.1.0, 0.3.0.0, 0.4.0.0, 0.4.0.1, 0.5.0.0, 0.6.0.0 (info)
Dependencies base (>=4.4 && <4.8), cuda (>=0.4.1 && <0.8), filepath (==1.3.*), language-c (>=0.4.2 && <0.5), storable-complex (>=0.2.1 && <0.3), template-haskell (>=2.7 && <2.10) [details]
License BSD-3-Clause
Copyright Copyright (c) [2012..2014]. Trevor L. McDonell <tmcdonell@cse.unsw.edu.au>, Ben Sherman <benmsherman@gmail.com>
Author Trevor L. McDonell, Ben Sherman
Maintainer Ben Sherman <benmsherman@gmail.com>
Revised Revision 1 made by bmsherman at 2017-03-31T20:53:12Z
Category Foreign
Home page https://github.com/bmsherman/cublas
Source repo head: git clone git://github.com/bmsherman/cublas.git
this: git clone git://github.com/bmsherman/cublas/releases/tag/0.2.1.0.git(tag 0.2.1.0)
Uploaded by bmsherman at 2014-12-17T16:22:05Z
Distributions NixOS:0.6.0.0, Stackage:0.6.0.0
Downloads 5769 total (37 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs uploaded by user [build log]
All reported builds failed as of 2015-12-12 [all 1 reports]

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees

Candidates