fltkhs: FLTK bindings

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain] [Publish]

Low level bindings for the FLTK GUI toolkit.


[Skip to Readme]

Properties

Versions 0.1.0.0, 0.1.0.0, 0.1.0.1, 0.1.0.2, 0.2.0.0, 0.2.0.1, 0.2.0.2, 0.3.0.0, 0.3.0.1, 0.4.0.0, 0.4.0.1, 0.4.0.2, 0.4.0.3, 0.4.0.4, 0.4.0.5, 0.4.0.6, 0.4.0.7, 0.4.0.8, 0.4.0.9, 0.4.1.0, 0.5.0.0, 0.5.0.1, 0.5.0.2, 0.5.0.3, 0.5.0.4, 0.5.0.5, 0.5.0.6, 0.5.0.7, 0.5.0.8, 0.5.0.9, 0.5.1.0, 0.5.1.1, 0.5.1.2, 0.5.1.3, 0.5.1.4, 0.5.1.5, 0.5.1.6, 0.5.1.7, 0.5.1.8, 0.5.1.9, 0.5.2.0, 0.5.2.1, 0.5.2.2, 0.5.2.3, 0.5.2.4, 0.5.2.5, 0.5.2.6, 0.5.2.7, 0.5.2.8, 0.5.2.9, 0.5.3.0, 0.5.3.1, 0.5.3.2, 0.5.3.3, 0.5.3.4, 0.5.3.5, 0.5.3.6, 0.5.3.7, 0.5.3.8, 0.5.3.9, 0.5.4.0, 0.5.4.1, 0.5.4.2, 0.5.4.3, 0.5.4.4, 0.5.4.5, 0.6.0.0, 0.7.0.0, 0.7.0.1, 0.7.0.2, 0.7.0.3, 0.7.0.4, 0.8.0.0, 0.8.0.1, 0.8.0.2, 0.8.0.3
Change log None available
Dependencies base (==4.*), bytestring, fltkhs, process [details]
License MIT
Author Aditya Siram
Maintainer aditya.siram@gmail.com
Category UI, Graphics
Home page http://github.com/deech/fltkhs
Source repo head: git clone http://github.com/deech/fltkhs
Uploaded by deech at 2015-02-21T01:57:52Z

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees


Readme for fltkhs-0.1.0.0

[back to package description]

Fltkhs - A Haskell Binding to the FLTK GUI Library

Fltkhs aims to be a complete Haskell binding to the [FLTK GUI library] 1.

The rest of the documentation (including installation instructions and usage) is located in src/Examples/Graphics/UI/LowLevel/FLTK/FLTKHS.hs. This is the primary module that needs to be imported by every Fltkhs app and the entry point into the application.

This package does not yet install on Windows.

Abbreviated installation instructions are reproduced here:

    > ./configure
    > make
    > make install
    > git clone https://github.com/deech/fltkhs
    cabal install