Metadata revisions for ghc-mod-5.2.0.0

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User Changes
-r2 Sun Oct 30 21:47:46 UTC 2016 DanielG
  • Changed the library component's library dependency on 'base' from

    >=4.0 && <5
    to
    <5 && >=4.0

  • Changed the library component's library dependency on 'djinn-ghc' from

    >=0.0.2.2
    to
    <0.1 && >=0.0.2.2

  • Changed the library component's library dependency on 'ghc' from

    >=7.4 && <7.10
    to
    <7.10 && >=7.4

  • Changed the library component's library dependency on 'ghc-paths' from

    -any
    to
    <0.2 && >=0.1.0.9

  • Changed the library component's library dependency on 'ghc-syb-utils' from

    -any
    to
    <0.3 && >=0.2.2

  • Changed the library component's library dependency on 'haskell-src-exts' from

    -any
    to
    <1.17 && >=1.16.0

  • Changed the library component's library dependency on 'hlint' from

    >=1.8.61
    to
    <1.9 && >=1.8.61

  • Changed the library component's library dependency on 'io-choice' from

    -any
    to
    <0.1 && >=0.0.5

  • Changed the library component's library dependency on 'monad-control' from

    -any
    to
    <0.4 && >=0.3.3.0

  • Changed the library component's library dependency on 'monad-journal' from

    >=0.4
    to
    <0.5 && >=0.4

  • Changed the library component's library dependency on 'mtl' from

    >=2.0
    to
    <2.1 && >=2.0

  • Changed the library component's library dependency on 'split' from

    -any
    to
    <0.3 && >=0.2.2

  • Changed the library component's library dependency on 'syb' from

    -any
    to
    <0.5 && >=0.4.2

  • Changed the library component's library dependency on 'temporary' from

    -any
    to
    <1.3 && >=1.2.0.3

  • Changed the library component's library dependency on 'text' from

    -any
    to
    <1.3 && >=1.2.0.0

  • Changed the library component's library dependency on 'transformers-base' from

    -any
    to
    <0.5 && >=0.4.3

  • Changed the library component's library dependency on 'Cabal' from

    >=1.18
    to
    <1.20 && >=1.18

  • Changed the library component's library dependency on 'Cabal' from

    >=1.10 && <1.17
    to
    <1.17 && >=1.10

  • Changed the library component's library dependency on 'convertible' from

    -any
    to
    <1.2 && >=1.1.0.0

  • Changed the executable 'ghc-mod' component's library dependency on 'base' from

    >=4.0 && <5
    to
    <5 && >=4.0

  • Changed the executable 'ghc-mod' component's library dependency on 'data-default' from

    -any
    to
    <0.6 && >=0.5.3

  • Changed the executable 'ghc-modi' component's library dependency on 'async' from

    -any
    to
    <2.1 && >=2.0.1.6

  • Changed the executable 'ghc-modi' component's library dependency on 'base' from

    >=4.0 && <5
    to
    <5 && >=4.0

  • Changed the executable 'ghc-modi' component's library dependency on 'ghc' from

    >=7.4 && <7.10
    to
    <7.10 && >=7.4

  • Changed the executable 'ghc-modi' component's library dependency on 'split' from

    -any
    to
    <0.3 && >=0.2.2

  • Changed the test suite 'doctest' component's library dependency on 'base' from

    -any
    to
    <5 && >=4.0

  • Changed the test suite 'doctest' component's library dependency on 'doctest' from

    >=0.9.3
    to
    <0.10 && >=0.9.3

  • Changed the test suite 'spec' component's library dependency on 'base' from

    >=4.0 && <5
    to
    <5 && >=4.0

  • Changed the test suite 'spec' component's library dependency on 'djinn-ghc' from

    >=0.0.2.2
    to
    <0.1 && >=0.0.2.2

  • Changed the test suite 'spec' component's library dependency on 'ghc' from

    >=7.4 && <7.10
    to
    <7.10 && >=7.4

  • Changed the test suite 'spec' component's library dependency on 'ghc-paths' from

    -any
    to
    <0.2 && >=0.1.0.9

  • Changed the test suite 'spec' component's library dependency on 'ghc-syb-utils' from

    -any
    to
    <0.3 && >=0.2.2

  • Changed the test suite 'spec' component's library dependency on 'haskell-src-exts' from

    -any
    to
    <1.17 && >=1.16.0

  • Changed the test suite 'spec' component's library dependency on 'hlint' from

    >=1.7.1
    to
    <1.9 && >=1.8.61

  • Changed the test suite 'spec' component's library dependency on 'hspec' from

    >=1.8.2
    to
    <1.9 && >=1.8.2

  • Changed the test suite 'spec' component's library dependency on 'io-choice' from

    -any
    to
    <0.1 && >=0.0.5

  • Changed the test suite 'spec' component's library dependency on 'monad-control' from

    -any
    to
    <0.4 && >=0.3.3.0

  • Changed the test suite 'spec' component's library dependency on 'monad-journal' from

    >=0.4
    to
    <0.5 && >=0.4

  • Changed the test suite 'spec' component's library dependency on 'mtl' from

    >=2.0
    to
    <2.1 && >=2.0

  • Changed the test suite 'spec' component's library dependency on 'split' from

    -any
    to
    <0.3 && >=0.2.2

  • Changed the test suite 'spec' component's library dependency on 'syb' from

    -any
    to
    <0.5 && >=0.4.2

  • Changed the test suite 'spec' component's library dependency on 'temporary' from

    -any
    to
    <1.3 && >=1.2.0.3

  • Changed the test suite 'spec' component's library dependency on 'text' from

    -any
    to
    <1.3 && >=1.2.0.0

  • Changed the test suite 'spec' component's library dependency on 'transformers-base' from

    -any
    to
    <0.5 && >=0.4.3

  • Changed the test suite 'spec' component's library dependency on 'Cabal' from

    >=1.18
    to
    <1.20 && >=1.18

  • Changed the test suite 'spec' component's library dependency on 'Cabal' from

    >=1.10 && <1.17
    to
    <1.17 && >=1.10

  • Changed the test suite 'spec' component's library dependency on 'convertible' from

    -any
    to
    <1.2 && >=1.1.0.0

  • Changed the test suite 'spec' component's library dependency on 'executable-path' from

    -any
    to
    <0.1 && >=0.0.3

-r1 Tue May 24 08:52:28 UTC 2016 DanielG
-r0 Thu Oct 30 17:46:04 UTC 2014 DanielG