ghcjs-dom: DOM library that supports both GHCJS and WebKitGTK

[ library, mit, web ] [ Propose Tags ]

Documentent Object Model (DOM) functions that work with GHCJS, but can also be used with GHC and WebKitGTK.

Versions 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.6, 0.0.7, 0.0.8, 0.0.9, 0.0.10, 0.1.0.0, 0.1.1.0, 0.1.1.1, 0.1.1.2, 0.1.1.3, 0.2.1.0, 0.2.2.0, 0.2.3.0, 0.2.3.1, 0.2.4.0, 0.3.0.1, 0.3.1.0, 0.4.0.0, 0.4.1.0, 0.4.1.1, 0.5.0.0, 0.5.0.1, 0.5.0.2, 0.6.0.0, 0.7.0.0, 0.7.0.1, 0.7.0.2, 0.7.0.3, 0.7.0.4, 0.7.1.0, 0.8.0.0, 0.9.0.0, 0.9.1.0, 0.9.1.1, 0.9.2.0
Dependencies base (<5), ghcjs-base, glib (>=0.13.0.0 && <0.14), gtk (>=0.13.0.0 && <0.14), gtk3 (>=0.13.0.0 && <0.14), mtl, text (>=0.11.0.6 && <1.2), transformers (>=0.3.0.0 && <0.5), webkit (>=0.13.0.0 && <0.14), webkitgtk3 (>=0.13.0.0 && <0.14) [details]
License MIT
Author Hamish Mackenzie
Maintainer Hamish Mackenzie <Hamish.K.Mackenzie@googlemail.com>
Category Web
Source repo head: git clone https://github.com/ghcjs/ghcjs-dom
Uploaded by HamishMackenzie at Sun Sep 21 14:37:37 UTC 2014
Distributions NixOS:0.9.2.0
Downloads 13615 total (251 in the last 30 days)
Rating 2.25 (votes: 2) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

Modules

[Index]

Flags

NameDescriptionDefaultType
ghcjs

Tell cabal we are using ghcjs (work around until hackage supports impl(ghcjs))

EnabledAutomatic
jsffi

Use JavaScriptFFI extension for GHCJS JavaScript output

EnabledAutomatic
webkit

Use WebKitGtk DOM functions

DisabledAutomatic
jsc

Use WebKitGtk JavaScriptCore

DisabledAutomatic
gtk3

Use GTK3 rather than GTK2 (only matters when using webkit)

EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees